Jump to content
Sign in to follow this  
fairleas

Using the Dream Rig for Wet/Dry.

Recommended Posts

Hi all. I'm currently playing with using my JTV59 and HD500X into my Soundsource and DT25 in a wet/dry set up. All connected via the L6 Link. The dry side is the DT25 and the wet side is the Soundsource. This means compressors, overdrives and FX loop before the split and all the other effects in side B after an appropriate amp. The mixer at the end is used to pan the two signal paths hard left and right into the two different physical amps.

I'm having trouble (to my ears) with getting an amp model in the dry side that sounds as good as the DT25 does on its own. I've turned off cab sims and just used the pre amp versions of the amps but it seems to lack something.

Any ideas on what I'm probably doing wrong? Should I just disable the amp model on the HD500 and just use its built in tones? I have the V2 software in there and have MIDI control of the assorted parameters.

Thanks.

John

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...