Jump to content

HX Effects Update Failure


jnix01
 Share

Recommended Posts

SO... just got a new HX Effects unit. Following the instructions in the manual, I downloaded the HX Edit software and tried to update the firmware with the Updater software.

The update failed, and now the unit wont boot back up. I have searched this forum and found many examples of the same situation and followed all of the recommendations. I have unloaded and re-loaded the software, and tried every USB port on my computer, but the software always fails.

I get a boot error when I turn the unit on... so I hold the right arrow while turning it on, and the unit comes on with nothing in the display at all. I run the installer, and have to select "unidentified HX effects unit"... it isn't recognizing the firmware on the unit. The installer starts, and the unit displays "updating". (so it must at least be actually connecting to the unit... right?) It runs for about 30 seconds or so, and then I get the error message that tells me to re-try the installation, try different USB ports, etc.

So here I am, on Thanksgiving day, knowing that Line 6 support won't be back until Monday, and I have a $600 boat anchor. I intended on spending the holiday setting up pre-sets, and now the damn thing won't even boot up.. I could not be less pleased. This should not be that complicated, and Line 6 should not sell equipment that malfunctions so easily. For it to work fine out of the box, and then fail completely when I follow the instructions for updating the firmware is unacceptable.

 

I can't even do a factory reset... pressing FS6 and TAP at the same time does nothing... (of course, the footswitches aren't actually numbered, and I don't see anywhere in the manual where it actually identifies exactly WHICH switch is #6... but I've tried them all anyway, so...).

 

SOOO... does anyone have any ideas on what to do now?

Link to comment
Share on other sites

OK... as a follow up. I finally got it to work. Why did it require finding a YouTube video to solve the problem? 

Anyway, after uninstalling and re-installing the software 3 times, and trying just about every possible way of hooking things up, I saw on a YT video where a guy said you need to disconnect the unit from the USB port on your computer, THEN turn the unit off and back on, and THEN connect to the USB port on the computer. Tried it in exactly that sequence and what da ya know... it worked. Is it really that complicated? SMDH!

Link to comment
Share on other sites

On 11/26/2020 at 7:59 PM, jnix01 said:

SO... just got a new HX Effects unit. Following the instructions in the manual, I downloaded the HX Edit software and tried to update the firmware with the Updater software.

The update failed, and now the unit wont boot back up. I have searched this forum and found many examples of the same situation and followed all of the recommendations. I have unloaded and re-loaded the software, and tried every USB port on my computer, but the software always fails.

I get a boot error when I turn the unit on... so I hold the right arrow while turning it on, and the unit comes on with nothing in the display at all. I run the installer, and have to select "unidentified HX effects unit"... it isn't recognizing the firmware on the unit. The installer starts, and the unit displays "updating". (so it must at least be actually connecting to the unit... right?) It runs for about 30 seconds or so, and then I get the error message that tells me to re-try the installation, try different USB ports, etc.

So here I am, on Thanksgiving day, knowing that Line 6 support won't be back until Monday, and I have a $600 boat anchor. I intended on spending the holiday setting up pre-sets, and now the damn thing won't even boot up.. I could not be less pleased. This should not be that complicated, and Line 6 should not sell equipment that malfunctions so easily. For it to work fine out of the box, and then fail completely when I follow the instructions for updating the firmware is unacceptable.

 

I can't even do a factory reset... pressing FS6 and TAP at the same time does nothing... (of course, the footswitches aren't actually numbered, and I don't see anywhere in the manual where it actually identifies exactly WHICH switch is #6... but I've tried them all anyway, so...).

 

SOOO... does anyone have any ideas on what to do now?

Hey I think I have exactly the same problem as you. I also did everything the instruction says. The only difference is that mine is HX stomp. Having played with the HX stomp for two days and expecting to get the newest functions but now it just turns into a brick. It's really frustrating! I start to consider returning it...

7 hours ago, jnix01 said:

OK... as a follow up. I finally got it to work. Why did it require finding a YouTube video to solve the problem? 

Anyway, after uninstalling and re-installing the software 3 times, and trying just about every possible way of hooking things up, I saw on a YT video where a guy said you need to disconnect the unit from the USB port on your computer, THEN turn the unit off and back on, and THEN connect to the USB port on the computer. Tried it in exactly that sequence and what da ya know... it worked. Is it really that complicated? SMDH!

Could you plz share the YT video? I did the same but the update still failed. Maybe I missed something.

Link to comment
Share on other sites

Well... I'm definitely not surprised... the thought occurred to me that maybe it is just so temperamental, that it could have been anything that I did differently. I tried so many different things. 

I think this is the video that I watched... not 100% sure though, as I spent hours looking for a solution. This video was for a Helix, not an HX effects, but I think its all the same problem.

 

The exact sequence that worked for me was:

1) Uninstall all of the software (completely) and re-install it.

2) Reboot the computer

3) Boot the HX Effects in update mode

4) Connect the USB to the computer.

5) Run the installer software

 

When it worked for me, I had disconnected my audio speakers from the USB port they were connected to on the back of my computer, and used that port... I guess that is something different. I had tried that port before (I tried every usb port on my computer), but not following the above sequence. So that might have had something to do with it as well... either that specific port or the fact that my audio speakers were disconnected... or both... who knows. Anyway, Good Luck. When it does finally work, the 3.0 upgrade is very nice. 

Link to comment
Share on other sites

15 hours ago, Ckathy said:

did the same but the update still failed. Maybe I missed something.

 

Hi,

 

This is the official Line 6 word on how to fix a failed install which was posted in the Knowledge Base section of these forums.

 

IMPORTANT! In the unlikely event that your update fails, please follow the steps below:

  1. Unplug the USB cable from both the back of your Helix and the computer.
  2. Turn your Helix/HX device off and on.
  3. Reconnect the USB cable to your Helix/HX device and the computer.
  4. Download, install, and launch the latest version of Line 6 Updater. In a failure state, the device will not connect to HX Edit.
  5. Select your device and try updating to the latest firmware again.
    • If the device does not show up in Line 6 Updater after these steps, try a different USB cable and/or USB port.
    • If it still doesn't show up, try a different computer.


This is the full set of instructions.


Hope this help/makes sense.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...