Jump to content

Red screen, black bean and nothing


Recommended Posts

Hi guys,


My new POD GO came in today. Unpacked the box and plugged it in. Nothing happens except what you see on the picture.

Tried C+D pushed in for more than 20 seconds and power on

The same with buttons A+B

Installed POD GO Edit and page -> pushing while firing up. Nothing. 

POD GO edit says nothing is connected.

Now I'm outa options. Hopefully someone can help me? Sending it back is not what I'm happy with.....


Link to comment
Share on other sites

Good times...   Pretty amazing you got a unit which was dead on arrival.  Where did you purchase it from?   I'm guessing someone bought the Go, tried to update its firmware, it bricked the unit, then the customer returned it, and the shop just sold it to you as if it was a brand new unit.  It's either that, or Line6 has ZERO QA and they're shipping 'dead' units lol  which I doubt...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...