Jump to content

Pod go 1.21 download


conradmarshall
 Share

Recommended Posts

What version of Pod Go Edit did you originally have installed on your Mac?  

 

Did you get the link from the official page here - if so, are you upgrading from v1.11?  If you had an earlier version of Pod Go Edit installed (or no Pod Go Edit installed) then you need to install v1.11 first, and THEN upgrade to v1.21 - you can't upgrade straight from eg v1.01 Pod Go Edit (or no installation) to v1.21.  I'm guessing the downloader has possibly detected you weren't on v1.11 and is taking you through that upgrade first.  Thereafter, you need to repeat the process and v1.21 should then be installed: 

?

Link to comment
Share on other sites

28 minutes ago, voxman55 said:

What version of Pod Go Edit did you originally have installed on your Mac?  

 

Did you get the link from the official page here - if so, are you upgrading from v1.11?  If you had an earlier version of Pod Go Edit installed (or no Pod Go Edit installed) then you need to install v1.11 first, and THEN upgrade to v1.21 - you can't upgrade straight from eg v1.01 Pod Go Edit (or no installation) to v1.21.  I'm guessing the downloader has possibly detected you weren't on v1.11 and is taking you through that upgrade first.  Thereafter, you need to repeat the process and v1.21 should then be installed: 

?

Interesting. I’m not aware that v1.21 requires an earlier installation. The official info you provided in the link doesn’t mention that. Did you have some experience with that?

Link to comment
Share on other sites

Hi @silverhead - not personally, but it's based on my best understanding from another forum where similar issues were reported.  I stand to be corrected here of course, but the Line 6 instructions say "How do I update to 1.21?" which would seem to indicate you have to have a previous installation to update from. So I think the 'given' from Line 6 might be that you will always be updating from the very last Pod Go Edit version, and not an earlier version.  I think it's just how the updates are designed i.e. on a 'layered' installation basis which I've seen before on some other program/application upgrades.    

 

One thing that was different after upgrading from v1.11 to v1.21 (my PC is Windows 7, 64 bit) is that, following an alert to do so on my PC, I had to reboot my computer ( not mentioned in the installation notes) before seeing the new models.  And I think that's been found by others too, both on PC and MACs.  So v1.21 wasn't quite the same as previous upgrades - but that's possibly because those were only 'bug fixes' and this was the first proper upgrade.  

 

BTW, I found a bug (reported to & confirmed by L6 support) on Pod Go Edit v1.21 re the Acoustic Simulator - it has no 'x' delete button in Pod Go Edit. To delete it you have to replace it with an EQ (or any other effect) and then delete that effect. I think there might be one or two other bugs spotted by others & reported, in addition to 'known bugs' in the above notes, so hopefully Line 6 will tidy these up next time round. 

  • Thanks 1
Link to comment
Share on other sites

7 hours ago, voxman55 said:

What version of Pod Go Edit did you originally have installed on your Mac?  

 

Did you get the link from the official page here - if so, are you upgrading from v1.11?  If you had an earlier version of Pod Go Edit installed (or no Pod Go Edit installed) then you need to install v1.11 first, and THEN upgrade to v1.21 - you can't upgrade straight from eg v1.01 Pod Go Edit (or no installation) to v1.21.  I'm guessing the downloader has possibly detected you weren't on v1.11 and is taking you through that upgrade first.  Thereafter, you need to repeat the process and v1.21 should then be installed: 

?


 

that’s it! Superb! Thanks a lot!! When the update failed the first time, i deleted the pod go edit and from then on it wouldnt update to 1.21 until i reinstalled the 1.1... 

  • Like 1
Link to comment
Share on other sites

2 hours ago, conradmarshall said:


 

that’s it! Superb! Thanks a lot!! When the update failed the first time, i deleted the pod go edit and from then on it wouldnt update to 1.21 until i reinstalled the 1.1... 

In the words of Hannibal Hayes from the A Team 'I love it when a plan comes together!'.  Glad you got it working. 

Link to comment
Share on other sites

  • 3 weeks later...

hey...successfully downloaded and installed v1.10, then v1.11.  Both were signed by Yamaha/Line6.  Then tried downloading v1.21 (not signed!) and the installed failed with an NSIS error (integrity check??).  All of this was after turning off Smart Screen and other Win 10 protections...

 

Any ideas about getting around this?  Thanks...

Link to comment
Share on other sites

You only needed v1.11 but no matter. You also should only update Pod Go via Pod Go Edit as its the most stable way to upgrade your Pod Go.  Have you installed Pod Go Edit v1.21? If not do this first and then upgrade your Pod Go via Pod Go Edit v1.21, not from any other Line 6 installer. You may also need to reboot your PC before you see the new models. 

Link to comment
Share on other sites

7 hours ago, voxman55 said:

You only needed v1.11 but no matter. You also should only update Pod Go via Pod Go Edit as its the most stable way to upgrade your Pod Go.  Have you installed Pod Go Edit v1.21? If not do this first and then upgrade your Pod Go via Pod Go Edit v1.21, not from any other Line 6 installer. You may also need to reboot your PC before you see the new models. 

 

thanks for your quick reply!  but I AM talking about Pod Go Edit v1.21!  it will NOT install...doesn't even get started... fails with an NSIS error (and msg regarding integrity check). No such problems with earlier versions of PG Edit.  I'm sure I can't be the only one having this problem...

Link to comment
Share on other sites

4 hours ago, jlh777a0 said:

 

thanks for your quick reply!  but I AM talking about Pod Go Edit v1.21!  it will NOT install...doesn't even get started... fails with an NSIS error (and msg regarding integrity check). No such problems with earlier versions of PG Edit.  I'm sure I can't be the only one having this problem...

There do seem to have been some problems reported by quite a few folk on this upgrade which appears to be a bit 'touchy' for Windows 10 and Macs. 

 

You might try completely uninstalling Pod Go Edit and reinstalling v1.1 and then reinstalling v1.21.

 

If this doesn't work, I'd suggest you raise a ticket with Line 6 to see if they can sort for you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...