Jump to content
AgFx

"Target is incompatible" on preset import

Recommended Posts

Hi,

 

I just did a backup, updated my HX Stomp to 3.11, and did a switch 2+3 reset. So far, so good, no problems.

 

I extracted the presets from the backup with that handy-dandy function in HX Edit, and wanted to import specific presets back in. But I get this message:

 

HX Edit was unable to import presets in this set due to following errors:

-8103 - Target is incompatible.

 

Anybody any clue what's going on?

 

Here's one of the presets:

Preset100-Ian's P.Y.T..hlx

  • Thanks 1

Share this post


Link to post
Share on other sites
5 hours ago, AgFx said:

Hi,

 

I just did a backup, updated my HX Stomp to 3.11, and did a switch 2+3 reset. So far, so good, no problems.

 

I extracted the presets from the backup with that handy-dandy function in HX Edit, and wanted to import specific presets back in. But I get this message:

 

HX Edit was unable to import presets in this set due to following errors:

-8103 - Target is incompatible.

 

Anybody any clue what's going on?

 

Here's one of the presets:

Preset100-Ian's P.Y.T..hlx 5.84 kB · 0 downloads

 

I think you have found a legitimate bug in the 'Extract Files From Backup' command. I am able to recreate this exact message when I attempt to import files created with this command. You should open a ticket with Line6.  This utility is still clearly buggy but holds great potential. I listed a couple of more minor bugs I found in the bugs topic already but this one is a showstopper.

 

Until Line6 fixes it I would encourage those who make backups of their setlists or presets to keep using HX Edit's old export functions until this utility is dependable.

 

Update: I have opened a ticket with Line6 on this bug and the others I found previously but the more the merrier(tickets opened that is, not bugs).

  • Upvote 1

Share this post


Link to post
Share on other sites

Oooh darn. I don't think I have other exports of my presets... *cries*

Share this post


Link to post
Share on other sites
6 minutes ago, AgFx said:

Oooh darn. I don't think I have other exports of my presets... *cries*

 

Hope you are kidding. I hear you though. It is always dangerous for a piece of software to have a backup or extraction function that does not work as people mistakenly think they have a dependable backup when they actually don't. Better in my opinion to pull it out of HX Edit until it works properly.

 

You should at least have the backup you extracted from. That will have all your setlists which can always be loaded and the presets sifted through using the old functionality. Sincerely hoping Line6 will fix this utility soon and definitely by the next firmware update.

Share this post


Link to post
Share on other sites

Hmm, that remark about the bug got me thinking. I've analysed the JSON structure that is generated from the exports (yay for Line6 making it a human readable format!)

This one is what is exported from the backup:

 

{
  "meta" : {
    "name" : "Ian's P.Y.T.",
    "build_sha" : "v2.92-565-g021787c"
  },
  "device" : 2162694,
  "tone" : {
       ... etc
    }
  },
  "device_version" : 50397184
}

But an export from HX Edit looks like this:

{
  "data" : {
    "meta" : {
      "name" : "Ian's P.Y.T.",
      "application" : "HX Edit",
      "build_sha" : "v2.92-565-g021787c",
      "modifieddate" : 1617105498,
      "appversion" : 50397184
    },
    "device" : 2162694,
    "tone" : {
       ... etc
    },
    "device_version" : 50397184
  },
  "meta" : {
    "original" : 0,
    "pbn" : 0,
    "premium" : 0
  },
  "schema" : "L6Preset",
  "version" : 6
}

There is quite obviously a structure difference. I think I can get my backup exports working if I convert the top version to the bottom version. I'll check that.

  • Upvote 1

Share this post


Link to post
Share on other sites
31 minutes ago, AgFx said:

Yep, that worked.

 

 

Well done sir!  Glad you checked the "Helix Bug Reports" topic where I posted that.

Share this post


Link to post
Share on other sites

Does it work on a backup taken after update? 

Bit long winded, I know, but a workaround might be to reinstall previous backups, and then 're' backup, maybe using their old file names to force them to overwrite the originals?

At this point, my own preference is to export my preset anytime I press 'Save' on the Helix... Is this an issue with old preset files, too, or just extracted files - sorry, I haven't had my Helix long enough to build up a 'history' of files.

 

Share this post


Link to post
Share on other sites
12 hours ago, somebodyelse said:

Does it work on a backup taken after update? 

Bit long winded, I know, but a workaround might be to reinstall previous backups, and then 're' backup, maybe using their old file names to force them to overwrite the originals?

At this point, my own preference is to export my preset anytime I press 'Save' on the Helix... Is this an issue with old preset files, too, or just extracted files - sorry, I haven't had my Helix long enough to build up a 'history' of files.

 

 

The 'Extract Files From Backup' command is still buggy, even if run on backups created after the latest firmware(HX Edit 3.10 & firmware 3.11). The backups work fine, just not the files yielded by the extraction command.  In the interest of not generating any confusion, I am not referring to the 'Create Backup', 'Restore From Backup' or any of the old export/import functions in the HX Edit librarian section.  Only the "Extract..." command.

Share this post


Link to post
Share on other sites
2 hours ago, HonestOpinion said:

 

No, it is still buggy on backups taken after the latest update.


Hi,

 

To clarify - this issue is only when extracting presets from the backup - yes?
 

It’s not something that I have tried, or needed to do, as I keep a folder full of individual presets, set lists, and fail safe bundles simply for ease of re-arranging presets as I need them.

 

The backup bundle file made before the update, containing the Globals etc., worked just fine and restored to my Helix with out any problems.
 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, datacommando said:


Hi,

 

To clarify - this issue is only when extracting presets from the backup - yes?
 

It’s not something that I have tried, or needed to do, as I keep a folder full of individual presets, set lists, and fail safe bundles simply for ease of re-arranging presets as I need them.

 

The backup bundle file made before the update, containing the Globals etc., worked just fine and restored to my Helix with out any problems.
 

 

 

 

Yes, this issue is only when extracting presets from the backup with the 'Extract Files From Backup' command. All other backup/restore and import/export operations continue to work and are the same "as it ever was" as far as I know. I can see where my original comment might cause confusion. I edited it to make it hopefully clearer. 

  • Upvote 1

Share this post


Link to post
Share on other sites
16 hours ago, HonestOpinion said:

 

The 'Extract Files From Backup' command is still buggy, even if run on backups created after the latest firmware(HX Edit 3.10 & firmware 3.11). The backups work fine, just not the files yielded by the extraction command.  In the interest of not generating any confusion, I am not referring to the 'Create Backup', 'Restore From Backup' or any of the old export/import functions in the HX Edit librarian section.  Only the "Extract..." command.

Thanks,

Yes, I was aware that the backups restore fine. Wondered if the bug was the 'extraction of' rather than the conversion to the new structure.

My question now would be, how far back do backups restore from? Is there a point from which previous backups can't be 'translated. ie. can a backup from, say, v2.00 firmware still be restored?

Again, apologies for the stupid questions, I only go back as far as v3.01.  

  • Upvote 1

Share this post


Link to post
Share on other sites
10 hours ago, somebodyelse said:

Thanks,

Yes, I was aware that the backups restore fine. Wondered if the bug was the 'extraction of' rather than the conversion to the new structure.

My question now would be, how far back do backups restore from? Is there a point from which previous backups can't be 'translated. ie. can a backup from, say, v2.00 firmware still be restored?

Again, apologies for the stupid questions, I only go back as far as v3.01.  

 

None of these are stupid questions, they all sound relevant to me. I would say the problem is the format of the files after extraction, rather than the import/conversion but it could be either/both.  It makes more sense to me that Line6 would not want to dedicate development resources to two conversion/import paths, one for exported presets and one for extracted. So you would think the preset file should be the same or close enough in format whether it is created with the "Extract.." command or by an Export command to be "import ready". 

 

Regarding how old a backup it will work on will be difficult to answer with confidence until they fix the utility so that the extractions can be properly loaded afterwards. I suspect it will be able to extract from most any firmware version's backups, but I guess that depends on how dissimilar the oldest firmware's backups' formats are to the current format. I would hope the Extract utility operates in a manner similar to the way the Import command can still import even old CustomTone presets as well as old setlist/preset backups from early firmware versions.  I guess more experimentation with this utility will answer your questions definitively.  Will be interesting to test once they fix it.

Share this post


Link to post
Share on other sites

I just ran the extract on one of my backups made with HX Edit 2.30 back in 2017.  HX Edit 2.30 was the first editor version to offer the 'Create Backup' command which resulted in a file with the "hxb" extension and format required for the Extract command. All the presets from that backup seem to have been successfully extracted. They just still can't be imported due to the current bug with the extracted files' format(-8103 - Target is incompatible).  So... looks like the extract should work with any backup made since the advent of the 'Create Backup' command. 

 

Wouldn't be surprised if you could find a way to edit the old "bundles" too, which were the format used for backups in the early versions of the editor prior to 2.30, or even old setlist backups and prepare them for the Extract command but it might be more effort than just parsing them for the presets yourself.

  • Upvote 3

Share this post


Link to post
Share on other sites

Thanks... what I was actually pondering is can all backups be restored or is there a cut off point where they can't be updated/rebuilt, during restore.

In terms of editing the old 'Extractions', can they be opened in Helix Native, with compatibility mode off? 

Also, may have been mentioned already, is there a pattern to which extracted presets are corrupte- eg. every 12th preset, every preset with a certain effect,...?

Share this post


Link to post
Share on other sites
1 hour ago, somebodyelse said:

Thanks... what I was actually pondering is can all backups be restored or is there a cut off point where they can't be updated/rebuilt, during restore.

 

So far with the exception of the odd preset that is corrupt or perhaps a firmware that left something out that impacted a specific parameter of a certain effect, all of the old presets and setlists have stayed compatible with every firmware revision and editor version up to the current day.  Congrats to Line6 for keeping restores backwards compatible.

 

1 hour ago, somebodyelse said:

In terms of editing the old 'Extractions', can they be opened in Helix Native, with compatibility mode off? 

 

No. Whether extracted from an old or new backup you get the same error message when you try to open an "Extracted" preset with Native that you get with the Helix - "8103 - Target is incompatible.".

 

1 hour ago, somebodyelse said:

Also, may have been mentioned already, is there a pattern to which extracted presets are corrupte- eg. every 12th preset, every preset with a certain effect,...?

 

There may be a pattern but I don't think so.  So far when using the files produced by the "Extract Files From Bakcup" command, every preset seems to fail on import, even blank "New Preset"s. Have not tested them all obviously.

Share this post


Link to post
Share on other sites
On 5/3/2021 at 10:07 PM, HonestOpinion said:

 

 

Well done sir!  Glad you checked the "Helix Bug Reports" topic where I posted that.

 

Um, yeah, about that. It's a large thread and I didn't have time to go through the full thing. So no, I didn't check it... :-)

Share this post


Link to post
Share on other sites
6 hours ago, somebodyelse said:

Thanks... what I was actually pondering is can all backups be restored or is there a cut off point where they can't be updated/rebuilt, during restore.

In terms of editing the old 'Extractions', can they be opened in Helix Native, with compatibility mode off? 

Also, may have been mentioned already, is there a pattern to which extracted presets are corrupte- eg. every 12th preset, every preset with a certain effect,...?

 

I'm pretty sure it's not a corruption issue, but simply a compatibility one. Both the old and new structures look completely fine, but there are such differences that I can understand that the newer software doesn't understand the old format. For instance, in the hierarchical structure of the new format some things are now embedded in a "data" node that wasn't there before.

 

I think it's a simple case that the programmers of HX Edit have changed the structure of the regular exports, but they have not updated the structure of the backup export to match.

 

Having been a programmer for many years I could create a Python script that can do a simple syntactical conversion on the old backup format files to the current format, but I have no idea if 1) the HX community is generally comfortable with running scripts like these, 2) if there's not already a fix underway from Line6, and 3) if this is even a common issue at all for most users.

  • Upvote 1

Share this post


Link to post
Share on other sites
5 hours ago, AgFx said:

 

Um, yeah, about that. It's a large thread and I didn't have time to go through the full thing. So no, I didn't check it... :-)

 

LOL, War & Peace at this point. Best to stick to the most recent posts.

Share this post


Link to post
Share on other sites
5 hours ago, AgFx said:

 

... but I have no idea if 1) the HX community is generally comfortable with running scripts like these, 2) if there's not already a fix underway from Line6, and 3) if this is even a common issue at all for most users.

 

Agree with all of this.  I suspect very few users have played with this command yet although I think it could be well used in the future.  I plan to just wait and see if it gets fixed in the next firmware update.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...