Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Line 6 POD GO Firmware Update Failure - SOLVED


jswoveland
 Share

Recommended Posts

This post explains one cause of firmware updates/recoveries failing for the Line 6 POD Go. Hope this can help someone. 

TLDR: prior to updating firmware, shutdown any and all applications that could conceivably use audio. 

I rented a POD GO a couple of days ago, and the firmware was still at 1.40.1, so soon as I connected to POD GO Edit, it prompted me to update it to 2.0. Unfortunately the firmware update failed. POD Go Edit said it "updated successfully", but the screen on the POD GO device itself just continued to say "Updating..".  I'm a software developer, and I know interrupting a firmware update is a big no no, so I went away and came back 30 minutes later. It was still stuck on "Updating..". At this point I sighed, turned the unit off and on, and it wouldn't boot past the "LINE 6 POD GO" screen (still shows firmware at 1.40.1). I tried a factory reset, but it doesn't get past the "Will reset Globals, Presets, IRs..." screen

The steps I took were as follows:

  1.  installed Lined 6 Updater
    It doesn't see the device. Also tried another USB Cable and alternate USB port.
  2. Tried booting POD GO holding "Page >" button.
    Line 6 Update now sees the device, but the firmware update fails. Will try a different computer later.
  3. Tried a different computer.
    No luck. (this is actually very interesting, which will become apparent later)
  4. The solution: Actually read the instructions presented in the Line 6 Updater (I know, I know, RTFM!).
    The first instruction provided by the Line 6 Updater is:
    "Shut down any programs that use audio or connect to your POD Go device, like DAWs, iTunes, Spotify, video games, etc."

    So I opened task manager, and saw that Spotify.exe was actually running in the background, so I killed that. I also killed MS Teams and WhatsApp Desktop.

    Tried the Updater again, and it worked!

The reason I mentioned earlier that it was interesting the update failed on the other laptop, is that it didn't have any of those applications installed. It did however have Discord installed. I suspect that was the culprit.

 

  • Like 2
Link to comment
Share on other sites

  • jswoveland changed the title to Line 6 POD GO Firmware Update Failure - SOLVED

I am having the exact same issue. However, I only have Macs available and no PCs. I tried using different computers, cables, USB ports and also tried the new Line6 Central app. The update in DFU mode always fails after a few seconds and POD Go is stuck at "Updating...".

 

I even installed a Windows VM, but Line6 Updater does not recognize POD Go in the virtual machine, though it is connected to the VM and shows up in device manager.

Link to comment
Share on other sites

On 12/4/2023 at 6:58 PM, paul5153 said:

My pod go has updated to version 2.0 but it freezes constantly now! Does anybody have any clues as to why thanks, or what I can do next Paul. 

Almost certainly you are experiencing strange behaviour due to code conflicts between old and new firmware. Did you reset back to factory after the update? It's very important to do this because it's like a clean install. 

Link to comment
Share on other sites

The new 2.0 update has completely crashed my Pod Go. Nothing works. Got an email from support telling me what to do. Nothing. Why are there always these issues with Line 6 updates? So frustrating. I've tried more than 20 times to reinstall 1.40.0. All I get is error messages. My Pod Go has now become a paper weight. I know Line 6 is aware of these issues and they haven't posted anything telling people how to fix it. 

Link to comment
Share on other sites

  • 1 month later...

I faced the same issue as soon as I updated to 2.0. But my Pod Go is getting stuck even while trying to factory reset it. Is there a way to at least bring it back to the previous working condition?

I am trying to factory reset by pressing the C and D buttons during startup. The screen keeps getting stuck at "Will clear Globals, Presets, IRs...".

Link to comment
Share on other sites

  • 3 weeks later...

I finally sorted this out, after a couple hours of trial and error.

 

The thing that eventually worked for me was the following:

 

- remove the USB cable from and shut down the Pod GO

- download the line 6 updater

- start the line 6 updater in offline mode - do not log in.

- from https://line6.com/software/   Filter by Hardware: Pod GO, Software: Firmware , Operating system: your operating system

- download the firmware version you were on before the failed update

- Turn on the Pod GO in update mode ( hold `Page >`) while flipping the power switch on

- quit all applications besides line 6 updater

- in Line 6 updater, choose the firmware .hfx file that you downloaded

- Go through the installation steps

 

That got be back to where I was before I bricked my Pod GO.

 

Then, to update to the newest version, I updated each consecutive version and updated to that through the line 6 updater.

 

whew. Hope that helps someone!

 

Screen Shot 2024-02-17 at 12.03.18 AM.png

Link to comment
Share on other sites

I've got the exact same problem. Got the POD GO at Christmas and have only just started really playing with it. Downloaded POD GO Edit onto my Macbook air and plugged in the POD GO. It prompted me to upgrade to v 2.0 (from 1.40.1) and I followed the instructions. Looked to be going OK, and the POD GO Edit screen said something like 'the POD GO is updating the presets and will reconnect to POD GO Edit in a few minutes'. Well it didn't, just kept showing 'Updating..' on the POD GO screen. After about an hour I turned it off, and tried to restart, but it's stuck at the kidney-shaped opening screen. Did some googling, tried the C&D button restart, nothing. Very annoying.

Ideas please?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...