Jump to content
MakeItShredNo1

"Model Knob" repair question

Recommended Posts

I have a chance to score a JTV69 for a steal, but the model knob is "broke."  According to the seller, it seems "stuck in the on position" - I imagine he really means that it's stuck non-depressed, but I can't be sure, as I will not be able to play the instrument before purchasing it and having it shipped to me.  


I've seen a couple of topics on common problems, but let's say worst case scenario - how much is it gonna cost to fix this if it is the worst possible problem?  And if I can't do it myself, what's a ballpark on the labor (which will of course vary from tech to tech - just a round-about number of what I could expect to pay)?  I'm curious if this will end up being a good deal that the guy just doesn't want to mess with, or if I should just buy a like-new one.

Share this post


Link to post
Share on other sites

Very typical issue - even "new" JTV-69's suffer from this - fixed by gently lifting "up on the Model knob  - to allow proper up/down travel for the "push"push" switch action  

Share this post


Link to post
Share on other sites

stevekc suggestion is a good place to start. He knows his stuff. One

of five people in the Americas (north or south) I trust to do a mod on

a JTV, ... without messing it up. Work on one of his Bigsby JTV-59's,...

... nice.

 

If it's in the "on" position, chances are it's just an alignment thing.

If the volume of tone control knobs are loose, then it's just a matter

of pulling off the knobs, testing the knob excursion for each position

is good, then tightening the nuts down.

 

There is also a spacer fix for that. A Line 6 authorized service center

could deal with that or get a knob with the in it. Being an authorized

service center, they would check out all the other things as well, as they

would have access to service info and service manuals.

 

Both of the above mentioned are simple and straight forward.

 

If the encoder is jammed underneath, the pick-guard would have to come

and that is a bit more involved. There could be a couple of reasons for that,

including a failed encoder.

 

 

In any case, it should be looked at by someone who knows the product.

At this point giving a ballpark idea would not be possible until a better idea is

regarding the above mentioned possibilities. They are just too wide and varied.

 

BTW, what's the serial number of the JTV-69?

Share this post


Link to post
Share on other sites

I got the owner to reply - he said not only does it seem "stuck on" but that the model select knob doesn't turn at all.  I'm not sure if he means that it's difficult to turn, or impossible to turn.  He also says that the model selection is functional when connected to a HD500 - the knob doesn't work, but the actual modeling is functional.  I don't suppose that narrows down the diagnosis?  

 

Assuming I can handle the simple repairs myself - like wedging paper underneath the knob, like I've seen mentioned on this forum - is it now possible to ballpark me a "worst case scenario"? Or still too many variables?

Share this post


Link to post
Share on other sites

Sounds like the knob is damaged rather than just not working.  Worst case you can replace it.  Not that big a deal if you can steal it.

Share this post


Link to post
Share on other sites

Thanks for all your help guys.  I think unfortunately I'm going to end up passing because there are too many variables, and ultimately I'm G.A.S.ing harder for a Helix with only so much money to go around.  

 

If it was surely a simple and cheap fix I'd have to consider it, but I've been burned by used gear a few times lately and don't feel like the headache right now.  Plus, the only certified Line 6 technician in town is super overpriced, so if it did need a repair I can't handle, I'd be out serious money.  

Share this post


Link to post
Share on other sites

Hi, 

 

I'm having difficulty with my JTV 69. I'm trying to tighten the tone control knob. It seems impossible to take off the front of the pick guard like on a regular stratocaster? I've removed the pick guard to reveal underneath? However I'm still unable to see any means of tightening? The tone control is not functioning properly. 

 

Does anyone have any ideas on how to replace or repair this? 

 

I've been performing full time with this for about the last 2 years. It's a great guitar. Wouldn't use anything else. Only recently I've been experiencing these issues. 

 

 

Cheers 

 

Matti 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...