Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Cant add blocks with mouse in Editor!!!


Recommended Posts

I'm hoping someone can help. I'v just purchased my Helix and all firmware is upto date as well as the latest version of Editor. When I try to had blocks to a new patch nothing happens. I'v tried double clicking the left mouse button, dragging and dropping etc etc and nothing happens. The only way I can do it is via the unit itself  :(


I have tried uninstalling and re-installing as well as 5+6 reset! Its super frustrating, I want to be able to do everything from my PC and not have to keep bending down to the unit to add amps/effects etc.


Anyone any ideas? 

Link to comment
Share on other sites

Click (don't double click) the empty block in the signal chain where you want to place the block. Once the empty rectangular block box is selected, click your mouse over the FX Block Category that you want to add. This list appears in the lower left area of the editor window. Then select the Processor Type from the pop up list, then the Model. Double-click the model name it to place it in the signal chain.

Link to comment
Share on other sites

Oh wow, this is crazy.  These may seem like basic or dumb suggestions, but they are all I can think of...


1. When you just hover your mouse pointer over a path line in the Helix editor, it should put a little gray preview square where it would put a block if you clicked there (it turns white when you click) See pic below.  Even using the keyboard arrow buttons moves the little square around on the paths in the Helix editor.  Does this even work for you?

2. Is Helix plugged into a USB 3.0 port and not a 2.0 port on your computer.  These are usually marked "SS" for super speed.  Sometimes this can cause issues.

3. Try a different USB port for your mouse

4. Try a different mouse

5. Do you have more than one pointing device (mouse, etc. plugged into your computer.

6. In Helix app Help>About it says that it was develped using Qt software.  From their website, it seems that it may utilize Open GL, Direct X and hardware acceleration.  Is your Windows OS up to date?  What version are you running?  Is your graphics driver up to date?

7. Have you tried rolling back and re-updating the Helix Firmware


Helix Application Pilots Guide lists a bunch of keyboard shortcuts.  Maybe you can try some of these to rule out the mouse or the Helix App as the issue.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...