Jump to content
Mnztrl

Variax Cable not connecting

Recommended Posts

Hi,

 

This might be a stupid question, but I just bought myself a Variax (JTV 69 S) and a Helix LT, along with a Variax Cable. For the life of me, I can't connect the cable, neither to the Variax, nor to the Helix. The cable simply won't fit into the Variax socket. Am I missing something obvious? Are there different types of Variax interfaces? Or are the cable defective somehow?

Share this post


Link to post
Share on other sites

Never mind, I figured it out. The ethernet connector in the cable was slightly off in both ends. I was able to connect it by unscrewing the cover and separating the ethernet connector and the metal casing, and connecting then one after the other. The ethernet connector won't stay in place though, I fear I'll have to go through this process every time the cable is connected. Is this a common problem with the Variax cables?

Share this post


Link to post
Share on other sites

Be sure when you remove the VDI cable to press the release before you try to pull it out.  I forget that all the time!   :)    I always have trouble getting it lined up to insert too.  But at least my socket doesn't appear to be moving!!   :)     Scott

Share this post


Link to post
Share on other sites

I have this same problem and I do have to unscrew the thing every time. Odd because the cable that came with the guitar (that only has the XLR-style plug on one end) does not have that problem and, in fact, swapping out the metal jacket from that cable fixes the problem. Might just put in a support ticket and see if they can send me another one.

Share this post


Link to post
Share on other sites

There's only one type of Variax connector, and it should click into the Variax sockets without trouble. Unscrewing the protective metal sleeve to "plug in" defeats its purpose, and of course the plastic connector won't stay in. Sounds to me like a misalignment between the sleeve and connector. The plastic tab on the connector should be aligned directly opposite the little hole on the side of the sleeve (which engages the thumb release). If you can't align it yourself you should return it for replacement. BTW this is the first I've heard of a misaligned connector.

 

Hope that helps.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×