Jump to content
SonicEchoes

Using the POD HD500X in the effects loop for Delay and Reverb only

Recommended Posts

i was wondering if anyone has tried to use their POD in the same way i am trying to do. what i want to do is to run my analog overdrive and distortion pedals into the front of my ac30 and then use the POD for post effects only through the effects loop, so the way i have it set up now is guitar--walrus deep six compressor--mojo hand fx rook overdrive--wampler catapulp--into my ac30 topboost channel just on the edge of break up. then i want to run my POD through the effects loop for delay, reverb etc, i have it set up ac30 effects send--guitar in on POD--1/4" out L POD--effects return on ac30. the levels are set to stomp, the issue i am having is that running it this way seems to suck the tone out of my drive pedals so they are not as distorted or warm as when i bypass the effects loop and i was just wondering if this is how i should have it set up or do i need to run the 4CM with my analog pedals in the POD effects loop? i dont use the pod for any amp modeling or drive pedals as i have some really nice ones, and i am in an ambient band so sometimes we play heavy and other times we play real spacey stuff so the M13 is out of the question because i need all 8 effects blocks for reverb, delay, modulation fun stuff. if I could get some help on this it would be great. Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×