Jump to content

Helix LT freeze when USB is connected


Recommended Posts

Hello there


I recently purchased the Helix LT and I have been enjoying it both for playing at home, and for party gigs.

I realised that I can practise in my room by connecting it through the USB, and play through my jbl LSR305 monitors, which really sounds great, and also gives convenient parameter control through the HX edit software.
A recurring error is however stifling my enthusiasm. When I've been playing for say 5-10 minutes, the Helix freezes and becomes unresponsive. In the HX edit software it disconnects from the device, and refuses to recognise that the helix is still connected. The sound goes through unaltered, but I can now no longer change parameters, and to access this again I have to reboot the pedal (discarding possible changes). This is really problematic, as it essentially removes the functionality that I want from the pedal, and googling it has yielded no results. Does anyone have similar experiences?

My specs are:
Helix LT is running v2.54.0 firmware.

13'' MacBook pro running high sierra 10.13.5

HX edit v. 2.52

playing through Logic Pro X v. 10.2.0



Link to comment
Share on other sites

  • 3 years later...

I have the EXACT same problem! It's driving me nuts! I can still change presets, although the display and button colors don't change at all. Also HX Edit says that the Helix LT is disconnected, but backing tracks coming from the pc still work fine and everything works as usual. I then have to disconnect the cable (also tried another cable and another port btw) and reconnect. Then it will work again for 5-10 minutes and disconnect again.


Very (!!!!) seldomly restarting HX Edit fixed the problem, which I find very strange. But in 9 out of 10 cases I have to replug the cable.


Have you found a solution? Why is there no answer yet to this question?


I'm on a Win10 PC using the 3.11.0 Firmware and a brand new Helix LT (some 2 months old). Everything is up-to-date and I also tried a factory reset some time ago. Didn't help at all.


So as it seems the problem exists on multiple OS...

Link to comment
Share on other sites


Check the power management on your pc

- Usb ports, right click in the port and check that power management is turned off/not allow to set the port in stand by.

-  Optimize power management - In control panel find energy setting there you have e few options. Pick the option balanced mode and  never set the computer in power saving mode. Find advanced  options and the USB option and select the option inactivate the possibility to turn off the usb-ports.

Above could be the problem, specially if its a lap top. To run a pc with real time applications its a good practice to optimize the system, incl audio, not letting any parts to be turned off, eg usb-ports, netwotk cards, pci-buss etc. You find them under the advanced tab described in second bullet above. On Internet there are descriptions in how to optimize the pc to run audio, above are part of that. Some are very advanced and I have only done the basics like power management, optimized some processes and turned off some application in start up. 

Hope above make sense, my pc is set to Swedish so I might not have translate the win 10 names correct... ;-) 


Give it a shot and see if it helps


  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...