Jump to content
Yitz

Is the Amplifi Dead?

Recommended Posts

I just found out about this piece of tech which sounded great and very conviently exactly what I need.. So I come here to see if theres any info about Android and various other questions I had regarding how it has progressed since release and I'm getting bad vibes of "HELP NOT WORKING!" and apparently 30% of peoples AMPs are frying and its near impossible to get it replaced?

 

Some real insight into wtf is going on with this product would be neat :)

Share this post


Link to post
Share on other sites

Hi Yitz,

 

I have had a couple of issues with my Amplifi 150 and it's been for repairs twice, including a new power supply being installed, but it hasn't given me troubles since. I considered buying maybe a spider if it wasn't reliable. After it went out of warranty it one day did the random shutdown thing, so I dismantled it and removed the firmware card. I then cleaned the slot and put it back together, and it didn't boot. (dammit) But then I realised I hadn't put the card back in. I pulled the back off again and reinstalled the card and it has worked like a dream ever since. It hasn't played up in nearly a year.

 

I really like my Amplifi and its tone modelling, even if it was trouble in the beginning, and I would like to hope it continues to serve me for the next 5 or 10 years.

 

I hope you get one, and that it works without a hitch for you.

Share this post


Link to post
Share on other sites

I’ve not had a single issue with my AMPLIFi 75. 

 

people who have had issues are rightfully going to vent their frustrations while those with no problems are going to stay quiet. 

 

The amplifi is is perfect for me. I don’t play in bands and just jam out at home with headphones. Being able to play along to songs through my phone is wonderful. 

 

If you can wait it might be worth seeing what pops up at namm 

  • Haha 1
  • Upvote 1

Share this post


Link to post
Share on other sites
On 10/5/2018 at 7:49 AM, SaltyRum said:

I’ve not had a single issue with my AMPLIFi 75. 

 

people who have had issues are rightfully going to vent their frustrations while those with no problems are going to stay quiet. 

 

The amplifi is is perfect for me. I don’t play in bands and just jam out at home with headphones. Being able to play along to songs through my phone is wonderful. 

 

If you can wait it might be worth seeing what pops up at namm 

 

And your Amplifi 75 is still working fine through the Amplifi App ?? jeez .. I've had problems with it for months:

 

1. Bluetooth Connection drops

 

2. Inconsistent volume control between guitar and music. Unable to level out the music and guitar to the same noise level, so one is always higher than the other. The guitar sound is almost inaudible, while the music is loud.

 

3. Also appears to be remove some of the individual feeds (guitar, drums, bass, whatever) while playing music (ie Metallica), such as you can hear guitar but no bass and drums are faint.

 

There have been no recent updates for the Amplifi app for iOS to fix any bugs (which there are).

 

Running iOS 12.1 and Amplifi Device Flash 2.60.

 

Customer support doesn't appear to be on Line6's agenda ... wish they would take a leaf out of Amazon's level of service!

 

It's got to the point where I have almost stopped playing guitar as this is the only amp I have now and to play along with music has ceased! Well done Line6 !!

 

On verge of deleting the App and using the AMP as a doorstop!

 

 

Share this post


Link to post
Share on other sites

Exactly my opinion dear peers. Its a great device. Although as with any amp it depends on the use you have in mind. 

Share this post


Link to post
Share on other sites

Well.....

 

Since I bought the amp I’ve been using an android phone, Samsung S5. The phone’s old and started slowing down but lucky for me my work phone broke so I got it replaced with an iPhone 8. Brilliant; I can now use my amp with a better phone, or so I thought. 

 

With the iPhone I’m getting all the issues that everyone else is. Losing connection, songs suddenly stoping, app not responding etc. I’m wondering if it’s the iPhone app that’s screwing everything. 

 

Gone back to the Samsung and again not a single problem. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×