Jump to content
asesino

Your Update is only for OS X 10.10??

Recommended Posts

VERY DISAPPOINTING that your software update firmware and HX edit only be for people

who have such an expensive device in Latin America as it is an OSX 10.10 or above.

Then I acquired your HX effects device but I will not be able to edit it or update it?
Your product and softwear should warn about this "very little detail"

Share this post


Link to post
Share on other sites

Think you need to look again - if that were true all us PC folks would be in big trouble! Unless, of course, you're using Linux.........

Share this post


Link to post
Share on other sites

I don't understand. Right on the download page it says, depending on whether you look at the Windows or Mac downloads:

Compatible OS: Windows 7, Windows 8, Windows 10

Compatible OS: Mac OS X, Mac OS Yosemite, Mac OS El Capitan, macOS Sierra, macOS High Sierra, macOS Mojave

Share this post


Link to post
Share on other sites

Mojave = 10.14

High Sierra = 10.13

Sierra = 10.12

And so on....

 

Just download and install the downloader. If it won't work, update your operating system.

Share this post


Link to post
Share on other sites
1 hour ago, asesino said:

VERY DISAPPOINTING that your software update firmware and HX edit only be for people

who have such an expensive device in Latin America as it is an OSX 10.10 or above.

Then I acquired your HX effects device but I will not be able to edit it or update it?
Your product and softwear should warn about this "very little detail"

 

If you're saying that the older version of OS X that will work with HX Edit is 10.10 (Yosemite), yes, that's correct... Apple doesn't generally support their own OS versions for more than three years, and 10.10 came out in 2014. I think 10.9 came out in 2013...

Share this post


Link to post
Share on other sites

Updating your Mac to a more recent OS is free. 

To not be able to update to a supported OS version, your Mac would be more than 9 years old. You can update late 2012 models to the latest OS. If older, you might need to use one of the other compatible versions. 

If you cannot do that, I think it is unreasonable to expect latest technology to be compatible with technology more than 10 years old. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...