Jump to content

Recommended Posts

Hi I need help. I've uninstalled and reinstalled all helix drivers/apps without my helix connected. tried 3 USB Ports.  My PC windows 10 recognizes the device under device manager (audio, video and game controllers.  there is an exclamation point next to line 6 Helix icon.  I have a Dell XPC 8920 Intel R Core TM i7-7700K CPU 4.20GHz 4.20GHz.

Thanks for your support

Share this post


Link to post
Share on other sites

i tried my laptop,  Line 6 Updater does see it. however HX Edit reads "connection Interrupted" Running one app at a time.

My current Helix software is 2.10.    dont know why is doing this. im afraid to update my helix

Share this post


Link to post
Share on other sites
2 hours ago, InvincibleNote said:

i tried my laptop,  Line 6 Updater does see it. however HX Edit reads "connection Interrupted" Running one app at a time.

My current Helix software is 2.10.    dont know why is doing this. im afraid to update my helix

 

Hi,

 

I can understand your concern about updating your Helix, but there is a whole thread on this forum dedicated to working through the issues that you have mentioned. As you haven’t said that you had checked any of the suggestions/solutions from those posts, I will point you to them. Work your way through all the posts and try all the various things that seem to have fixed things for other users. You will see from the amount of comments that you are not alone, but most of these problems are misunderstanding how to install or “operator error”. These situations are usually not fatal and can be resolved with a little patience.

 

Please read through this and see if it helps.

 

 

Good luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×