Jump to content
Wondo100

2 New PC+ Stereo Problems

Recommended Posts

Spend most of the day with two 112 PC+. Updated to new FW on both cabs. Both cabs hooked up via L6 Link. Just one cab by itself is starting to sound good. Hook up the other via L6 on back of cab and now the power is cut in half and it is really hard to get both cabs to hit that sweet spot that the one cab does. Someone said there may be problems with a stereo set up with both cabs. Not sure if this is it, but running both in stereo does not sound good. I adjusted both levels the same in the PC. 

Share this post


Link to post
Share on other sites

So is it using them in stereo, where one side may have quite a bit different of a signal being sent to it?  Or are you trying to first run them both mono.  That's surely where I would start.

 

Since I know this forum doesn't get much action, here's a link to another post from a ways back on stereo Powercabs.

 

 

Share this post


Link to post
Share on other sites

Thanks. That thread talked about the same set up I have with L6 Link. When the Cabs are run in stereo, it cuts the volume in half. I may just decide to send these back. I get much better tone of what I am looking for running two Grandmeisters in to two 2x12 with V30s. I have much more control over things this way. In this set up, I use Helix in 7CM and primarily as an effects processor and sometimes will switch from the loops to an amp block using my power amp and cab to power it. Sounds great. For studio, I have a great pair of Yamaha HS 7s. At this point all the extra tweaking of the PC is just too much headache for me. They may be good for some, but not for me. I spent a good deal of time with them and they are cool, but not my cup of tea at this point. 

 

I do thank everyone on here for their help. Great forum with very knowledgeable people. Although, I may be done with the PC, I may still need guidance with the Helix and hopefully some day be able to return the favor and offer help to others (especially when it comes to 7CM, since not many people are doing that, and I think I have found a great set up).

Share this post


Link to post
Share on other sites

I wish I could help you, I brought the 212+ PC and as soon as I hooked them up it gave me the stereo sound....but from what I have seen you have to go into the settings and try different settings...

Share this post


Link to post
Share on other sites

Yeah, I have heard that with the 212, this is not an issue especially when running dual  amp paths, but as far as I can tell with 2 of the 112s it is an issue. It is okay. I am really happy with my two amps in 7CM at this point and I can save some money.

 

Share this post


Link to post
Share on other sites

one thing you have to do to get the two 1x12 PC+ cabs to work together is power on helix first then power on what will be cab 1 then power on cab 2.........

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...