Jump to content
musicker

Workbench HD: Can't remove a 3rd pickup

Recommended Posts

I'm sure this is an easy one and I'm just missing something...

 

In playing around in Workbench HD, I added a 3rd pickup to a Custom model with the Gretsch 6120 (which defaults to only 2 pickups). Now I no longer want that 3rd pickup in the model, but I can't figure out how to delete it in all cases. I checked the Workbench manual:

 

Why do I see only 2 pickups on some bodies, and 3 pickups on others (with 1 being transparent)?
True to the original guitars we modeled, the number of pickups you see will be appropriate to the source guitar. In other words, on a 2 pickup guitar, when a Workbench HD middle pickup is de-activated, it will become invisible, but on a 3 pickup guitar, a de-activated middle pickup will be translucent.

 

So, fair enough, in 1st and 5th positions, the middle pickup becomes invisible:

 

1770139502_middlepickupinvisible.thumb.jpg.d5965a3f52414050c04dd6e77e27449e.jpg

 

But not in position 3, even though the middle pickup is deselected:

 

middle_pickup_ghosted.jpg.8c5c39c4c6d7eb01e171d8745ac43101.jpg

 

What am I missing? How do I get rid of that middle pickup?

 

Thanks in advance for any help you can offer. =)

 

Share this post


Link to post
Share on other sites

Curious. I have just repeated your setup. In my Workbench HD. I selected the R-Billy G-Brand body and the images of its 2 pickups appear in the neck and bridge positions with both pickups active. When I select the Middle pickup its image appears in the middle position. However, the bridge pickup is deactivated and its image becomes translucent.  In effect the guitar remains a 2-pickup guitar with the bridge pickup active and moved to the middle position even though its translucent image remains. When I deselect the Middle pickup its image disappears and the bridge pickup image remains translucent. It can be reactivated by selecting the Bridge pickup.

 

 I experimented a bit. The behaviour changes depending on which of the Neck and Bridge pickups (or both) are active/selected when you select the Middle pickup. However, at all times, the image shows only one or two pickups active. You can't have no active pickups, and you can't have three active on that body type. You can, however, arrange to have only the middle pickup active. In that case you can't delete it because you would then have no active pickups. As mentioned, there must be one or two pickups active and selected at all times.

 

From your picture it appears you may have swapped (clicked/dragged) the positions of the pickup images at some point. By doing so I did manage to create the situation shown in your picture: three pickup images are present with the neck and bridge pickups active while the middle pickup image is translucent and can't be removed because Workbench HD knows it is one of the original two pickups.

 

I don't think it's a bug but it is confusing.

  • Upvote 1

Share this post


Link to post
Share on other sites

I think it depends on the toggle position, one, the other or both.

Similar for three pick-up.

Share this post


Link to post
Share on other sites
Quote

From your picture it appears you may have swapped (clicked/dragged) the positions of the pickup images at some point. By doing so I did manage to create the situation shown in your picture: three pickup images are present with the neck and bridge pickups active while the middle pickup image is translucent and can't be removed because Workbench HD knows it is one of the original two pickups.

 

THIS IS EXACTLY WHAT HAPPENED! I tried the 2 permutations, and sure enough, I swapped the neck- and middle- pickups and was able to get the previously-neck/now-middle one to disappear. Thank you so much, I doubt I would have figured that out on my own. It seems like the software or documentation could be more helpful here, if only to say "don't do that." =)

Share this post


Link to post
Share on other sites
15 hours ago, musicker said:

 

... It seems like the software or documentation could be more helpful here, if only to say "don't do that." =) ....


True, but this is only a display image issue. The performance and audio from the guitar is the same whether or not the extra image appears in the Workbench HD program.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...