Jump to content
Sign in to follow this  
egkor

Dt50 Head, Firmware Update Issue

Recommended Posts

Hi,

 

Recently obtained a new DT50 Head.  I assume since new it is probably at a firmware version < 2.0.

 

So since I could most easily get a USB/MIDI interface that is a Hosa USM-422, I have been trying to use that. It is very similar to the M-Audio Uno USB/MIDI interface.

 

So after several hours attempted I cannot get the Monkey firmware update process to proceed any further than:

 

Failed, Code: 8000000A, undefined error

 

I have tried:

 

Using different Windows computers (Win 8.0 and Win 7)

Using different computer USB ports

Check Control Panel, Device Manager, in "Sound" there is a "USB 2.0-Midi" entry 

Have run the DT50 in both Standby and On, and Safe Mode

 

The driver for the USB/Midi Interface is the standard Windows driver, so special driver needed

 

Have uninstalled/reinstalled the standard USB/Midi driver, unplugging and reconnecting the Interface to USB to let the computer detect it and install the standard driver

 

Am pretty sure the Interface Midi cables are connected correctly to the amp (Amp Midi Out -> Interface Midi In, Amp Midi In -> Interface Midi Out)

 

I observe the lights on the Interface, I am getting "power", and data going in both directions (if I reverse the Midi connections at the back of the amp then I don't get this far)

 

I have downloaded and installed "DTEdit", and I can see that if I make a change to "Pentode/Triode" in the app then the amp will respond and switch.  Likewise if I change the switch on the amp, the app will update to match

 

I have downloaded the DT50 firmware update files 1.10, 1.20, and 2.0, and tried Monkey with all of those

 

I registered the amp with Line6, so no stoppage there

 

So I feel like I have exhausted all the possibilities/combinations of things to try.

 

I am guessing but the likely suspect causing the firmware update failure issue is the Hosa USB/Midi Interface.

 

So now I'm going to return the Hosa USM-422 USB/Midi interface.  I have a M-Audio Uno USB/Midi interface on order.  At this point all I know to do is to try is a different interface.

 

The main reason I put this post out there is if someone else is struggling with the DT firmware update, maybe this will help save them time, and show what "not" to do (try this first with the M-Audio Uno USB/Midi interface).

 

-Gary K

 

Share this post


Link to post
Share on other sites

I'm having the same difficulty with my DT25 and the M-Audio Uno.  Line 6 definitely has some issues to resolve when it comes to communicating with these amps.  The Uno connects to my Vetta II every time on the first try.  I have the latest drivers for it as well.  I've also tried booting the amp in safe mode.  I'll post back if I figure something out.

Share this post


Link to post
Share on other sites

I have the mio 1 in 1 out to MIDI connection and Im getting the same. "Failed, Code: 8000000A, an undefined error occurred:

make sure the cables are still connected and try the update again. they are and I did. Still No JOY

Share this post


Link to post
Share on other sites

Update:

 

Joy!  The update to 2.0 firmware to my DT50 worked!  On the first try!

 

While waiting on the M-Audio Uno to come in, I had an opportunity to try a M-Audio M-Track Audio/Midi (USB) Interface.  The M-Midi portion of the M-Track worked flawlessly.

 

Here is a summary of what I used and what I did:

 

M-Audio M-Track (comes with USB cable)

Host Computer w/ Windows 7 64-bit

2 Midi cables, connection as follows:

DT50 Midi Out to M-Track Midi In, DT50 Midi In to M-Track Midi Out

I downloaded and installed the drivers for the M-Track for Windows 7 64-bit from the M-Audio web site 

Made M-Track (Windows) settings as shown in the (downloaded) M-Track User Guide.

Powered up DT50 in Safe Mode.  Safe Mode is:  Hold the Channel A/B switch down to B position, turn the amp power switch from Off to Power while holding the channel switch down to the B position.  I then let approx. 15 seconds go by, and released the channel select switch.

Ran DTEdit to verify connections.  Changed Pentode/Triode switch in DTEdit on the computer and saw the DT50 reflect the change on its front panel.

Ran Line 6 Monkey.  Monkey came up recognizing M-Track Midi as the device interface. 

Monkey showed Current Firmware=Unavailable, Selected Firmware=2.0

I selected "Update From File", and browsed to the v2.0 firmware file I had downloaded from Line 6, selected that file.

After accepting the various prompts and panels, the firmware update started!  And ran without error!

It seemed to take approx. 5-10 minutes to complete the flash, with the amp restarting once in the process.

After the update, Monkey showed Current Firmware=2.0, Selected Firmware=2.0

 

-Gary K

Share this post


Link to post
Share on other sites

I finally got the update to take.  I didn't change anything; I just kept at it.  This was with my M-Audio Uno.  I gave up for a few days and then tried again.

 

Come to think of it, there was one difference; this time I was not signed in to Line 6 Monkey.  Don't know if that mattered.

Share this post


Link to post
Share on other sites

DarrellM5,

 

Good Job!

 

The M-Audio Uno looks to be a USB/Midi interface that has a reputation for working with the DT amps and Monkey, and DTEdit. 

 

-Gary K

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×