Jump to content

rizzy

Members
  • Content Count

    18
  • Joined

  • Last visited

Everything posted by rizzy

  1. The DI track you recorded needs to be raised by 6 dB in level to get the same results as if you were playing live into your Stomp. When you save the preset back to the Stomp and you are running that DI track through it, it still has to be risen by 6 dB. Mind you, this is valid for Cubase. Phil_m pointed out somewhere above that the reamping works just fine with standard settings in Reaper. I checked that and figured that Reaper handles audio track levels via aux differently than Cubase does. You've got to try for yourself if this problem is existing in Pro Tools - my guess would be that it is. I've contacted support regarding this issue. Their first reply was that this behaviour would be normal - to which I replied that there's no way that this level drop could be intended and that it'd be nice if the firmware would be updated accordingly. Their second reply suggested that I should set the 2nd path to no input at all, because otherwise the volume would be split. I tried that on my Helix LT but there's no volume split happening at all, no matter if the 2nd path is set to multi, guitar, USB etc. or X. So I reported that back and then the support ticket got auto closed.
  2. Hi, unfortunately -as far as I know- it's not possible to update via MIDI. Just out oft curiosity - what happened to your USB Port ? 5 months is not long ago. Is there a possibility that there's a warranty on the repair ?
  3. Thx for the hints about the discount on HX Native. It is possible to configure MIDI controls for automation in a DAW. Since HX Edit has all the controls preconfigured, I thought it would be easier to use those as compared to setting them up and dealing with MIDI implementation charts - especially for non experienced users. I see that this idea led to a partly heated discussion here. It's just an idea. If it doesn't make it no one will get hurt and life will go on.
  4. Oh. I didn't even know I was allowed to vote for my own idea, thx for the hint - and for your vote of course. Guys, thx for your opinions and input.
  5. I never said it should be free. I said I don't want to buy Helix Native as I have the hardware unit and it would be cool to automate it using a plugin dedicated to that. How you are getting to the conclusion that I think Line 6 should drop everything else and whatnot is beyond me. All good. I totally get where you guys are coming from. I just thought it would be cool to have another option on the table for the non Native users.
  6. I don't own the Native software and would like to be able to automate things while reamping through the hardware unit using the HX Edit GUI as a Plugin. I don't want to buy HX Native and think this way would be easier than to set up dedicated MIDI controllers in a DAW. It would be like doing automation you'd do within Native but using the Hardware unit. This possibility does not exist in the suggested way right now.
  7. Well, I thought having the HX Edit user interface as a plugin inside a DAW would make automation of the hardware unit easier - i.e. if one wants to program changes of parameters that should happen at a given point in time while reamping through the hardware unit. It would be easier that way as compared to setting up controller components inside a DAW and sending MIDI events from them, as HX Edit already comes preconfigured for that task. Think of it like doing automation inside HX Native but doing it via HX Edit using the hardware unit.
  8. I'd love to see an additional HX edit version as a VST/AAX/AU plugin. That way parameters could be automatized within a DAW and reamping using the hardware unit would step up a few levels. line6ideascale - HX Edit as VST/AAX/AU Plugin
  9. You might be on to something here....I was thinking that the Helix would kind of autosense which connections are made to it - but maybe it doesn't.
  10. Hey phil, I was fiddling around with Reaper lately. I was wondering why the '6 dB problem' didn't occur to you while reamping. Reaper is unique in that it's using a one track fits all approach. All audio tracks are 2 channel tracks. In order to get a mono track being placed center, it is internally mapped onto those two tracks. Both tracks are equal in level. When routing such a track to the Helix via USB 3/4 those 2 channels are summed together which results in a level rise of 6 dB. This signal reaches the signal chain in the Helix and gets attenuated by 6 dB as I've described. So in the end the Helix output signal is equal to the live signal. This works only using Reaper and only if one doesn't change the routing settings. If the Post-pan in the routing dialogue is set to full right or full left, it will send a 'real mono' signal, meaning the level sent to the Helix will drop by 6 dB. The same happens if one's choosing USB 3 as an output - only one of those two mono tracks is sent to the Helix and the signal's level is 6 dB too low. Cubase (ProTools and Logic Pro as well IIRC) don't behaves like that. There are dedicated mono and stereo tracks. If I route a mono track to the Helix, it is that one track that goes there. If I choose USB 3/4 as an output, it gets only fed into USB 3, because it's mono. I can mimic that Reaper behaviour by routing two equal mono tracks to USB 3/4, but then again I could simply raise the gain by 6 dB which results in the same outcome. I hope this makes sense and is somewhat understandable.
  11. I let my DAW compare the RMS values of the recorded tracks (live track through the Helix and DI track via USB through the Helix), that gives me an indication of the ballpark the tracks are at levelwise. If necessary for getting the exact value, I then try to null the tracks - flipping the phase on one of them and panning them center (using just one track if they are stereo tracks as this only works in mono). I raise or lower the level of one of the tracks, if the level of both get into the area of being equal, the two tracks cancel each other out almost completely. In order to make that work, the tracks have to start at the exact same point in time. During my testing I found out that the Helix ASIO USB driver, which is only relevant for Windows user, doesn't report the correct latency to the host (DAW). That resulted in a negative 1.9 ms latency for the reamped track compared to the live recorded track at a sample rate of 48 kHz. Very interesting that you have to lower the level at the Native's input by 6 dB. That is very interesting as well. I'm using Cubase. What I found baffling is that when I don't put any effects in a chain on my Helix LT - just in > out - there doesn't happen any attenuation to the level of a DI signal that is fed into it via USB channel 3. As soon as I put a preset in there or build some signal chain, the 6 dB drop happens. For me, this behaviour ruled out that Cubase has something to do with it.
  12. I suppose the code from the Helix hardware was 1:1 implemented into Helix Native - and with it the 6 dB problem.
  13. Hi, to get the same level as if you were playing through the Helix stomp you'd need to raise the gain at the Helix Native's input by 6 dB. The same is true for reamping through the Helix stomp I suppose - at least it is for the Helix Floor and LT.
  14. Hey Gary, interesting. Thx for pointing that out.
  15. Editor/Firmware: 3.01 / 3.01 Helix LT OS: Windows 7 Hi, the USB levels sent to the Helix for reamping get attenuated by 6 dB once they enter a signal chain. As a result, a reamped track is quieter and doesn't sound the same as a reference live track. This does only happen if a signal chain is involved, with no chain involved (input > output) there's no level attenuation happening. Also this is just happening during reamping via USB. The level stays as it should using the old school method (signal + 4 dBu send from audio interface to Helix input set to instrument). The via USB reamped track is not sample accurate regarding track placement in a DAW compared to a reference live recorded track from the Helix's USB out 1 + 2. At a sample rate of 48 kHz, there is a negative latency of 91 samples or about 1.9 ms for the reamped track.
  16. Hey, so, upon further research I found out that the USB channels sent to the Helix for reamping get attenuated by 6 dB once they enter a signal chain. The RMS values of the reamped tracks hover in the area about 5.7 to 5.9 dB in reference to the live recorded track, but I think that offset to the mentioned 6 dB might be due to the modeling algorithms. This does only happen while using USB for reamping. The old school method - sending the signal from an audio interface (+ 4 dBu) into the Helix (input set to instrument) - works as it should, no level attenuation happening. The via USB reamped track is not sample accurately placed in reference to a live recorded / DI track from the Helix. At 48 kHz sample rate it shows a negative latency of 91 samples or about 1.9 ms. I assume that the latency the Helix ASIO driver is reporting to the host is somewhat off. Until these issues get adressed in one of the future firmware updates, the workaround would be to raise the level of the USB channel which is sent to the Helix for reamping by 6 dB using the fader or gain setting in a DAW. Another option would be to add a gain block to the Helix preset in question and and to raise the level by 6 dB. If the reamped track should show up sample accurate in the DAW in reference to a live recorded track / DI track from the Helix, it has to be pushed by +91 samples or +1.9 ms. These values are only valid at a sample rate of 48 kHz. For any other sample rate they need to be recalculated accordingly. I'm gonna add this issue to the bugs thread and will open a support ticket.
  17. Hey phil, thank you for your reply. I did some extensive testing meanwhile. It turned out that my initial test setting was flawed. I figured that the mentioned 2 to 2.6 dB level difference between the reamped and the live recorded track does only happen within that preset I was using. It differs from preset to preset, using one of my own presets delivered a difference up to 5 dB. I had to take the amps + effects out of the equation, so that there was only input and output left. I then recorded a DI track from incoming USB channel 7 simultaneously with a track that captured the USB 1 output of the Helix LT. After that I reamped the DI track, sending it to USB 3 in of the Helix and tracking the USB 1 output again. The DI track and the simultaneously recorded track were equal in level and tone, they both cancelled out when doing a null test. The reamped track was equal in level but didn't cancel out with neither the DI nor the simultaneously recorded track doing a null test. This could be due to some modeling algorithm, but since there was nothing in the signal chain except for input and output, I'm not sure if that would make sense. It would make sense if at least an amp was involved and the nonlinearities are taken into consideration. Result so far: Recorded DI and live track are the same, reamped track is somewhat in the ballpark of the others. Here comes the interesting part. This result changes completely as soon as I try it with a preset/full signal chain. Comparing the live recorded signal with the reamped signal always shows that the reamped signal is a few dB lower in level. You suggested sending the DI track via USB 3 + 4 instead of 3 to the Helix. That results in a level rise of the reamped track that puts it near the level of the live recorded track, but it still sounds different regarding reaction of the effects and amps to the guitar (distortion at heavier picking for example). I always interpreted the parts of the manual where it says "send it to USB 3/4" as "send it to USB 3 or 4". I've been watching some videos regarding that topic on YouTube lately and all the guys (including the Line6 guy) where sending it to one USB channel only so I suppose that's the way it's intended to work. As it seems, something is happening/not happening to a signal that goes via USB to the Helix LT. As soon as processing is involved (and I can't say which parts of the signal chain are responsible for it), it gets altered in a way that the reamped sound is lower in level and doesn't sound the same as the live signal. From a gut feeling I'd say that the level settings on the components of a signal chain are not computed or not computed in the right way if an USB signal enters the processor. This happens to all incoming USB signals, I tested it with channels 3 - 8. I would love to make sure that I'm not missing something in my setup that causes this. It would be cool if someone could do a test and tell me if she/he experiences the same thing. Just record a track with the DI out (input channel 7 on your DAW) and another one with the output of the Helix (Input channel 1 and/or 2 depending on if you record in mono or stereo) at the same time. After that, create a reamped track (use the just recorded DI track for that - set the output channel on the DI track at your DAW to 3 and the input at the Helix to USB 3/4 and record that output onto a new track, input comes from channel 1 and/or 2 again). Please check if the level of the reamped track is lower and/or sounds different than the live track you've been recording simultaneously with the DI track. Thx!
  18. Hello there, I'm new here - nice to meet y'all. I'm a soon to be 50 years old/new guitarist from Germany. I'm trying to make a really great first impression by reporting a possible bug.... Kidding aside, I stumbled across the following issue: I tried out the reamp possibilities on my Helix LT. During that, I discovered that the DI Signal which is send to the DAW via USB channels 7 + 8 is lower in level than the signal that is running through the processor while playing. I recorded a DI track from USB channel 7 and tracked the input from USB channels 1 + 2 at the same time. After that I added a track on which I recorded the reamped DI signal, this was sent to USB Channel 3 to the Helix LT through the same preset and settings. The reamped track is about 2 to 2.6 dB lower in level and lacks a little bit of high frequency content, it's not as 'crisp' as the recording of the 'live performance'. This difference in level is enough to change the behaviour of the amp + effect models in a way that they start to sound different from what I'm hearing while I'm recording. I'd tend to think that the DI signal should be an exact copy of the signal that runs through the virtual circuits so that the sound of the two tracks would be the same. Anybody else experienced this ? Thx!
×
×
  • Create New...