Jump to content

xmacvicar

Members
  • Content Count

    196
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by xmacvicar

  1. So with Helix recording into Logic Pro X - I record dual tracks (Helix stereo track on 1/2 and the dry track on USB7). For all I know, there is no way to control the USB 7 volume other than the guitar pad input? The reason I ask is the signal is way to hot. I am using pre fader metering to check levels in Logic Pro X as per instructions in this video Pre Fader Metering My track is basically full blown clipping at 0DB like so: even reducing the gain on the track inspector by -30 db is not solving the issue. How would one rectify this?
  2. I agree too. I get that everyone advocates that you really have to level patches by ear and that's even joked about in the name of the release for this particular firmware - however I'm not sure what the meter's tell me at all in its current iteration
  3. They are in the output block
  4. Last night I was having odd behaviour from my Helix. I was testing a bass with really noisey pickups and I was playing in a bass preset and it was super noisey and I was picking up electrical interference for sure. To test I plugged in my LTD Eclipse (another guitar with active pickups) and I was getting the same electromagnetic noisey. If I turn away, it would clear up, but it was not great - as I played the guitar, the buzz was loud (all signs online point to the wiring being the issue) but this guitar is BRAND new and was working perfectly 2 days ago. Eventually the signal sounded like it was 'dying' - that sound as if it was cutting out or limp, no drive, no feeling. I was freaking out. I thought my Helix was having electrical issues or about to break. Now today, its totally fine. I am kind of worried as I don't know if there is actually something wrong with it, or if it was a one off? I did all the things like try new cables, plug into different outlets, etc. Anyone have any idea what may have been happening?
  5. Adding to this..I wish HX Edit employed more "computer" features. For example, we have 1024 presets - I would love there to be filters where I could say "show me all presets with Cali rectifier" amp models, etc.... or the same thing with FX. That way, across all my preset banks, HX edit would show me those patches. If I am feeling in a 'metal' mood, I can show all my 'metal' presets vs. country ones, etc.
  6. I also never seem to get one with dual amps - never a massive 'improved' sound to justify doing it
  7. How are you doing this in Helix? A separate eq block like the cali eq ?
  8. xmacvicar

    Helix 2.9

    Had to turn off email notifications for this thread :( I just want 2.9
  9. It really is a night and day difference. I'm going to do a sound clip comparison and host it here. This would be the mesa helix 4x12 vs a third party IR
  10. xmacvicar

    Helix 2.9

    Lol. Farce buck
  11. I will say for the longest time I was against IRs. I figured dialing In great tones with built in cabs was possible and ir was not needed. Well lollipop. Tonight I was working with my Adam Jones tool patch and I loaded up an IR based on a Mesa cab and holy lollipop. Helix came to life. Doing an A/b comparison is night and day. Built in cab sounds weak and lifeless. IR patch sounds huge and alive. Just no comparison!!!
  12. Please see: https://imgur.com/NEZ14xg The native input shows that its well below hot, but the fader shows me just about to hit 0.....i am a recording newbie - just hoping for an easy explanation?
  13. Hey folks! I am finally diving into IR's after all this time owning my helix. Seeing that all these IR packs you can purchase come with often, hundreds if not thousands of IR's, how do you go about testing all possibilities here? Given that you can only load so many IR's on the Helix itself. Do you just keep replacing IR's in the same slot to test? Eventually want the IR library in the helix to be your 'final' set of IR's, not a bunch of test ones?
  14. Took it to my guitar shop. We discovered the bridge pickup (by tapping on the outer housing) is pinging non stop - obviously something not happening on other guitars or on the neck pickup. They are gonna disassemble and adjust or insulate it or something? Either way, waiting to hear back from them!
  15. I have foam behind the nut right now, as well as a GruvGear Fret Wrap. I haven't tried anything with foam near the bridge yet....I'm taking it back to my local guitar shop where I bought it 2 days ago - they can take a look for me as well!
  16. Just tested that - appears its only the bridge that is causing the excessive ringing - the neck is as quiet as can be
  17. This is def an issue with the guitar and not the helix. Something is loose inside, or the pickups are microphonic or something.
  18. Its the guitar....no other guitar is doing it. If I use another amp model, such as the Revv for example, the loud ringing persists with the LTD but no other guitar has the issue.
  19. I just got this new guitar LTD EC1000 VB with EMG 81/60 When using the Badonk for that brutal metal crunch, I get this insane ringing on palm mutes - shown in this video: https://www.youtube.com/watch?v=5Fav1TAe6vM Other amp models don't seem to be pronouncing the ring the same way.....is it the guitar? The helix? Both together? I am just trying to get some help narrowing this down. Thanks! *attached the preset I was using* DEATH2.hlx
  20. Alex Strabala who is a big helix user, mentions this on his site: All of my presets are designed to be used in stomp mode on Snapshot 1. Some presets have an ambient volume swell pad sound on Snapshot 4. This allows you to quickly and seamlessly switch to ambient parts without sacrificing a footswitch in stomp mode. The rest of the Snapshots are unused by default. Feel free to modify the other snapshots to best fit your workflow. I am not understanding that flow on the helix. Can anyone explain that? In stomp mode if I am using all 10 stomps (which he is) you would have to press mode, switch to snapshot 4...which doesn't sound at all user friendly?
  21. I think this is it? Snapshot Bypass Helix Floor, Helix Rack/Control, Helix LT, Helix Native, HX Effects, HX Stomp, HX Edit There may be situations where you don't want Helix's snapshots to control a particular block's bypass state; that is, you'd prefer to turn it on and off manually. For example, you may want manual control of a boost pedal at any time without worrying whether a particular snapshot might turn it on or off. Depending on your type of Helix/HX product, follow the procedure below: Helix Floor/Rack/LT—Select a processing block, press ACTION, and set Knob 5 (Snapshot Bypass) to "Off" to disable snapshot control of that block's bypass state HX Effects—Select a processing block, press ACTION, and press the "Snapshot Bypass" switch to disable snapshot control of that block's bypass state HX Stomp—From Edit view, select a processing block, press ACTION, press PAGE >, and set Knob 3 (Snapshot Bypass) to "Off" to disable snapshot control of that block's bypass state Helix Native/HX Edit—Right-click (Mac: control-click) on a processing block and uncheck "Snapshot Bypass." Alternatively, right-click (Mac: control-click) the Bypass button to uncheck "Snapshot Bypass."
  22. Just hoping someone can help me. I remember when @Digital_Igloo showed off the upcoming 2.8 many months ago, there was a feature about when adding a new block, its just bypassed by default and not on for all your snapshots. How do you achieve this on the Helix? Its unclear to me. Thanks!
  23. Anyone else not a fan of the newer "save to library' function of HX edit? I liked previously how it was one single click to save. Now its an entire modal, and needing to press save again to quickly save changes. Not a huge deal, but one of those little greviances of software changes
  24. As per instructions, I updated HX Edit to 2.82. I do have a backup of my helix. I connected to L6 Updater and only see 2.81? 2.82 does not appear. I was on 2.80 and I updated to 2.81 thinking that would get it to show 2.82 next, but I still only see 2.81. What am I missing?
  25. Interesting. I am glad its working, however, if it was set to multi, this should have also controlled the signal over digital L6 Link, so that kind of doesn't make sense? Scratching my head there haha
×
×
  • Create New...