Jump to content

Search the Community

Showing results for tags 'fuse'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Community Support
    • Multi-Effects Units
    • Variax Instruments
    • Amplifiers
    • Computer Based Recording
    • Live Sound
    • Pedals/Controllers
    • Dream Rig - Line 6 Product Integration
  • General Discussion
    • Share your Settings
    • Line 6 Lounge

Categories

  • General FAQ
  • Tutorial Videos
  • Effects/Controllers
    • HELIX/HX
    • Firehawk
    • FBV Controllers (MKI / MKII/ 3)
    • M5 / M9 / M13
    • JM4 Looper
    • Stompbox Modelers / ToneCore
    • ToneCore Development Kit
  • Recording
    • Helix Native
    • Echo Farm/Amp Farm
    • POD Farm / POD Studio / TonePort
    • Computer Audio Set Up and Troubleshooting
    • Riffworks Line 6 / Standard Edition
  • POD
    • POD HD Family
    • POD HD500/HD500X
    • POD HD300/400
    • POD X3 Family
    • POD 2.0 / PODxt Family / Pocket POD / FloorPODs
  • AMPLIFi Series Products
    • AMPLIFi 30/75/150/TT
    • AMPLIFi FX100
    • Videos
    • Tone Creation
  • Amplifiers
    • Spider V
    • Powercab
    • Firehawk 1500
    • DT50/DT25
    • Spider IV/Spider Online
    • Spider Valve
    • Spider Jam
    • Vetta
  • Live Sound
    • Relay/XD-V Digital Wireless
    • StageScape M20d Mixer
    • StageSource Speaker
  • Guitars
    • JTV / Shuriken / Variax Standard / Workbench HD
    • 1st Gen Variax Guitars / Bass / Workbench
  • Mobile Products
    • Sonic Port devices / Mobile In
    • Mobile Keys
    • MIDI Mobilizer
    • Mobile POD app
  • Dream Rig
  • Legacy Products
    • Amps
    • POD
    • Effects and Controllers
    • GearBox
    • Line 6 X2 Digital Wireless

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Registered Products

Found 5 results

  1. Literally desperate at this point guys,if anyone could help me find a site where to buy the fuse you would be a lifesaver.
  2. StageSource L3M not turning on when powered up (have checked cables, etc). When we switch on we get a faint electrical click, but no lights on the back of the unit (as is the case on the other working unit we have). Help will be greatly appreciated as currently in Albania using them with a Kids holiday camp Mark
  3. smalltownsounds

    Pod X3 Pro replacing fuse issue.

    Hi there, I have the Pod X3 Pro. I have had what I believe to be the same issue in this legacy post - http://uk.line6.com/supportarchivenew/thread/65387/ It did the pop thing and then died and didn't switch back on. So, as well out of the warranty, and I as I imagine costly to send to the nearest service centre in the UK, I decided to follow the advice on that post. Everything worked fine as expected.... I found the fuse OK, But - as per the image below it seems to state 2.5amp slo-blow fuse is required. However the moderator posted in that post to replace with a 1 amp slo blo fuse. So, I've scoured the web a little bit and it appears other people have mentioned 2amp fuses, 1.5 amp fuses as replacements etc for the x3 pro!... So, I am all confused now!! Which fuse should I use to replace with?? Frustratingly, I actually have a 1amp, a 2amp and a 3 amp slo blo fuse lying around,!! Just not a 2.5 amp one!!.... So, which should I use? One of the 1,2 or 3 amp ones - or look around to see if I can get a 2.5 amp one??. It seems a lot of work for a 50 pence fuse! ;-) Thank you in advance G.
  4. My DT25 head has started blowing the tube protection fuse. This happens shortly after i turn it on. I have noticed the following before it happens: 1. I turn on the amp. 2. wait for a minute or two. 3. The amp starts making crackeling noice and one of the power tubes starts glowing brightly (like it has a hot spot all orange) If I don but it in standby at this spot, then the fuse blows. Do I have a faulty amp or do I just need to replace the power tubes ? Any help is greatly appreciated.
  5. Hi. I need to replace the fuse in my Spider IV 120 - does anyone know exactly which type of fuse is needed? Thanks Brian
×