Jump to content
pwik

DT25 head popping noise

Recommended Posts

My DT25 head is making a popping noise. It just started happening. It takes a couple minutes after turning it on but does it whether I am playing or not. Also can hear it when the volume is turned down. The head is about 18 months old and used regularly for band practice. Any ideas? Tubes maybe?

 

Thanks!

Share this post


Link to post
Share on other sites

Well I pulled the tubes out of my DT25 combo and put them in the head (and the head tubes in the combo). No popping with the head anymore but the combo started so I guess it's the tubes. :)

Share this post


Link to post
Share on other sites

Yep, popping noises that begin once the tubes warm up a little is a pretty good sign that they're on their way out or not seated very well.  Cool that you had another DT to experiment with.

Share this post


Link to post
Share on other sites

The tube pins can become oxidized and you can get some "bug zapper" sounds in the back ground. pull the tubes, clean the pins and the sockets and re-insert them...Just make sure that you do it when the amp is unplugged from AC and you note the sockets the power tubes came from so the bias adjustment  stays in check.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...