Jump to content
Gareth1

Crackling 150

Recommended Posts

So, my amplifi 150 is crackling. I've tried everything to sort it out, new power lead, reset to factory etc, but still it fizzes and crackles. It isn't noticeable when I'm playing, but just when I'm not playing or I'm listening to music quietly thru it, there it is! Amp is on a hardwood floor, there's nothing around to create static etc, so it's not that.

Anyone have any ideas?

Share this post


Link to post
Share on other sites

does it crackle without your guitar plugged in?  And does it crackle with your guitar plugged in and you touch a finger to the mounting screws on one of your pickups?

Share this post


Link to post
Share on other sites

It crackles with or without a guitar plugged in....It happens whether I'm using my strat, variax or acoustic. Most frustrating!

Share this post


Link to post
Share on other sites

if it is crackling without a guitar plugged in, then perhaps you have noise in your A/C line that is making its way into the amp.   Do you have a UPS you could try plugging your amp into, then the UPS into the wall, and see if the crackling diminishes?  Many companies sell power line filters to remove AC noise, but many times a UPS filters well enough to see if that is a problem.

Share this post


Link to post
Share on other sites

My first 150 (new) had this problem in the upper left speaker.  Nothing in the input, nothing connected to Bluetooth, all amp controls set to zero/min.  I tried several outlets in the house. Always upper left speaker; I guessed loose connection.  Is your crackle from the same location?

 

I was able to return it for a (new) replacement.  The seller must have agreed with me, as I had no issue getting a replacement.  No issues with the new replacement 150.

Share this post


Link to post
Share on other sites

sorry for the delay.... i'm at a bit of a loss as to where it actually is in the amp. It may be that the mains feed is dodgy (old house!) I'll keep trying! thanks for your assistance guys! In other news, I've ordered a Helix & an L2M which are coming at the end of this month, so my Amplifi woes will not be around for long once I start playing around with that! I'll get back to my Amplifi after I've explored my new toys!

thanks again! 

Share this post


Link to post
Share on other sites

Gareth1,...

Do you use a pedal controller with the AmpliFi?

If so, what kind is it?

Take it to E&M Electronic in Milton Keynes, they're an authorized service center.
They'll know what to do.

 

Share this post


Link to post
Share on other sites

thank you for this.... it somehow managed to sort itself out! very odd! I'm not using any foot controller, i just run it from my ipad. i shall keep an eye on it, & hopefully itll be just fine now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×