Jump to content
jakeman19

Please PIN Variax updating Via Helix NOT SUPPORTED

Recommended Posts

Line 6  moderators, please pin this topic of Variax users trying to update them via Helix ISN'T supported at this time. I've seen all to many posts here and on multiple Facebook pages of people asking why trying to update their Variax guitars(or Workbench) using a Helix doesn't work. Yes, it was missed in Helix and may come in a future firmware update in which at that time you could then delete the Pinned post. 

 

Jd

Share this post


Link to post
Share on other sites

Is this still the case in September of 2019? I recently got a used JTV-59 and am unable to update the firmware on it using my Helix. It came with nothing other than the guitar and case. I bought the cable and a battery but that's all I have for now. The USB box is pretty damn expensive for what it is - around $100 from what I've seen. I sure hope I can do without one but I would like to be able to manage the firmware.

 

Share this post


Link to post
Share on other sites

Anything prior to JTV with firmware prior to Flash v2.00, won't update through Helix.

Share this post


Link to post
Share on other sites
23 minutes ago, psarkissian said:

Anything prior to JTV with firmware prior to Flash v2.00, won't update through Helix.

 

Does this mean that a JTV and flash v2.00 *will* update via the Helix?

Share this post


Link to post
Share on other sites

It should.

Earlier Variaxes like 500 and 700, or JTV with v1.70 or v1.90 won't.

In short, anything using the HD Flash versions (v2.00 or higher) should be able to update through Helix.

 

Share this post


Link to post
Share on other sites

So I don't need to use the VDI interface box that originally shipped with the JTV's? I don't have one and would prefer not to buy it unless I absolutely have to. I have tried to use the Helix to update firmware and it always errors out. I'm not sure what the reason is if I don't actually have to use the VDI box. My path is JTV > VDI Cable > Helix > USB Cable > Line 6 Monkey running on an iMac. Errors out with a MIDI error but I'm not using MIDI for anything while I'm trying to do the update. If anyone has any advice, I'm all ears...

 

Share this post


Link to post
Share on other sites

MIDI Time Out errors? iMac? Pre OS X? That would be a problem for the Helix.

- iMac with OS9 may be too old for the Helix. Check the Downloads page for OS compatibility.

- Make certain there are no USB hubs connect while attempting updates.

- You may not be using MIDI, but the MIDI Time Out label is general data time out error.

 

You may need to use the interface kit for this one, as it is not OS dependent.

 

Share this post


Link to post
Share on other sites

Actually I'm running the latest OSX operating system on the iMac. Sorry if that wasn't clear. I wouldn't think that should be an issue. Not clear on why I'm getting that error. Maybe there's something tying up the MIDI ports that I'm not aware of.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×