Jump to content
Vickozg

JTV-89F won't turn on

Recommended Posts

Ok, I bought new JTV89f, it plays like a charm if used as pasive guitar. But I cant turn on, modality knob "clicks" when pushed in but nothing happens, no light around it so I can see it's turned on (it's pluggen in speaker, so cable is in guitar). Battery full, it's the only thing I can test on it, all green little lights show. Tried to set new firmware over Monkey, but "guitar side" of usb hub is blinking red all the time and it wont' recognize it. Usb side i constantly green. Any ideas?

Share this post


Link to post
Share on other sites

This could be 2 issues.

 

1)If the guitar side is blinking red, it's not "seeing" the guitar. I seem to recall that you need to have a 1/4" guitar cable plugged into it for it to "see" it. I could be wrong about that but don't quote me.

 

2) JTV Variax's are semi notorious for the model knob to not push the metal post it's on down far enough. Carefully take the model knob off using the spoon method. Be sure to protect the finish of the guitar better than the picture. Maybe use washcloths. Then push the metal post down to see if the models will now engage. If they do, you need to put something in the knob's post hole to allow it to push the metal post down further.

 

That's all I got.

spoons.jpg

Share this post


Link to post
Share on other sites

Thanks, but I tried both oh them. I even  tried few cables, and managed to pull knob out and slowly pressed it in. I can hear "click" when pushed down, but no sign of life. I wanted to update firmware, but Monkey/Workbench won't recognize it, probably because it's off.

Share this post


Link to post
Share on other sites

@Vickozg, 

 

It can be one of four things. This won't be something you can fix yourself. Looks like it's still under warranty. 

Since you logged a Support ticket, they will let you know what the options are. I will be following this post. 

 

Also, in the video you are using a 1/4" TS tip plug. Try using a guitar cable with a 1/4" TRS tip. This is a guitar 

with active electronic, it works better using a guitar cable with a 1/4" TRS tip. 

 

Share this post


Link to post
Share on other sites

Plugging a 1/4" jack into my JTV-89F worked for usb recognition.

I have found that the guitar selector switch has to be set to Acoustic to turn it on.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×