Jump to content
Sign in to follow this  

Spider V20 Ruined by Firmware Update?

Recommended Posts

Hi, all,


I heard buzz about the new Mk II firmware update for older Spider V models and thought I'd give it a chance with my Spider V 20.


I couldn't find any downloads for this firmware update under the Spider V 20 category, which should have discouraged me from proceeding. However, a different thread showed the firmware update listed under the Spider V 240HC. Assuming the download listings were just quirky, I decided to download that update and install it via the Line 6 Updater. I had to manually select the file for the updater to install it.


The updater didn't complain, just installed the firmware and restarted my amp. However, the update seems to have broken my amp--when I turn it on, it crackles a few times, and all three FX buttons are orange. Neither my Spider V Remote nor my Line 6 Updater software will recognize that the amp is plugged into my machine.


I have tried two methods of factory resetting that I could find online:

1. Hold down all three FX button and press Save.

2. Hold down FX2 and FX3 and press Save.


Neither method worked.


Have I bricked my amp? If not, is there some info about resetting it that I'm missing?

Share this post

Link to post
Share on other sites

The 2.0 update doesn't apply to the Spider V 20. I'm not sure if there's a way to force the V20 into Update Mode. I would think you could reflash it with the 1.00 firmware to get it back up and running. If you're not having any luck, try opening a support ticket. They should be able to help you. Most likely it's not really bricked.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this