Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Pod Go Firmware Mishap


Recommended Posts

I was trying to update the firimware on my pod go and after the laptop restarted something didnt go right. So right now when I turn the Pod go on, I get just  red bean and nothing loads up.

Pod Go edit doesnt recognize that it is connected. Ive tried the power off and holding page> and also the poweroff and hold c and d. i cant figure out how to get it back to factory set up or even getting some thing to update to the lpc. or whatever it shows up as usb storage device. i just got this today and was wanting to update it before ttrying it out. now its jsut a brick.

Link to comment
Share on other sites

Hey Clutchman,

I have the same issue.

You can try to recover using the Line 6 updater.

Disconnect USB cable from PC.

Open the updater.

Turn off Pod Go and restart while holding the PAGE right button.

Let go of button when you see a white screen.

Plug USB cable back in.

Updater should see something.  If not unplug and replug.

If it sees the POD select it.

It will take you to the Firmware update screen.

Choose the latest update.  Click UPDATE. 



if your lucky, it will download and install the firmware.


Mine fails every time on 3 different Windows machines. 

There appears to be a driver error but I do not know if it is the POD GO or the driver itself. 

The driver error appears in the Windows device manager under the Sound,video and game controllers section.


Good luck.

Im sending  mine back for a replacement.



It took multiple attempts. Like 50, to try to and force different drivers,firmware, etc.

Finally it was able to install.  

I was a computer tech for many years and have the experience to mess with the drivers.





  • Like 1
  • Upvote 1
Link to comment
Share on other sites

I am having the same issues, and have tried loading Pod Go Edit onto 3 different computers (2PCs: WIndows 7 and 10, and a Mac Mini) and am still unable to get them to recognize that the POD Go is connected (although it does show them in the Device List). I've submitted a ticket to Line6 Support. Is there anything else I can consider doing?


Link to comment
Share on other sites

Focus on getting the LPC drivers loaded. You can click on the properties to see if the drivers are loaded or not. Get the drivers from line6 but leave your GO unplugged from the computer. After downloading them check the properties again and if it’s good it will say line 6. Then connect the Go and hold the right page and power up. Everything goes right should be go to download the firmware from line 6

Link to comment
Share on other sites

Thanks Clutchman. Still a "no go" for me. On my WIndows machines (Windows 7 and 10), when I plug in the Pod Go (after starting it in "update mode"), I can see in my "Device List" that a device called "LPC" pops-up. but nothing further happens...Pod Go just stays on the white screen and the Pod Go Edit app. says "No device connected". If I unplug the USB cable...the "LPC" device disappears from my device list. I've literally tried this reboot, replug process 50+ times and Pod Go just remains bricked. I've tried uninstalling/reinstalling the Pod Go Edit app. (on all three computers) and still not working. On my Mac Mini...I get no response from the Mac indicating that the Pod Go has even been plugged into it.


If I can ask, when you say "click on the properties to see if the drivers are loaded"...what exactly do you mean? What should I click on? Thanks in advance for any further insights.

I've heard back from Line6 and their initial response is that I may need a "powered USB hub" for my Mac to recognize the Pod Go...which doesn't seem to make much sense, nor do I have one of these devices. I'm also waiting to hear back from Sweetwater support. Just a bummer to have new gear that's inoperable. Oh well...first world problems at this stage. ;-)



Link to comment
Share on other sites

When you go to devices on your computer and you see the Lpc shown, look for the properties tab for it. On pc it says drivers etc...if it shows none that means you will have to down load the drivers for the Lpc basically the drivers for the go itself. On the line 6 pod go download software page try downloading the Mac version of the line 6 updater and the line6 drivers v.1, something. Do worry about having the pod go edit program running for the time being while doing this. See if running the downloads work by checking the drivers on the Lpc again. If it works you should see line 6 on the description for the Lpc. Just toy with it and hopefully you’ll get it and you can get the go back to factory and it will be current on the firmware ware. 

Link to comment
Share on other sites

  • 1 month later...

I have the same issue when trying to update to Firmware version 1.11.0 with my Windows10 machine and the POD Go Edit software:

Update failed, the device cannot be booted anymore and stops at the bean-screen.
After the failed Update, the POD Go Edit software no longer recognizes the device.

The Line6 Updater can recognize the device when i start it in update mode (hold Page right while switching it on), but updates to Firmware v1.10.0 or 1.11.0 fail here, too.
The message being displayed right before the failure is "Please wait. Loading important post-update instructions"
The device remains in a broken state though.

UPDATE: After turning the device off, unplugging it and waiting a couple of hours I decided to try again. So I turned it on again in update mode (as I did before) and connected the USB to my PC (as I did before) and tried to update to Firmware v1.11.0 via the Line6Updater (as I did before) the Update finally went through! So it works again. But the update-experience lets me think twice before the next update... Line6 should definetly investigate why this fails so often!

TL;DR: Retrying x-times with update-mode and Line6Updater "fixes" the issue

Edited by asturm
Update worked after a couple of retries
Link to comment
Share on other sites

18 hours ago, asturm said:

 I turned it on again in update mode (as I did before) and connected the USB to my PC (as I did before) and tried to update to Firmware v1.11.0 via the Line6Updater (as I did before) the Update finally went through!


Almost same thing happened to me.  The key to me seemed to be closing the updater after a failed attempt.  The message says to just retry, but I retried multiple times and it didn't work multiple times.  But it worked after closing and unplugging everything...  Maybe it was all fluke though, but since fails all happened rather quickly (maybe even quicker each time?), I think closing updater is indeed key...

Link to comment
Share on other sites

  • 4 weeks later...

Hello there,


I've just installed Edit today after I purchased the Pod Go. It's already on 1.11 but the Edit prog does not recognize the Pod despite the fact all the drivers are updated.


Regarding all the previous answers I still don't figure what I should do. Contact the seller and ask for an exchange? 




Link to comment
Share on other sites


Before asking for an exchange you can try a differen USB port on your PC. Part of the problem might be unpowered USB ports.
So try plugging your device into one of the ports directly on the motherboard (backside of your desktop PC) and see if it is recognized then.
When using a laptop, you may have to use a port on the left or right side instead (usually the USB ports directly connected to the motherboard are on the same side as the side fan). Do not use any USB-hub if possible.
If the Problem persists, try cleanly reinstalling the drivers and scan for new hardware.

best regards, Adrian

Link to comment
Share on other sites

@asturm I've tried this and it semi-worked : it recognized the Pod and Edit launched but disconnected after like 10 seconds. So I tried with an old USB cable and... it works perfectly. It was so obvious I did not event tried this.... Luckily I had such this cable.


Thanks for your help! 


Cheers from Switzerland

Link to comment
Share on other sites

  • 2 months later...
  • 3 months later...
  • 1 year later...

Hi to all!


Same thing happened to me, even after repeated attempts at powering the Pod Go on while holding down the Page Right button, I kept getting the error message that the update failed.

The key, and I repeat THE KEY to updating the Firmware is to exit the Line 6 Updater, reboot it, and once you do that you will see a status bar appear (which did not appear in my previous attempts) as it's loading the new Firmware.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...