Jump to content
PerS

Going for PowerCab 112 Plus…

Recommended Posts

Hi

I’m on my way to invest in a PC+ and have some questions I need to wrap my head around. So, turning to the expertise. And sorry for a long post…

 

Background – Have used Line6 gear sin early 90’th and have my Helix LT for 3 years now and witch I’m super happy with. My guitars are fairly standard, Gibson LP, a Strat, an SG mod’ed for slide and my Variax 500 mainly for acoustic (and occasion same electric half acoustic)(don’t use VDI, use the XPS). Blues and rock are my areas of interest. Cheat sometimes on some jazz…. In front of my Helix I have a small pedalboard with some pedals I can’t live without, in order – Shure GLXD16 or Variax /XPS -> Compressor -> EP-boost clone -> BD2-> NS2 -> Lehle ground loop eliminator -> Helix. This goes to a mixer, to a power amp and to my speakers/monitors.

So, what I like to do is to run the “Helix chain” into PC+ via L6 Link. I will connect the PC+ via USB to my PC for recording and run the PC+ editor (Helix is already connected). Will use L6 Link to control and audio to the PC+. Just by the book I think (page 23 in the manual), no special about that I think. I will set the Global on the PC+ to be controlled from Helix and store settings per patch (jepp, one of those who reads the manual…).

 

My questions

  1. Acoustic – What is your experience with acoustic guitar direct PC+ and Helix/PC+? I intend to use my Variax XPS/XLR to the input of PC+ in FRFR mode and Variax via Helix and XPX/1/4 with an acoustic patch including some compression, preamp, reverb etc., maybe a good IR. Two different applications but will give some acoustic option. I feel safe to use the Helix for acoustic, do that today. It’s together with PC+ that is the main question. Any comment/suggestion/advice on that? How do you use the PC+ for acoustic?
  2. Electric - Another notice I made when searching PC-patches, very few used IR’s in the PC+ (found one, again with the risk I haven’t got all hits…). IR’s on Helix or speaker modeling on PC+ was the majority. Is there a disadvantage to load the IR’s on the PC+? How do you use it?
    My own comment/reflection are if I use standard cabs or IR’s I use FRFR-mode. That give me better control of the signal chain, the Helix will feed the final processed signal to the PC+ (delay, reverb, eq compression…). To use IR’s loaded on the PC+ the IR must do that final touch, page 9 in PC-manual the control room will be FRFR. Have some trouble to wrap my head around this application.
    If I use speaker mode on PC+, no problem. Just leave cabs out in the Helix.
    Feel free to correct me if I get this the wrong way… or over thinking this.  
  3. Referring to previous point - Has anyone used the Live Ready Sound IR’s for PC+, https://livereadysound.com/impulse-responses/. This is supposed to be optimized to be used in PC+. If you tried it how does your signal chain look like and how did they sound? Any other IR’s optimized for PC+ you know of and used with a good result?
  4. Witch mode do you prefer/use, Flat (LF Flat/LF Raw)/Speaker/IR? Or are you using them all and maybe for different applications/style? In what occasion do you prefer one over another? Today I use both standard cabs in the Helix (think they are pretty good) and IR (have a few I use now and then) depending what I’m after. The PC+ is a bit different as the speakers “ends up” in the end of the chain, after delay/reverb/studio compression etc. Asking because I want to try using the full potential of the PC+. So, your experience is more than welcome. My patches are not very big/complex, how hard can it be to get a good blues/rock tone :-)… so no DSP-issues for now, but like to understand when/if IR's add anything in the Powercab.
  5. Today I have a template I use to make my patches, it’s a modified version of the one Jason Sadites published. Anyone using a template for their Helix/PC+ creation? And want to share it?

 

As you probably understand, I'm trying to value Power Cab against investing in a better FRFR speaker. Speaker mode in PC+ is definitely a driver. IR’s in PC+ not so much at this point. FRFR absolutely, but I can get a FRFR-speaker for less money.  But I might be corrected… that’s what I need you for :-). There are some more questions but let’s add them if needed.

English is not my native languish so be gentle with me… 

 

//Per

Share this post


Link to post
Share on other sites

1) Acoustic - No experience

 

2) I think of it this way - with the IRs loaded on the PC+, you're hearing what the engineer in the Control Room hears - the sound of a mic'd cab in another room, at the end of the guitarist's signal chain. With the IR loaded on the Helix as the last block in the signal chain, you get the same thing. If you add stuff (EQ, Compression, Reverb, Delay, etc) AFTER the IR, YOU are now the Engineer in the Control Room, adding Post effects. If you want an "Amp In The Room" experience, use the PC+ Speaker Emulations. If you're trying to duplicate a recorded sound from a studio produced album, loading the IR on the Helix and adding Post Processing effects might be a better way to go.

 

3) LRS - No experience of the enhanced for PC+ IRs, but wasn't thrilled with the freebies.

 

4) As for which IR Mode to use, Flat is FRFR with the HF Driver; LF Flat is the Eminence Speaker w/o the HF Driver, EQ'd to be Flat; RAW is the Eminence in it's natural state - as if it was just another 112 cab w/o HF Driver or compensatory EQ. Use the one that sounds best in your application. I'm a simple guy, not obsessed with getting "that perfect tone". I use the Speaker Emulations, then record with an XLR from the PC+ to the AI (Scarlett 18i20) and into Reaper with whatever PC+ Mic sim sounds best in that particular scenario. I've also tried taking an additional XLR direct from the Helix (IRs on the PC+) and using Two Notes WOS and their cabs. Meh. Sounds good and all, but for my purposes (and lack of patience) I'm not sure it's worth the trouble. YMMV. Try it!

 

For simple in the room jamming I also run another XLR from the Scarlett to my FRFR112 for a fuller sound in the room, and to get an approximation of what FOH might be putting out to an audience. I'll only be using the FRFR112 for the fuller sound until I get another PC+. Then I'll have STEREO! HMM...STEREO GOOD!

 

5) I have a number of templates, starting from the basic JS Template, for various applications. Templates are a great beginner's tool, saves lots of time when trying out things, but I have found that the more I use my Helix, the more I know what I like, and the more likely I am to just start from scratch.

 

BTW - Your English is EXCELLENT! As a typical American, I only speak English, and American English at that! Be proud of yourself!

 

***See Edit in Point 2

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi rd2rk, thanks for the replay and your answers... much appreciated 

 

I start at the bottom – Well me, Google Translate and MS World are good friends :-). It will almost make you speak Swedish too :-) (Just a curiosity – A few years ago me and my former girlfriend was going to Florence, Italy. To do the “invitation” a bit more fun I wrote the “invitation” in Swedish, translated it to Italian and sent it by mail. She had to translate it back. Unfortunately, I did not check how the revers translation came out… It was not the reason she is former girlfriend, but we had a god laugh. Sentence is – check the translation both ways…).

  1.  Acoustic – I think I feel safe there now, found some similar topics using it for playback. It will work just as any other source and I use FRFR-mode.
  2. Agree with you there, that’s how I see it too. I just wanted that confirmed in case I missed something. The big plus with PC+ as I see it are the “Amp in the room” as another tool to sculpture tones and also get a “mic’ed” output to FOH. I don’t mix that up with FRFR, two different applications. 
  3. Tried to find someone using them, didn’t find anyone so had to ask. I have, as a primarily working hypothesis, the Helix as my main source, including standard cab's and a few IRs that I picked out, using PC+ in FRFR mode. Will be a bonus if I use IR on PC+ in some patches. Will experiment with the different voicings.
  4. And a perfect tone gets me going off. Since I am actually a pretty lousy guitarist, the tone is an inspiration to exceed my own capacity, to get a bit crazy :-). To be serious, I’m really curious on the speaker emulation. I use a lot of 112 and 212 in my patches, at this moment the Gramatico cab is my favorite, and speaker mode what got me inspired of the PC+. A real driver for me.
    Glad you mentioned how you recorded. That was one question I left out and you confirmed my thoughts here. I also have a Scarlett but the 18i6 (old one but works if Microsoft not shooting it down…) and plan to record that way in speaker mode. As the Helix probably will be my main source of sound, my main source for recording will be from there if I run FRFR mode. Point for some trial and error.
  5. I have no problem to dial up a patch from scratch, this is a lazy part of me talking. I get some cornerstones in may patches pre-configured, like od/dist/dly/rev/eq etc. I have 3 or 4 templates with different structure I use, all the blocks turned off by default. Add an amp/s and cab/s and go from there. Faster workflow for me, get the levels in the ballpark and add what I need from there. I got the idea from JS and his template and optimized it for my needs (one or more routing optins for amps/cabs, some blocks pre/post amp pre-configured, one for the Stomp etc.).    

 

Forgot to say, it's the Helix LT i have and use.

 

Again, thanks for your feedback rd2rk. You confirmed some of my thoughts and also opened up for some more ides. Very much appreciated.

Share this post


Link to post
Share on other sites

Been using my JTV59 / Helix / PC112+ for the last several gigs. Tried using PC112+ in FRFR mode and IRs in Helix. Didn't dig that much, but didn't spend a lot of time on it either. Thought about moving the IRs to the PC112+. Didn't get that far. Tried the PC112+ speaker emulations first. Fantastic! Finally feels like I am playing an actual amp, very happy with my sound on stage. Tried using XLR out of PC112+ to FOH, rather than XLR out of the Helix to FOH as I was doing prior. Was not as pleased with the XLR out of the PC112+ to FOH. I use a lot of 4x12 IRs in the Helix and the PC112+ is only emulating a 1x12 setup so I really wasn't too surprised there. Back to tapping the Helix directly to FOH. I also use the PC112+ in FRFR mode when using the JTV59 for any acoustic stuff. Sounds great on stage as well. So I am using the PC112+ for stage monitoring only, but I really dig it - and it can get plenty loud to keep up with the rest of the guys! My only issue is the loud volume spike that you can get if you are in the middle of hitting anything on the guitar and switch from FRFR mode to speaker. I have to make sure I am not sending any signal from my guitar to the PC112+ when switching. More than a bit of a problem, but I can work with it for now. Hopefully they address the issue soon, can't imagine I am the only one to run across this when playing live. Sold some more gear I wasn't using and scored a second PC112+. Haven't used the two together yet. One's at the practice pad, one's at home. Soon. Looking forward to checking out dual amp / dual speaker type setups. Oh yeah, and I only need to run one AES cable to the PC112+ from the Helix. Fabulous. Overall, very pleased!

  • Thanks 1

Share this post


Link to post
Share on other sites
31 minutes ago, cfhmonkey said:

My only issue is the loud volume spike that you can get if you are in the middle of hitting anything on the guitar and switch from FRFR mode to speaker. I have to make sure I am not sending any signal from my guitar to the PC112+ when switching. More than a bit of a problem, but I can work with it for now. Hopefully they address the issue soon, can't imagine I am the only one to run across this when playing live.

 

I set up a preset using snapshots to switch from PC+Speaker (SS1 - Green) to PC+ USER IR (SS2 - OH 412 MRBW GNR 57) to the same IR loaded on my Helix with PC+ in Flat Mode.

I hit the big "A" chord, let it ring, and cycled through the Snapshots. No volume spike at all. In fact, I was surprised that, other than the expected tone differences between the Speaker Emulation and the OH IR, the levels were perfectly matched. I used snapshots, how are you doing it? Maybe you could record the phenomena and attach it?

Share this post


Link to post
Share on other sites

I've got one path on the Helix with the input set to Variax and the output set to PC112 FRFR - this is my acoustic chain. Have a second path on the Helix with the input set to Variax mags as input and output set to PC112 Speaker modeling - this is my electric chain. I use snapshots on the Helix to switch between the two. I use gain blocks at the front of each chain to do so. Snapshot one for acoustic is top path at 0dB while the lower path is at -120dB, snapshot two for electric is the reverse. Maybe there is a better way to do this? Possibly user error on my part? Reason I assumed it was a powercab issue is because it works fine, no spike, out of the Helix XLR outs. I will record and / or video something as soon as time permits...

 

Thanks for the info, rd2rk!  

Share this post


Link to post
Share on other sites

Troubleshoot by starting with a new, blank preset. Add the base requirements (amp, cabs). Add things one at a time until you create the problem.

Then figure out a new plan to achieve the desired results.

 

Share this post


Link to post
Share on other sites

Thanks for the comments cfhmonkey, much appreciated.

 

I get more and more exited over the speaker emulation feature. I have lately used 1x12 and 2x12 speakers in my patches, both Helix original and IR’s and with really good result. Think this will give me more interesting options.

 

I guess I will have some testing to do how to best do recording and to hook up to FOH. Looks like there is different opinions on this part. But that’s part of the game and will be fun.

 

Glad you confirmed about the acoustic sound. That has actually been one of my concerns. Looking forward to test that, without the spikes (I also read your post - Volume spike when switching from FRFR to speaker modeling Powercab 112+). I guess I will make a package deal with my vendor to include an AES-cabler and a month of underwear’s ;-). Hope you solve that problem, with some help from rd2rk. I run my old Variax 500 fully analog (no VDI) so I hope I don’t run into the spike problem. (Correction - Sorry, wrong from me, its all in the PC+...)

 

So, thanks for your feedback. Start to feel confident to go the PC+ way. Time to check prices… Also, thanks to rd2rk commenting on cfhmonkey challange. Gives me even closer to “daily work and challenges” :-).   

Edited by PerS
Wrong conclusion...

Share this post


Link to post
Share on other sites
19 hours ago, cfhmonkey said:

That's the plan then once I find some time. Thanks, rd2rk!

I have the same issue, did a support ticket. No real answer,due to the fact that they were unable to go into the office to test it on the gear. Does not happen with XLR midi, only Line6 link.

FTW it only happens between FRFR and speaker sim mode. IR mode seems to switch ok.

Share this post


Link to post
Share on other sites
9 hours ago, Tick1 said:

I have the same issue, did a support ticket. No real answer,due to the fact that they were unable to go into the office to test it on the gear. Does not happen with XLR midi, only Line6 link.

FTW it only happens between FRFR and speaker sim mode. IR mode seems to switch ok.

 

That's confusing. MIDI does not use XLR.

FRFR IS IR mode. 

The test I ran switched (with snapshots) from speaker emulation to FRFR with the IR on the PC+ and to FRFR with the IR on the Helix. No noise.

Maybe you could attach your preset so I can see what's happening with it? 

Here's my test preset. You'll have to use your own IR of course, unless you have the same OH IR thst I used, both on the PC+ and the Helix.

 

BrtPlxJmpMode.hlx

Share this post


Link to post
Share on other sites

Sorry for the confusion.  What I mean is when you connect the powercab using the xlr outs of the helix and also a midi cable and set it up to switch powercab presets using midi.There is no problem using it in that manner (no vol spike between FRFR and speaker mode) . If you use Line6 link instead( one cable vs 3 cables) the spike happens.FRFR is not IR mode. There are 3 separate modes for the powercab+ ( FRFR/Speaker/IR  ). But I'm sure you are aware of this.  Thanks for your reply.  I'll get a preset posted for you to test later today.

Share this post


Link to post
Share on other sites

Hi, I loaded your preset, and added the ir..........it has the volume jump as well.Switch from snapshot 3 back to snapshot 1, big vol spike, go from snapshot 1 TO snapshot 3, no vol spike. Thanks for your time on this. Line 6 will eventually fix it. 

Share this post


Link to post
Share on other sites

Can't imagine what it could be, but must be something in the PC+ configuration. Hopefully support can sort it out for you, cause it's certainly not normal!

 

Share this post


Link to post
Share on other sites

OK, I THINK I hear the noise you're talking about, I had to turn up the volume to hear it.

I don't hear it as a volume spike though. It's hard to describe. The only thing I can think to compare it to is the sound you hear when you change the delay time on a delay while playing. It happens either on Helix or on a real delay pedal. I don't think it's a SW issue, more the sound of the HF driver dis-engaging. IOW, an electrical noise.

 

It would be worth recording it for support so they have something to kick upstairs to the engineering guys.

Share this post


Link to post
Share on other sites

Nah, this is different. This is a definite vol spike. I'll see if I can put together a video of the issue. It is definitely SW related to Line 6 Link only. Once again, the workaround is to use midi for switching instead of L6 Link. 

Share this post


Link to post
Share on other sites
4 hours ago, Tick1 said:

Nah, this is different. This is a definite vol spike. I'll see if I can put together a video of the issue. It is definitely SW related to Line 6 Link only. Once again, the workaround is to use midi for switching instead of L6 Link. 

 

It can't be "definitely a problem with L6 Link", because that's what I use, and there's no such problem. There definitely could be something wrong with your configuration, or the way your presets are done, and that there's two of you with the same problem is suspicious, but other than the two of you, I've never heard of this before, and this is NOT the only Helix forum that I frequent. Maybe (as I suggested several posts ago) you could post one of your presets? Take some screenshots from HX Edit's Powercab screen AND Powercab Edit?

 

I'm not saying it's your imagination, but I can't duplicate it. It's an interesting problem, and I'd like to get to the bottom of it as much as you.

Share this post


Link to post
Share on other sites
2 hours ago, rd2rk said:

 

It can't be "definitely a problem with L6 Link", because that's what I use, and there's no such problem. There definitely could be something wrong with your configuration, or the way your presets are done, and that there's two of you with the same problem is suspicious, but other than the two of you, I've never heard of this before, and this is NOT the only Helix forum that I frequent. Maybe (as I suggested several posts ago) you could post one of your presets? Take some screenshots from HX Edit's Powercab screen AND Powercab Edit?

 

I'm not saying it's your imagination, but I can't duplicate it. It's an interesting problem, and I'd like to get to the bottom of it as much as you.

I hear ya, it is definitely a goofy issue.Your preset does the same thing as mine. At least it does on my machine,I've reloaded all the software an the helix and the powercab ect ect. Thanks for your time! Nice to have help even if you don't have the same problem. 

Share this post


Link to post
Share on other sites

Doesn't matter that you've reloaded the FW and SW. Ever think that there might actually be a difference in the way mine is configured? Maybe a change I made so long ago I don't even remember doing it? That's why I asked for screenshots.

 

Of course, if the only solution you're willing to accept is that you have a defective unit, Good Luck!

 

Now that I've been dismissed, I just hope that IF Support resolves the issue, even if it turns out to be good old-fashioned OE, that you'll be considerate enough to post the solution here, and not just disappear as many others do once their personal problem is solved.

 

How about you, cfhmonkey? Still working on it?

Share this post


Link to post
Share on other sites
10 hours ago, rd2rk said:

Doesn't matter that you've reloaded the FW and SW. Ever think that there might actually be a difference in the way mine is configured? Maybe a change I made so long ago I don't even remember doing it? That's why I asked for screenshots.

 

Of course, if the only solution you're willing to accept is that you have a defective unit, Good Luck!

 

Now that I've been dismissed, I just hope that IF Support resolves the issue, even if it turns out to be good old-fashioned OE, that you'll be considerate enough to post the solution here, and not just disappear as many others do once their personal problem is solved.

 

How about you, cfhmonkey? Still working on it?

Hi, sorry if you felt my tone was dismissive, was not my intent at all. You must not be used to being thanked for your time.  LOL   All good here! 

Share this post


Link to post
Share on other sites
1 hour ago, Tick1 said:

Hi, sorry if you felt my tone was dismissive, was not my intent at all. You must not be used to being thanked for your time.  LOL   All good here! 

 

Sorry if I inferred something that was not implied. All good here too.

I meant what I said about posting back if you find a solution. Too many posters don't bother to share.

Share this post


Link to post
Share on other sites

Been busy with work, studio, upcoming gigs...haven't had time to test things properly yet. Planning on removing everything from my preset and adding things back in one at a time to see where / when the problem shows up. Also, I'm using a JTV59 and switching between the variax modelled acoustic voodoo and the mags when this is happening - wondering if that's not part of the problem? You guys? I need to test with a normal guitar.

Share this post


Link to post
Share on other sites
12 minutes ago, cfhmonkey said:

Been busy with work, studio, upcoming gigs...haven't had time to test things properly yet. Planning on removing everything from my preset and adding things back in one at a time to see where / when the problem shows up. Also, I'm using a JTV59 and switching between the variax modelled acoustic voodoo and the mags when this is happening - wondering if that's not part of the problem? You guys? I need to test with a normal guitar.

 

I don't have a variax, but it could very well be part of the problem. That's a good question for Tech Support.

I also know that you can get a "POP" sound when making sudden radical changes to certain amp settings (DRIVE in particular). This is not just a Helix thing, it happens on some real world amps too.

Share this post


Link to post
Share on other sites

Hi Guys,  I have the issue a regular guitar and also with a variax (using vdi cable or 1/4")

Share this post


Link to post
Share on other sites
12 minutes ago, Tick1 said:

Hi Guys,  I have the issue a regular guitar and also with a variax (using vdi cable or 1/4")

 

So, what have you heard from L6 support?

Share this post


Link to post
Share on other sites

Sorry for the duplicate post here, as I posted the following on my original thread elsewhere and don't mean to hijack this one, but...

 

Finally got some time to take a look at this last night. Probably chalk it all up to user error on my part, sheer ignorance, or both. I deleted every block from my preset and still had the issue when switching from a snapshot using the PC112+ in FRFR mode to another snapshot using the PC112+ in speaker emulation mode. Loud "pop" on the PC112+ and the input light goes red for a second. Looked at the Powercab tab in HX Edit. "Speaker Level" on the FRFR snapshot defaults to 0dB. "Speaker Level" on the speaker emulation snapshot defaults to -15dB. Not surprised then that there is a volume spike when changing snapshots, because that's a volume spike (duh). When I say "defaults" I do so because I don't remember setting the values, and if I start with a blank preset, those are the values that show up for FRFR and speaker mode. 

 

If "speaker level" is set to the same dB or even relatively close, no pops or volume spikes. Yea!

Share this post


Link to post
Share on other sites
1 hour ago, cfhmonkey said:

Sorry for the duplicate post here, as I posted the following on my original thread elsewhere and don't mean to hijack this one, but...

 

Finally got some time to take a look at this last night. Probably chalk it all up to user error on my part, sheer ignorance, or both. I deleted every block from my preset and still had the issue when switching from a snapshot using the PC112+ in FRFR mode to another snapshot using the PC112+ in speaker emulation mode. Loud "pop" on the PC112+ and the input light goes red for a second. Looked at the Powercab tab in HX Edit. "Speaker Level" on the FRFR snapshot defaults to 0dB. "Speaker Level" on the speaker emulation snapshot defaults to -15dB. Not surprised then that there is a volume spike when changing snapshots, because that's a volume spike (duh). When I say "defaults" I do so because I don't remember setting the values, and if I start with a blank preset, those are the values that show up for FRFR and speaker mode. 

 

If "speaker level" is set to the same dB or even relatively close, no pops or volume spikes. Yea!

 

That didn't make any sense to me either, since changing the SPEAKER level from -15 to 0 IS a BIG TIME volume boost! I tried it. No "POP", but the difference in levels of 15db is not usable. -15db on the speaker setting is equivalent to 0db on the Flat setting, because IRs are by default -18db (most vendors - mine are OH), so it roughly zeroes out.

 

So, having time on my hands, I reconfigured my rig so that I was using the Helix XLRs and MIDI to accomplish the same thing (same preset, modded to send MIDI PC to switch presets on the Powercab). Using the default level settings, it sounds EXACTLY the same as the L6 Link configuration, but no "POP". This is what you said in your original post (but I hadn't had time to verify).

 

Conclusion: This is a problem with L6 Link. On which end, Helix or Powercab, who knows.

Recommendation: Open a support ticket with a link to your post in the Powercab thread (shorter and to the point). I'll also post this reply there.

Share this post


Link to post
Share on other sites
4 minutes ago, rd2rk said:

Recommendation: Open a support ticket with a link to your post in the Powercab thread (shorter and to the point). I'll also post this reply there.

 

OK, I meant I'd post to the original thread, but I've lost track of it! Link?

 

Share this post


Link to post
Share on other sites

Here's the link.

 

I ended up offsetting the lack of volume issue on my FRFR snapshots (which I use for exclusively for JTV59 acoustic stuff as I'd mentioned, prefer the speaker modeling for anything electric) by using a gain block, adjusting the IR level, and adjusting the output level at the end of the chain. Probably not the ideal solution, but it seems to work, and no spikes when switching snapshots. Good enough for me for now...Will know more when I get to rehearsing and gigging.

Share this post


Link to post
Share on other sites

Hi Guys,  Thanks for continuing to research this. These are the same results that I have. As I said in my first post,I opened a support ticket on this and really got nowhere with it, as they were unable to test it. I'm sure they will figure it out sooner or later, in the meantime xlr and midi works fine.  Thanks again for your time.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...