Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Migrating to new computer with Helix Native


Recommended Posts

On 6/10/2022 at 12:11 AM, BucF16 said:

From a 2015 iMac to a new Mac Studio.

Can't even find Helix Native on the new computer.

What is the approved solution for reinstalling/updating a previously authorized license on the new computer?




I’m not entirely sure, but If you are on a Mac Studio, it may depend on whether you have the M1 MAX or M1 ULTRA installed. Although I haven’t seen any reports of those models not being able to use Native. I’m still holding back on Catalina and everything works fine.

IIRC, the download page for the Mac version of Native lists Monterey as being compatible, and I would expect that the OS handles the installation just the same as other versions - you should find Native in the /Library/Audio/Plug-Ins/Components .


As for migrating to the new machine, you need to hit the “SUPPORT” menu tab at the top of this page. Next you should see an icon in red (which represents you when logged in) and it drops down a menu where you select “Authorised Devices” from under the Hardware & Software section. From the next page you can then de-authorise your old machine and authorise the new Mac Studio. AFAIK, you can have 11 lifetime devices registered. If you run out, raise a ticket with Customer Support to have it reset.

I have not had to do this with Native, but have previously done this with hardware units, simply enough really.


Hope this helps/makes sense.

  • Like 1
Link to comment
Share on other sites

I have deauthorized the old computer and authorized the new one but when I tried to use Helix Native I get a "Failed to connect to DSP engine. (Device has not been inntialized properly. [code -8201])" warning banner in a blacked out Helix Native window.

I tried reinstalling Helix Native and restarting, then I was able to get into Helix Native and log into my L6 account from within the Native window.  However, Helix Native told me I had too many devices authorized (which I don't). I tried deleting and reauthorizing but now it's even worse. When I open a project in Logic that uses Native I get a warning that there's a plug-in that is destabilizing Logic, and Helix only opens in a tiny little window that looks nothing like Native.

Any ideas?

Link to comment
Share on other sites

On 6/14/2022 at 11:40 PM, BucF16 said:

Any ideas?



I guess you migrated your stuff from the old machine to the new one? 


O.K. Check this thread - there is a post from a guy who got a response from Customer Support and posted the details.



If that doesn’t work for you, then you need to raise a ticket with Support.


Hope this helps/makes sense.

Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...