Jump to content
FRANCKNEXT

Vetta 2 Combo Main Board Dead

Recommended Posts

Hi Vetta users !

Recently my Vetta  combo mainboard has passed away ( semaphore overflow message then nothing ).

I'm going to try to find some spare parts in the future cause I really like  my Vetta and I think Line 6 has never put something equivalent on the market since the Vetta ( I mean a amp with all their knowledges and ability in ).

But in case I wouldn't find spare parts , I'm thinking about using the Vetta like a cabinet with his own power amp. So I'd like to know if anybody has a diagram wich will permit me to connect a preamp to the Vetta's power amp . I mean what are the different pins function on the power amp board ( power supply , signal input etc.).

Has anybody already done this ?

 

Have a nice day

 

Share this post


Link to post
Share on other sites

I keep hearing more and more about dead Vetta mainboards and that scares me.  I have many mainboard type things that are still working that are older that the Vetta.  Does anyone know how common this is?  Is it inevitable?

Share this post


Link to post
Share on other sites

I think a lot of the times it's a dead battery or something simple. Usually an easy fix for someone handy with electronics. From what I've seen, and I've seen a lot of gear having spent a lifetime in electronics, it's a well designed and well built but very poorly supported piece of gear.

Share this post


Link to post
Share on other sites

My Vetta has the dreaded "access error" problem after it warms up. I checked all of the traces and the onboard battery and everything checked out good. Help! I love my Vetta when it works...

Share this post


Link to post
Share on other sites

 

You need to get it to someone who is good with electronics and has the test equipment and knowledge to fix it. If they don't have a service manual I can fix them up with what I have that was downloaded off the Internet. The manual I have is for a head unit but the heads and combos are almost the same execpt for the final power amp.

 

My Vetta has the dreaded "access error" problem after it warms up. I checked all of the traces and the onboard battery and everything checked out good. Help! I love my Vetta when it works...

 

Share this post


Link to post
Share on other sites

God! Just found that the main board in my Vetta HD (2002) is dead. Is there any replacements elsewhere? in the world?

Share this post


Link to post
Share on other sites

Play Taps to it from another amp then part out everything except the main board. Trash the main board or drive a monster truck over it. You'll get way more enjoyment out of it that way.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×