Jump to content

Recommended Posts

Hi, I tried to connect my helix via xlr direct into the m20d (also tried into L3t and from L3t out into the m20d).

There was quite a bit of clipping going on even though the meter was not showing any clipping. I wanted to to trim (using the auto trim option in m20d) but the mixer could not adjust saying "signal too hot". It is a bit weird since I did not have the impression I played very loud. In the helix I did just update to firmware 2.2 and all global settings are on "default". The xlr out is set to line level. The big volume know was set to the middle position. Very strange. Anybody has experience with that?

Tks

 

Markus

Share this post


Link to post
Share on other sites

Try setting the helix XLR to Mic level. That's what the M20d XLR inputs are expecting. And start with the M20d trim at its lowest setting.

Share this post


Link to post
Share on other sites

Your best option is to run from the XLR mono out to one of the 4 line level inputs, but you will need a XLR to 1/4 TRS adapter. Or a good quality guitar cable from the 1/4 out mono to same line input. Make sure the 1/4 output is set to line level as well. Works great for me.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...