Jump to content
riffster21

Helix Reamp Question

Recommended Posts

Hi guys,

 

I know the fix is a simple one, but I cant'a not figure it's out. I have spent days googling and watching video... help...

 

When I run my DI track into helix over USB and record the output in my DAW (Reaper), my track isn't stereo? It's double mono? I can't pan the track at all (i.e. that's how I know it's duel mono and it doesn't sound 'stereo'). Yes, my Helix patch is Stereo out. Here is my setup:

 

- I set my recorded DI Guitar DAW track to send to hardware input USB 7 (the default re-amp channel in Helix)

- I set new blank track to record/capture the re-amped tone to receive from hardware input USB 7.  

 

The results - both the previewed sound and the recorded sound are duel/double mono. I tried changing the Helix input/output channels to 7/8 instead of just 7. I made sure that both of my Reaper channels are stereo. 

 

Any/all suggestions are very muchly appreciated. :D

 

46941b8752119fb6e371e5fd5287df17.jpg

 

Dan

Share this post


Link to post
Share on other sites

USB 7 is the default output that will be dry for reamping later. Since you already have your DI track recorded, you don't need to use USB 7/8.

 

Try this, because it's worked for me in Reaper - set the hardware output on your DI track to USB 3. Then on the helix set the input to USB 3/4 and the output to USB 1/2 (or multi would work). Then on the track you're arming to record, set the input as USB 1/2. This should be in stereo.

Share this post


Link to post
Share on other sites

Your dry out recording to DAW will be two monos because a guitar signal is a mono signal. You won't get any kind of "stereo sound" until you put some stereo type effects on it to make it sound that way.

 

Your non-dry signals coming from Helix to DAW will sound stereo unless you are collapsing them into mono before it goes out. 

Share this post


Link to post
Share on other sites

I use Logic so I can't exactly for Reaper, but the concept is probably similar.

 

With your dry track already recorded - set that track's output to be USB3/4.

 

On your new blank track, the one you are about to record into, set it's input to USB1/2.

 

And on the Helix hardware itself in the patch you want to re-amp into, set the Path input to USB3/4.

 

Then just press "record" in your DAW - that should "play" your dry track into USB3/4 which feeds your Helix input Path, and the Helix output block will go out normally to USB1/2 and be recorded.

 

That's the way it works in Logic anyway, and probably in Reaper, too - just the specifics of setting it up are probably slightly different.

Share this post


Link to post
Share on other sites

When I run my DI track into helix over USB and record the output in my DAW (Reaper), my track isn't stereo? It's double mono? I can't pan the track at all (i.e. that's how I know it's duel mono and it doesn't sound 'stereo'). Yes, my Helix patch is Stereo out. Here is my setup:

- I set my recorded DI Guitar DAW track to send to hardware input USB 7 (the default re-amp channel in Helix)

- I set new blank track to record/capture the re-amped tone to receive from hardware input USB 7

The results - both the previewed sound and the recorded sound are duel/double mono. I tried changing the Helix input/output channels to 7/8 instead of just 7. I made sure that both of my Reaper channels are stereo.

Any/all suggestions are very muchly appreciated. [ :D]

Dan

 

Hi Dan,

 

I have highlighted a few points in your post which seem the most relevant here.

 

O.K. the first thing to note is your original DI signal is MONO because that's how guitars function - generally. (yes, I'm aware that stereo guitars are available, but...)

Therefore, if you also DI'ed an acoustic guitar or vocal mic on USB 8 that would also be MONO, because that is also how they are in the the real world.

So, USB 7 & 8 are always MONO feeds but are made stereo by the digital processing of the re-amp via Helix. This basically what is stated by "jbuhajla" in the post above.

 

Once you have got your head round that, you only need to follow the advice from "bsd512" above, also "mfalkler" is giving the same advice. They are perfectly correct that you need to send you DI track back out from your DAW on USB 3&4 and Helix input as 3&4. Your newly processed stereo signal comes back to the DAW to your ready armed record track on USB1&2.

 

Hope this makes sense.

 

Enjoy!

Share this post


Link to post
Share on other sites

Hi guys,

 

I know the fix is a simple one, but I cant'a not figure it's out. I have spent days googling and watching video... help...

 

When I run my DI track into helix over USB and record the output in my DAW (Reaper), my track isn't stereo? It's double mono? I can't pan the track at all (i.e. that's how I know it's duel mono and it doesn't sound 'stereo'). Yes, my Helix patch is Stereo out. Here is my setup:

 

- I set my recorded DI Guitar DAW track to send to hardware input USB 7 (the default re-amp channel in Helix)

- I set new blank track to record/capture the re-amped tone to receive from hardware input USB 7.  

 

The results - both the previewed sound and the recorded sound are duel/double mono. I tried changing the Helix input/output channels to 7/8 instead of just 7. I made sure that both of my Reaper channels are stereo. 

 

Any/all suggestions are very muchly appreciated. :D

 

46941b8752119fb6e371e5fd5287df17.jpg

 

Dan

Hey ... been a while since I've used reaper.. but on cakewalk I have to set my track input to either left right or stereo. 

Otherwise.. no stereo. 

This holds true with USB as well 

 

Share this post


Link to post
Share on other sites

OK.. you have to select track input DAW to 7/8 {stereo}
[Of course this is considering you have already ENABLED inputs 7/8 in your DAW software]

Also the output. This will go to helix to re amp. 
Global settings on Helix >>> USB 7 {Guitar}  USB 8 {Guitar}
Done
 

Share this post


Link to post
Share on other sites

OK.. you have to select track input DAW to 7/8 {stereo}

[Of course this is considering you have already ENABLED inputs 7/8 in your DAW software]

Also the output. This will go to helix to re amp. 

Global settings on Helix >>> USB 7 {Guitar}  USB 8 {Guitar}

Done

 

 

Yep, this one worked. If you leave USB 7 as the only guitar USB source, you will only get mono (in and reamped). No idea why, but that's the way it worked. 

 

Strange tid-bit; they way I had it before (with only USB 7 as the guitar USB source), even when I used a plug-in like Bias or S-gear, my output was duel mono. The fix was turning of Helix and running my audio though another sound card. So the fix was the Helix audio routing.

 

Thanks for the help folks.

Share this post


Link to post
Share on other sites

Yep, this one worked. If you leave USB 7 as the only guitar USB source, you will only get mono (in and reamped). No idea why, but that's the way it worked. 

 

Strange tid-bit; they way I had it before (with only USB 7 as the guitar USB source), even when I used a plug-in like Bias or S-gear, my output was duel mono. The fix was turning of Helix and running my audio though another sound card. So the fix was the Helix audio routing.

 

Thanks for the help folks.

As an afterthought, it may be worth taking a little time to watch this Line 6 demo of how to re-amp with Helix.

https://youtu.be/Vf3i18zOgG0

You should note that the DI guitar on USB 7 is MONO until it is re-processed via Helix which makes it STEREO.

Hope this clarifies the mono/stereo thing.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...