Jump to content

Helix and Workbench HD not working, Help Help

Recommended Posts

Hi All

Ok So i am losing my mind trying to get Helix and Variax JTV 69 working. I installed a brand new Windows 10 install

and no matter what always get 'The connected Variax is not compatible with Workbench HD.

You must use a James Tylers Variax version 2.0 or higher' so I go and disconnect the Variax completely and get the exact same error so it appears that really the message is bogus. I have the supplied VDI cable and have tried several CAT 5 and Cat 5 E cables still always get the same error.


Does any know exactly why this doesnt work? Does having Line 6 POD HD 500 installed as well as helix cause this? I did not try uninstalling Line 6 monkey

but did disconnect the line 6 POD 500.  


I just cant figure out how this doesnt work and why my system only


FYI Line 6 Support says they have no idea and it 'should work;!


Here is my Black Friday recording with 2.30 firmware 




help help

Share this post

Link to post
Share on other sites

Connect the way you normally would for Monkey update or Workbench HD

with the the interface device and cables that came with the JTV.


Unplug any USB hubs that may be connected. 


Insert a fully charged JTV battery into the compartment, then plug a stereo headphone adapter

into the 1/4" jack. Listen for the click of the relay engaging. There should be two green LED's on

the interface device. 


Check Line 6 Monkey for the Firmware version on the JTV guitar. If it is not v2.00 or higher, Workbench HD

will not recognize the guitar.


Once all this is completed, you should be able to open Workbench HD.


Check the online Pilot's Handbook and the Knowledge Base on this subject for further details if needed.


Share this post

Link to post
Share on other sites

Yeah so everything works witg monkey and the usb interface but with helix nothing..i get tge error..tge firmware for variax is tge latest

Share this post

Link to post
Share on other sites

Use the interface device and cables that came with the JTV-69,

and connect to the computer with that, without the Helix. Try that.


Share this post

Link to post
Share on other sites

Hi.. fwiw, I have a an iMAC and Workbench HD along with HX Edit, JTV and Helix LT

Workbench HD is very very intermittent connecting to my JTV, and I get the same message you see.. the one about the software version on the JTV.


I've tested various connectivity scenarios and the Workbench HD sometimes connects, sometimes doesn't and sometimes connects then fails to communicate with the JTV when settings are changed..


Currently my chain looks like this..


MAC USB --> Helix LT --> JTV (via the cat 5 cable).

This is the most stable connectivity sequence I can get.... dropping out the Helix makes connectivity to workbench worse..


Basically, workbench is useless to me, so the value of it is wasted.


I'd like a solution, but it looks like this issue isn't restricted to Windows... it's MAC too..


Help anyone?


PS, everything (including the iMAC) is running latest available firmware..



  • Upvote 1

Share this post

Link to post
Share on other sites

I recall some odd quirk between JTV and iMac's. I think that got resolved early on, but make sure to add that

to your support ticket,... just to be certain that is covered.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...