Please ensure Javascript is enabled for purposes of website accessibility Jump to content

HX Edit (2.81) and Helix Native starting with with a "blank" screen and crash


Recommended Posts

I have an Intel NUC where the M.2 and SATA ports are not re-arrangeable, so the M.2 NVMe (with the OS on) will always be listed as disk 1 and the SATA SSD/HDD as disk 0. Aside from the disk numbers being wrong, it also seems like I can't disable my SD-reader so that I don't get a blank line as the first one under Serial Numbers when I type in "wmic diskdrive get serialnumber" in CMD. There is no SD-card in the reader, and has never been, and I've also disabled the SD-reader completely in UEFI, so I don't get why it still shows a blank line as the first.


Does all of this mean that there's no hope for Line 6 software to ever work on my machine?


This issue seems like such a stupid one! I don't understand why Line 6 hasn't fixed this yet?



Link to comment
Share on other sites

  • 1 month later...

Thanks to everyone who has contributed to this thread, it helped me to get around both HX Edit 3.51 and Helix Native 3.51 crashing on my PC after I added a new system drive and installed a clean copy of Windows 11. To help anyone else struggling with this issue on a similar set up I have documented my experience below.


To begin with, I looked for information in the windows event log (right click the Start button and select Event Viewer). In the Application log (listed under Windows Logs in the left hand panel) I found an application error for each time I had tried to start HXEdit. The details show that HXEdit is crashing with an 0xc0000005 exception code.


Using the instructions provided in this thread I did the following to narrow down and overcome the problem.


1. I ran the diskpart list disk command to reveal that I had a disk0 and it was online.


2. I ran windows disk management (right click the start button and select Disk Management). This showed that disk0 was my newly installed system disk. So no issues so far.


3. Next I ran wmic diskdrive get serialnumber in a command line terminal and found that I did have a blank line as the first entry in the list. This is an issue documented earlier in the thread that is directly related to the cause of the crash.


4. Initially I thought that the blank line would be disk0 but after a bit of research into the wmic command I discovered that you can run wmic diskdrive get name to get a list of the corresponding disk names. This revealed that the list was not in drive order and that the disk associated with the blank line was in fact drive5 on my system.


5. With this information I went back to windows disk management and discovered that drive5 was the SD Card reader built into the front panel of my PC.


6. This is the really interesting part. I didn’t have a card in the reader which led me to dismiss the earlier comments in this thread about ejecting the SD card. However, I decided to put a card in the reader and repeat the wmic command, sure enough the blank line was still there. I then ejected the card using the windows safely remove program in the menu tray. When I repeated the wmic command this time the blank line had disappeared. Unfortunately, after a reboot of the machine the blank line returned. The drive is only removed from the list as part of the safe removal of an SD card.


7. This left me with a choice. I could insert an SD card and eject if every time I wanted to run HXEdit or Helix Native or I could disable the card reader and only reenable it if I needed it. I chose the latter.


So, to fix the problem and get HXEdit and Helix Native working I disabled the card reader in Windows Device Manager. Mine was listed under Disk drives as Generic STORAGE DEVICE USB Device. Right clicking on it allows you to disable and enable it. When disabled the Helix programs work fine, when enabled they don’t.

Link to comment
Share on other sites

If anyone finds themselves here with this problem, please vote for a fix on ideascale at Windows HX Edit, Helix Native & Pod Go Edit SD Card Bug/Crash (


Line 6 support pointed me to this thread when I reported the problem and were very non-committal about when or whether the problem will be fixed in the future. They pointed me to ideascale to suggest a fix.


When I searched ideascale I found the above suggestion for a fix was already there with some extensive work by Chris Windibank in tracing the issue. Unfortunately, it currently only has 4 votes. I find it hard to believe that this reflects the number of people who have been affected by the issue, but I suspect that it will be seen as a reason not to address it.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...