Please ensure Javascript is enabled for purposes of website accessibility Jump to content

Neighborhood power failure as I was updating Helix Floor - Please Help!


Recommended Posts

I'm stuck.   Before posting here, I googled my Helix Floor Error Message - "Boot Failure, Entered Update Mode" and did not find any advise on how to complete the helix floor the 3.5 update.


I was in the middle of the update and was running the newest version of HD-Edit (3.51) when the entire neighborhood lost power. 


I tried to resume the update and when I turned on the Helix and FS6 & FS12, the unit froze with the message "Entered Update Mode" and HD-Edit 3.51 does not connect with the Helix.


I tried to boot using FS9 & FS1 and then also tried FS 9 & 10 .  Both resulted in the Helix starting a screen boot up with a "3.5 firmware" display but all three attempts went into "Boot Failure, Entered Update Mode" and the Helix Edit 3.51 does not connect to the Floor Unit.


I downloaded the firmware 3.5 manually from line 6 but I don't see how to launch the file that downloaded.


Any help would be greatly appreciated.  Thanks!



Link to comment
Share on other sites

On 11/30/2022 at 12:43 PM, silverhead said:

One of the files you downloaded in the background in the HX Edit package is called Line 6Updater. Locate it. Close the HX Edit program. With your Helix device in the aforementioned Update mode, run the Line 6 Updater program.

I found the Line 6 updater program on my computer (thanks!). IT had an install date of 9/18/22 (bad sign, as it's probably old).  It ran and said it would update to a newer version (that's good) but wound up taking me to the Line 6 website.  I had already tried this morning to download the firmware and I did download an HXF file but when I clicked on it, my mac did not have any program associated with it, so I am not sure how to get the HXF file working with either HD Edit or the Hexlix Floor.

Link to comment
Share on other sites

The link that was sent in this post did the trick!  Thank you so much!!!


I realize it's frustrating to repeat over and over the same advice.  I wish google had pointed to more current answers that involved the newer firmware releases so I would not have to waste everyone's' time.


Thank you all, I appreciate your assistance!

  • Thanks 1
  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...