These forums are read only, please use our new forums here.

Main :: DT50/DT25



DT-25 Head - Class A/B Issue
by cis689 on 2013-02-21 07:51:20

Hey guys, just wondering if anyone here has experienced what I am seeing here. I've had the DT25 along with the HD500 now for awhile with no problems. The other day I noticed that when I switched to Class A/B the amp would screech, drop in volume, then cut out / clip. I have the latest (and even reinstalled) firmware. I am running directly to the DT25 and it has clean power. I must mention that Class A gives me no issues. Now, it doesn't appear to be volume related either, this will happen at low volume. Since both classes share the same tubes I assume the only thing left would be a transformer going bad???

Thanks for any input.



Re: DT-25 Head - Class A/B Issue
by cis689 on 2013-02-21 08:03:21

I hope I am not the newest member to the "club" - Ugh!



Re: DT-25 Head - Class A/B Issue
by TheRealZap on 2013-02-21 08:58:02

sounds like possibly a tube issue...

but be sure to adjust the amp settings volume/gain as well... because sometimes it's just a matter of the settings not being suitable for both.



Re: DT-25 Head - Class A/B Issue
by cis689 on 2013-02-21 09:02:02

Voulme / Gain settings not an issue. Happens at very low volume. I question the tube theroy, as both channels use the same tubes do they not?



Re: DT-25 Head - Class A/B Issue
by whiteop on 2013-02-21 21:34:49

Hopefully you won't become a member of the Blown Power Transformer Club but if you do be sure to check in. Quite a few haven't yet. Sort of a way to keep tabs on this problem...;)



Re: DT-25 Head - Class A/B Issue
by TheRealZap on 2013-02-22 06:08:14

I'm not an engineer or designer... but if other amp charecteristics change the way those tubes are operating, then i think it's possible. i mean the whole entire tube doesn't have to be bad for one particular part of it to malfunction.



Re: DT-25 Head - Class A/B Issue
by Hummelong on 2013-02-22 11:25:06

I have had some occasional noise (not screechy, but undesirable) problems.  I suspect the relays that are used to switch the topologies around get scratchy.  When this happens, I toggle the appropriate switch a few times which has worked for me to clean the relay contacts enough that the problem goes away.

Don't know if this will help, but it is worth a try.

Mike



Re: DT-25 Head - Class A/B Issue
by stumblinman on 2013-02-22 13:05:09

Since it works in class a but not a/b I would wonder about the phase inverter tube.  It's a 12ax7b in my DT25. Replace or reseat and go from there.



Re: DT-25 Head - Class A/B Issue
by cis689 on 2013-02-23 08:53:46

I will try that. Is there a trick to getting the back panel off without tearing up the tolex ?




The information above may not be current, and you should direct questions to the current forum or review the manual.