Jump to content
ppoceiro

HD500X and Midi clock sync

Recommended Posts

Hi,

I'm trying to sync the tempo in the POD by sending the clock from my DAW (Reaper) via midi.

 

I have two problems.

1.The POD only syncs the tempo when I go to the midi page in the system settings or when I press a footswitch. 

 

2.The synchronized tempo always drifts by -/+0.2bpm and takes a bit of time to sync.

 

I tried with both global and preset options for the tempo.

Is there some workaround for these problems?

What I'm trying to do is to play backing tracks with tempo changes during the playback and I would like the tempo in the POD to sync with the DAW without me having to press footswitches and without any drifting.

Any advice or setting i'm missing in the DAW or in the POD?

 

Thank you

Share this post


Link to post
Share on other sites

Did you ever figure this out?

I'm trying to do something similar...

 

Hi.

Didn't solve the problem and found no feedback from support or forums.

I have a workaround that works pretty well.

Requires a bit a work.

Created a tempo track for sending tap tempo through CC midi messages to the pod and created midi for every tempo change and every patch change with just 3 or 4 beats.

Works great.

Just be careful with patches with phaser or similar effects because every tap tempo you send resets the effect and creates strange sounds.

And turn off the tempo sync from the options.

Cheers.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thank you for the wonderful insight into something I was looking to do on Helix, which is a way to reset a time based effect to have predictable behavior from that effect.

Share this post


Link to post
Share on other sites

Thank you for the wonderful insight into something I was looking to do on Helix, which is a way to reset a time based effect to have predictable behavior from that effect.

You're welcome.

As i understand it, at least in the pod, the time based effects reset the tempo when you press the tap tempo so each time i send a CC midi message with tap tempo to the pod the tempo of the effect resets. The problem is you cannot send too many beats or else the effect creates strange sounds. Not noticible in delays but very noticible in phasers or flangers. I only send the minimum beats for the pod to calculate the tempo. Usually 3 beats is sufficient. Its not the exact tempo but if you have many preset changes or tempo changes it's not noticible.

I also send CC messages when I change presets manually for the tempo to align correctly because you may not change the preset with your foot in the exact beat. This way it's always synced. 

Share this post


Link to post
Share on other sites

So, there's no way to send the exact timing from the clock in the DAW into the pod?  That seems wrong.  I've read a lot about midi clock sync and it seems universally possible with almost every device, yet I can find nothing relating to the pod...huge bummer.

 

I want it to utilizer the looper and have the tempo match the sessions in Sonar...

This should be possible... I hope someone has a bright idea to fix, because I didn't understand if your solution would help me.

Share this post


Link to post
Share on other sites

So, there's no way to send the exact timing from the clock in the DAW into the pod?  That seems wrong.  I've read a lot about midi clock sync and it seems universally possible with almost every device, yet I can find nothing relating to the pod...huge bummer.

 

I want it to utilizer the looper and have the tempo match the sessions in Sonar...

This should be possible... I hope someone has a bright idea to fix, because I didn't understand if your solution would help me.

Well.

Can't help you with the looper function of the pod. Don't use it.

However I've already spent a lot of time searching for this and I do recall people with that exact problem.

But can't say if there's a workaround. Or if my method works with the looper.

What I know is the pod does receive the tempo of the DAW, with a bit of fluctuation, not the exact tempo. But if you have changes in tempo during a song, the pod doesn't keep up unless you press a footswitch. It's strange and unusable for me. So the best method for me is to send CC messages to the pod with the tempo.

If you think my method could help you out I can give you some more hints with that. 

Share this post


Link to post
Share on other sites

Hi!

I have Ableton 9 and the POD HD500X

I tried linking the POD with a MIDI to USB cable, and I was able to make a preset where the POD recieves CC info to the TAP pedal...and then I progrmmed a MIDI track in Ableton to send 4 midi signals on C1 at the beats....and nothing is happening...can you explain deeper on how you used CC messages to control the tap tempo on your POD please?

Share this post


Link to post
Share on other sites

Hi!

When you say C1 are you talking about the note C1?

If that's the case that's not how you send the tap tempo information.

In the midi item you need to send a CC message. I think it's the CC64 but you better check it on the manual. Adjust that CC value to 127 on the beats you want.

Then on the track you have the midi item you have to configure it to send midi information to hardware and select the usb to midi adapter.

I don't know how to do it in Ableton.

Maybe check YouTube for some similar tutorials on how to send midi CC messages to external hardware from Ableton.

Cheers

Share this post


Link to post
Share on other sites

good day all, i have finally synced my podhd500x to my daw which is ableton live9, how i did it is kinda simple though it is always -0.2 on the tempo of my DAW but i think it's good enough because in reality when you play live , that small discrepancy  on tempo will not matter not unless you're gonna play a loop all throughout the song without retriggering it, here is how i did that, my live setup is ableton live 9 on mac, connected is my audio komplete 6 native instrument, and  the midi out of the NI komplet6 is connected to midi in of the podhd500x,, i have assigned a track on ableton that will change my podhd preset by sending program changes as i play any song .. on the midi tab of ableton , i turned on the output track, sync and remote of my komplete6 audio, the track "midi out to" (at the bottom of the track) that sends program change to my pod should have the same channel as the midi channel of the pod for them to communicate. once it is done, you will need to make a midi clip on the exact scene as the song is(in my case i have a clip that will just send the program change and will stop playing after 1 bar/measure  and the podhd500x will  follow any tempo of the current song, (but it is always  -0.2 of the current tempo , i mean if song tempo is 90, the synced tempo on the podhd will be 89.8. my preset setting on my pod hd500x using the pod hd edit is set to preset and it always follow as long as you do these things i mentioned.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×