Jump to content
Ruben40

choosing a preset in stomp mode activates custom midi footswitch command

Recommended Posts

Hello
I don't know, if this normal or if this seems to be a bug.
I use the helix in the stomp-footswitch mode.
I assigned midi commands to the lower 8,9,10 footswitches. This midi commands controls the fx of a digital mixer.
When I press the mode button the presets are shown in the lower footswitch row.
I press for example the footswitch 8. The preset will load, but also the midi command of the according footswitch will be transmitted.
But this should not happen, because I want to control the midi commands with the footswitches and not send them automatically,

when the preset is changed.
 

My solution now is to use the preset mode to avoid the automatic switching.
Could anybody confirm this?

 

Thank you

 

Share this post


Link to post
Share on other sites

There is a global option to shut this behavior off, which is MIDI PC Send/Receive.

Share this post


Link to post
Share on other sites

Actual I cannot verify if the global midi setting avoids sending the midi command, which is stored at a preset custom footswitch position.
I will check, when I'm at home.
But here I don't mean the midi program change commands which will be sent automatically, when I change the presets.

An example:
I have two presets which are stored at footswitch 8 and 9.
Each preset has two custom midi commands stored also at footswitch 8 and 9.
I'm in stomp mode with preset 8. I press the mode switch and load preset 9.
After loading the preset 9, the custom midi command of the footswitch 9  (stored in the preset command center) is also transmitted.
When I switch back to preset 8, then the command 8 is transmitted.
The helix manual says only the program change will be surpressed. the custom midi commands are not affected.

I hope I could describe my problem. Could anybody confirm this behavour ?
Thanks for support.  

Share this post


Link to post
Share on other sites

Hello

I don't know, if this normal or if this seems to be a bug.

I use the helix in the stomp-footswitch mode.

I assigned midi commands to the lower 8,9,10 footswitches. This midi commands controls the fx of a digital mixer.

When I press the mode button the presets are shown in the lower footswitch row.

I press for example the footswitch 8. The preset will load, but also the midi command of the according footswitch will be transmitted.

But this should not happen, because I want to control the midi commands with the footswitches and not send them automatically,

when the preset is changed.

 

My solution now is to use the preset mode to avoid the automatic switching.

Could anybody confirm this?

 

Thank you

 

So are you saying you're in the mode where you have the bottom row of switches showing presets and the top showing effects? I believe what you're experiencing the expected behavior.

Share this post


Link to post
Share on other sites

The helix is in the stomp footswitch mode.

In my preset at the lower row there are the switches for custom Midi commands and in the upper row are the other fx switches.
For changing the preset I press one of the left bank switches. Here the lower row changes to the preset mode.
This means the lower row shows the actual preset bank.
I press for example the switch 8 (lower row) to load the according preset. Here comes my problem.
The new loaded preset has a custom Midi command on the same switch position (here 8). This midi command is executed automatically after preset loading.
This command should not executed. 
I hope I could clarify my problem.

Share this post


Link to post
Share on other sites

I just tested and can confirm what you're saying is what actually happens.

 

So if you have a midi command assigned to the same switch being used to switch to a preset, Helix will automatically send the midi command of the preset you are switching to.

 

This sounds like it would be expected behavior. Don't know for sure. But there is no way shut this off without removing the midi command, or reorganizing the order of the presets, so that when switching presets, the two functions to coincide to the same switch.

Share this post


Link to post
Share on other sites
......

So if you have a midi command assigned to the same switch being used to switch to a preset, Helix will automatically send the midi command of the preset you are switching to.

 

.......

 

I have highlighted the last word above just to ask for confirmation....... I don't have the right setup to test this myself right now but am interested......

 

So it seems the midi command associated with the NEW, not CURRENT, preset is sent? In other words the midi command is sent AFTER, not BEFORE, the preset switch?

Share this post


Link to post
Share on other sites

I have highlighted the last word above just to ask for confirmation....... I don't have the right setup to test this myself right now but am interested......

 

So it seems the midi command associated with the NEW, not CURRENT, preset is sent? In other words the midi command is sent AFTER, not BEFORE, the preset switch?

 

Yes, correct. The commands being sent originate from the preset you're switching to. But this will only happen when the preset you're switching to contains a command on the same switch you're hitting to get to the preset that you're switching to. That's how appeared to work when I tried it.

 

I've also noticed that if your intention is to have automatic commands sent from the preset you're switching to, there are the lightning bolt icons, or instant commands in the command center. That appears to be what these are for. You can have six of them. These are sent upon the preset's recall.

Share this post


Link to post
Share on other sites

Yes, correct. The commands being sent originate from the preset you're switching to. But this will only happen when the preset you're switching to contains a command on the same switch you're hitting to get to the preset that you're switching to. That's how appeared to work when I tried it.

 

I've also noticed that if your intention is to have automatic commands sent from the preset you're switching to, there are the lightning bolt icons, or instant commands in the command center. That appears to be what these are for. You can have six of them. These are sent upon the preset's recall.

 

Well that behavior doesn't make sense to me, if that's truly what's happening. How would the Helix "know" what command is assigned to that switch in the new preset before it is loaded? I suppose it's possible that Helix loads the preset and then send the command associated with that switch, but that doesn't seem like a useful behavior.

 

Are you sure you're not just seeing the MIDI PC message associated with that preset being sent?

Share this post


Link to post
Share on other sites

Well that behavior doesn't make sense to me, if that's truly what's happening. How would the Helix "know" what command is assigned to that switch in the new preset before it is loaded? I suppose it's possible that Helix loads the preset and then send the command associated with that switch, but that doesn't seem like a useful behavior.

 

Are you sure you're not just seeing the MIDI PC message associated with that preset being sent?

 

Positive. I have that turned off.

 

I was using ReaControlMIDI to view the messages being sent.

 

It must load the preset first, and it also sees the switch you're pressing somewhere in this process, and then it decides to send the midi command associated with that switch in the just loaded preset.

 

Could this be a bug?

Share this post


Link to post
Share on other sites

This must be a bug, because a custom footswitch should not be activated automatically after the preset is loaded.

Another strange effect.

If you move the preset position then the activated midi command-footswitch also moves.

That's no useful behavior.

Share this post


Link to post
Share on other sites
  • Single commands (MIDI CC, Bank/Prog, MMC, Ext Amp, CV Out), when assigned as Instant (lightning bolt) 1-6, will be recalled upon preset selection
  • Single commands (MIDI CC, Bank/Prog, Note On, MMC, CV Out), when assigned to a footswitch, will not be transmitted upon preset selection
  • Dual-state commands (CC Toggle, Ext Amp, CV Toggle), when assigned to a footswitch, will be transmitted upon preset selection; its value depends on the switch's current state (dim or lit)

By default, selecting a preset will also transmit a PC message on the Base MIDI channel; this behavior can be disabled at Global Settings > MIDI/Tempo > MIDI PC Send/Receive.

Share this post


Link to post
Share on other sites

 

  • Single commands (MIDI CC, Bank/Prog, MMC, Ext Amp, CV Out), when assigned as Instant (lightning bolt) 1-6, will be recalled upon preset selection
  • Single commands (MIDI CC, Bank/Prog, Note On, MMC, CV Out), when assigned to a footswitch, will not be transmitted upon preset selection
  • Dual-state commands (CC Toggle, Ext Amp, CV Toggle), when assigned to a footswitch, will be transmitted upon preset selection; its value depends on the switch's current state (dim or lit)

By default, selecting a preset will also transmit a PC message on the Base MIDI channel; this behavior can be disabled at Global Settings > MIDI/Tempo > MIDI PC Send/Receive.

 

 

The second item there is what doesn't seem to work correctly, then. Because a CC is transmitted in the condition that the switch being used is the one for selecting the preset and the one the message is assigned to.

 

If works as stated when the preset you're loading is on a switch that happens to have no single-command message assigned to it, from the preset you're loading.

 

If the preset you're loading is on a switch with a single-command message on it, from the preset you're loading, that is sent automatically.

 

When I say single-command message, I've only tested with CC, nothing else.

Share this post


Link to post
Share on other sites

In my opinion this seems to be a bug. 
My workaround is to set the midi footswitch commands to the upper footswitch row and select the presets with the lower row.

Share this post


Link to post
Share on other sites

Has there been any development on this - I think it may be a bug too.

 

Heres what Im trying to do

 

I have a midi toggle command set on a preset so that I can play/stop a backing track on Logic. Works great. I have also tried it with CC and Note on and that works too, but toggle is best because the footswitch lights up when its on and goes off when its off, I can't get that to happen on the other types of command. Note that I have dim and Lit both set to 127 to make that happen. All good until when I select the preset the playback starts immediately which is not what I want. I have tried turning off send PC commands in Global settings but that doesn't make any difference.  I also tried using the instant command to send a CC message to turn the playback command  to 0 in the vain hope that it would somehow get out before the footswitch command.

 

Reading the comment below it would seem that the reason my toggle switch doesnt work is because both Dim and Lit are set to 127. If I set Dim =0 and Lit=127 I can make it so that the preset doesn't automatically play the backing track. However I now have a rubbish switch that I have to press twice to get it to change state and the light can be lit up whether its playing or not. It would be so much better if preset selection didn't send my foot switch commands, period.  Is this a design flaw or am I missing something?

 

  • Quote

     

    • Single commands (MIDI CC, Bank/Prog, MMC, Ext Amp, CV Out), when assigned as Instant (lightning bolt) 1-6, will be recalled upon preset selection
    • Single commands (MIDI CC, Bank/Prog, Note On, MMC, CV Out), when assigned to a footswitch, will not be transmitted upon preset selection
    • Dual-state commands (CC Toggle, Ext Amp, CV Toggle), when assigned to a footswitch, will be transmitted upon preset selection; its value depends on the switch's current state (dim or lit)

     

     

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...