Please ensure Javascript is enabled for purposes of website accessibility Jump to content

No update...


Recommended Posts

Hey guys,


Brand new owner of a helix! Yaaaaaaay!

Unpacked it! Admired it! .... ok let''s update first!


Nope! Installed latest software, but it just keeps skipping the installation.

Allost immediatly I get the post-installation screen telling the helix will reboot... not ...


I uninstalled, i rebooted.... nothing







Link to comment
Share on other sites

Try doing a foot-switch 6-12 safe boot mode update...


Turn off the Helix and then hold down foot switches 6 and 12 both are on the far right top and bottom and while holding down turn on the Helix...

Should start up in safe mode then follow the update instructions and re-install the update..


Hope this helps!

Link to comment
Share on other sites

Sorry to hear the update process has diminished your enthusiasm about the brand new Helix.


What computer and OS are you using while attempting the update?


Are you connecting the supplied USB cable directly between the Helix and a primary USB port on your computer (rather than a remote or hub USB port)?

Link to comment
Share on other sites

Sorry guys, but living in Belgium so other timezone...

No success till now.

I run windows 10 and tried different usb ports.

Tried the 6-12 update boot... when the display says entered update mode, I hear my laptop beep like i connected something,

But nevertheless he skips the update screen...

Very dispappointing so far...



Link to comment
Share on other sites

Try to install using google chrome or some other browser. I had the same problem on a windows 10 machine using internet explorer (not edge) and it would not install. I thought I had bricked my unit for good. I could not boot up with any foot switch combinations. I finally used google chrome for the install after booting up into safe mode and at long last success. I think I booted into safe mode although I'm not sure it fully booted up. I only got a blank screen when I first booted up in safe mode.   I started the off-line install anyway and it finally installed the update. I used goggle chrome to download the firmware update file. Couldn't get internet explorer to download the file.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...