Jump to content
Sign in to follow this  
cpllorenzo

Help with Helix Editor Installation Issues

Recommended Posts

Dear Helix User Friends,

 

I have recently purchased a Helix LT and have already successfully managed to upgrade the firmware to 2.21, however I am having issues installing the latest version of the Helix Editor software.

 

I have downloaded the latest software (Helix 2.21) at the Line 6 website and installed on my computer (Windows 7), however when attempting to open the editor I receive an error message saying “Helix has stopped working).

 

I have uninstalled and re-installed the software various times, I have re-booted the computer between installations, etc and nothing seems to work…

Has anyone else faced the same problems? Any ideas on how to get over this issues and get the software up and running?

 

Thank you and I look forward to some help!

Share this post


Link to post
Share on other sites

Are you opening the editor with the USB connected to Helix, or with no connection?

Share this post


Link to post
Share on other sites

Dear Helix User Friends,

 

I have recently purchased a Helix LT and have already successfully managed to upgrade the firmware to 2.21, however I am having issues installing the latest version of the Helix Editor software.

 

I have downloaded the latest software (Helix 2.21) at the Line 6 website and installed on my computer (Windows 7), however when attempting to open the editor I receive an error message saying “Helix has stopped working).

 

I have uninstalled and re-installed the software various times, I have re-booted the computer between installations, etc and nothing seems to work…

Has anyone else faced the same problems? Any ideas on how to get over this issues and get the software up and running?

 

Thank you and I look forward to some help!

 

You may have already tried this but I would suggest unplugging every USB connection possible on your computer, rebooting, and then trying each available USB connection (front, side, back) with the Helix. 

Share this post


Link to post
Share on other sites

Thanks for the answers...

 

I have disconnected Helix from the USB and also tried different ports on the computer... still no luck!

 

Any other ideas I could try?

Share this post


Link to post
Share on other sites

Thanks for the answers...

 

I have disconnected Helix from the USB and also tried different ports on the computer... still no luck!

 

Any other ideas I could try?

http://line6.com/support/topic/16055-unable-to-connect-to-pc/

Interesting, another topic on this that looks eerily similar with no resolution. When was the last time you ran the Windows Update on your PC? It looks like at least one user was having more luck with a Windows 10 machine than Windows 7.

 

Btw, did you do the global reset after updating your firmware (take backups first)?

 

Some other thoughts:

  • Try a different USB cable
  • If available I would try connecting to another computer, hopefully with a more up to date OS, and see if you still get the same disconnect message. If so I would probably try doing the firmware update and global reset again.
  • Contact Line6 tech support
  • Downvote 1

Share this post


Link to post
Share on other sites

http://line6.com/support/topic/16055-unable-to-connect-to-pc/

Interesting, another topic on this that looks eerily similar with no resolution. When was the last time you ran the Windows Update on your PC? It looks like at least one user was having more luck with a Windows 10 machine than Windows 7.

 

Btw, did you do the global reset after updating your firmware (take backups first)?

 

Some other thoughts:

  • Try a different USB cable
  • If available I would try connecting to another computer, hopefully with a more up to date OS, and see if you still get the same disconnect message. If so I would probably try doing the firmware update and global reset again.
  • Contact Line6 tech support

 

 

I have the same issue and I did all you advice, the last step, contact with line 6 was do nothing… "wait for new actualization"  :huh:

Share this post


Link to post
Share on other sites

Got it working!

 

I changed USB ports, updated windows and turned off firewall.... then reinstalled drivers and software....

 

not sure what was the problem so tried a bit of everything at once...

 

Thanks for the help...

Share this post


Link to post
Share on other sites

Got it working!

 

I changed USB ports, updated windows and turned off firewall.... then reinstalled drivers and software....

 

not sure what was the problem so tried a bit of everything at once...

 

Thanks for the help...

 

Glad to hear it!   :)

 

Not sure what shook things loose and allowed the Editor to work properly but you mention a couple of potentially relevant details that might help someone else that don't get mentioned often. The usual advice - reflashing firmware, installing/uninstalling Editor, trying alternative USB cable or port, or another computer,

but also...

  • Update your OS, particularly with an older OS like Win 7
  • Turn off firewall/antivirus while you test (might want to be offline when you do this) and check if Editor works properly. Turn firewall/antivirus back on. Note: Most machines don't seem to have any problem the Editor working with firewalls or antivirus programs other than very occasionally during the download of the software. Turning off the firewall/antivirus is not only usually unnecessary but does entail some risk although it can be minimized. This should probably be one of the last things attempted and I am not sure if it helped but certainly worth a try. I have definitely had firewall and antivirus programs interfere with other (not Helix) software installs or device communication in the past.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×