Jump to content
Doezer99

JTV-59 3 Way Selector Switch - Works with Variax but not with Pickups

Recommended Posts

Hi folks..

 

Ive just bought a 1yr old JTV-59.   It has a fault with switching between pickups though.

 

The 3 way selector switch works fine when switching between Variax sounds,  but not when Im trying to switch between the regular pickups.

I can only hear the Neck Pickup.  The other two settngs just give silence..

 

Could someone please help - is there a part I can buy to swap out?  

 

May I just say that other than that,  the guitar looks, feels and sounds amazing.  Really exceptional - especially the pickups,  but also the Variax sounds.

sounds amazing  ;))

 

 

Thanks

Domhnall

Share this post


Link to post
Share on other sites

It's a complex switch assembly, so don't mess with it, it very touchy in there, probably a solder point.

It could be the pick-up cable, or the pick-up itself. Could even be a debris short.

 

May seem easy to deal with, but it's also easy to mess up, and those end up on my bench all too often and

take longer to deal with. So leave it to those who know the insides of these. They aren't our fathers guitars.

 

Make certain your guitar is registered in your account, then log a ticket in your account with Line 6 Custom Support.

 

Share this post


Link to post
Share on other sites

I have a friend who has literally pulled apart various Variaxes and re-built them.  hes a bit of an electronics whizz.

so i do trust him.

Im based in Ireland so if I were to go the Line 6 route is there anyone here that does that work??

 

thanks

Domhnall

Share this post


Link to post
Share on other sites

https://line6.com/find/service_center/

 

I don't know anyone in Ireland, but I have a mate, Mark Wright Music in Northampton. He used to be my opposite number

at Line 6 Rugby, when we had a location there. He knows these guitars as well a I do. Also E&M Electronics in Milton Keyes.

 

 

Share this post


Link to post
Share on other sites

I have a recent purchase JTV-59 that has a similar issue , but the opposite symptom.

The mag PU's switch just fine.  The models do not switch.  The modelling sounds work but the default sounds

for the model comes up when you rotate the knob such as Lester, spank etc....  It just won't switch between the 

various PU sounds in the preset.  Latest software loaded 2.14.  Did not work on previous software either.

Opened ticket, looks like I need to take it to an authorized SC. 
 

I took photos of the switch cavity.  There is a pair of wires, red & white for each PU that should have shrink on them. 

Neck PU wires did not have shrink and the connection was laying on a soldered joint.  Thought that was the issue.

Put shrink on it but no change.   Mags work fine, models work, but no model PU change when toggle is moved.

I'm open to any suggestions  from you psarkissian to keep this rascal off your bench.  I'm an electronics guy with

years of guitar/amp/fx repair.  I did not pull the switch per your warnings.  I did check that all the terminations were made

in the cavities.  Nothing obvious laying about inside.

 

 

20180625_000308[1].jpg

Share this post


Link to post
Share on other sites

Hello bobruz! I have the exact same issue with mine JTV 59! The mag pickups works fine,but the variax don't change presets... I've disassembled the switch and I measured all the switches(microswitches inside) and terminals,everything seems OK,but still the switch doesn't change the presets in Variax mode... Do you have any progress on your guitar? I'm out of ideas... :( 

Thank you! :)

Share this post


Link to post
Share on other sites

Hi Andrioman,
Mine turned out to be faulty switch.  Line6 repair depot fixed it up for me.
I did see some questionable joints, but reflowing them did not solve the problem.
Turnaround was only a week or so in my case.  I live like 2 mins. from authorized service shop.

 

Bobruz

Share this post


Link to post
Share on other sites

Possible reasons,...

-May need to re-install or update Flash memory.

-Problem with the 3-Way switch or switch in the Model encoder assembly (would require a trip to a Line 6 authorized service center).

-Not changing presets could be problem with the Model encoder contacts (would require a trip to a Line 6 authorized service center).

 

Share this post


Link to post
Share on other sites

I see... Thanks to both of you! Now I know where is my problem! :) It's the encoder, because I tried to flush it with some contact spray, but also with WD40 which was a bad idea... Strangely the encoder works perfectly, but maybe there is some contact issue on some pins inside... :)

Unfortunately I don't know where to purchased it in Europe, there is a shop I know, but only for US. 

I'll try to fix it in some way :) 

Thank you guys! 

Cheers! :) 

Share this post


Link to post
Share on other sites

" Strangely the encoder works perfectly, but maybe there is some contact issue on some pins inside " --- If it is skipping

over some of the Models,... then yes, it is a failed encoder.

 

And as far as contact cleaning goes,... 

... something I prepared for the admin for such questions.

 

Best to have done by an authorized service center,... https://line6.com/find/service_center/

 

    Sc Pecef Tehnica Srl
Ploiesti, Pompelor Street No. 3
Ploiesti, 100 411
Phone: 0344403030
Email: service@pecef.ro
URL: http://www.pecef.ro

 

 

Share this post


Link to post
Share on other sites

Then my encoder is OK :) I'll keep trying to fix it, but if I don't find the problem I'll get new switch and encoders.

Thanks a lot for the info! :) 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...