Jump to content
Maestro77

No Volume Control with Helix as Sound Device on Mac?

Recommended Posts

hey,

 

on my previous mac mini from 2014 with the older osx i had a normal volume control in the menu bar.

this was quite good, because i do not want to have every youtube video and so on playing at 100% by default as they can be extremely loud.

 

now with my new mac mini 2018 and the same helix driver there is no volume control available anymore now.

 

is that normal?

can i change this?

how is it for you? do you have volume control on max os mojave with helix?

 

thank you!

 

--------------> Answer: <--------------

 

for anyone who has the same problem:

 

1) mac os possibly blocks the driver.

go to your mac system preferences -> security

there should be a button to allow the driver.

more on this here:

https://line6.com/support/page/kb/recording/computer-audio-set-up-and-troubleshooting/macos-high-sierra-1013mojave-1014-driver-installation-change-r879/

 

2) when you start your mac and the helix (lt) at the same time it can happen that the driver will not work.

in this case power off the helix off and power on again.

 

Share this post


Link to post
Share on other sites

Are you using the Helix Driver as your Output control?

 

Go to Control Panel; Sound; Output and make sure 

the output is your audio interface. 

Share this post


Link to post
Share on other sites

yes. it is selected as the output device and the sound is going into (and out of) the helix properly.

 

in Control Panel; Sound; Output -> it says "the chosen device has no volume control".

(or something similiar; i have translated this from my language to english).

 

i start to think it is normal like that but i want to be sure.

having the volume control would be great.

 

and on my previous mac i had the volume control with the same driver, same helix.

only the macmini and the mac os are new.

 

 

Share this post


Link to post
Share on other sites

You can adjust the playback volume from your computer by going to Global Settings>Ins/Outs>USB In 1/2 Trim.

 

Are you using the Line 6 driver or the Core Audio drivers on your Mac?

Share this post


Link to post
Share on other sites

Good, glad it's working now Maestro77. Could you change/add to the topic "Solved" now? Thanks.

Share this post


Link to post
Share on other sites

hey,

 

sadly it is not solved.

the helix is now twice in the sound settings.

 

one is called "HELIX Audio" and the other one "Line 6 Helix LT".

 

does anyone know why the helix is displayed twice now?

 

also the one called "Line 6 Helix LT" offers me a volume control (which is good) but somehow this driver only worked once and now no more.

 

the other one called "HELIX Audio" does not offer me a volume control which is a bit annoing because every website etc. that has sound can start blasting at full volume.

 

how can i solve this whole issue?

do you guys have a volume control (besides of the physical one on the device itself, of course)?

 

and how is the device called on your mac? helix audio or line 6 helix lt?

 

thank you very much!!

Share this post


Link to post
Share on other sites

Audio Midi Setup is your friend. Get to know him.

Share this post


Link to post
Share on other sites

i solved it and i have edited my first post so anyone with the same problem can solve it right away.

 

thanks for all yor help!

Share this post


Link to post
Share on other sites
Posted (edited)

Seeing this issue on my macbook pro, running Catalina with latest Helix driver installed (1.0.7). The helix device is new, and upgraded to 2.82. Trying to load L6Helix.ext is denied due to invalid signature, as seen in the output below. Anyone able to workaround this issue? I'm hoping once the signature issue is resolved, I could do the "Allow" step mentioned here as the solution, and be happy :-)

 

$ kextstat | grep -i line6

  206    0 0xffffff7f83ed0000 0x18000    0x18000    com.line6.driver.helix (1.0.7)  ..

 

$ sudo kextutil /Library/Extensions/L6Helix.kext

/Library/StagedExtensions/Library/Extensions/38DF1AE2-F7E9-4C54-A11C-C512AA622B69.kext does not appear in strict exception list for architecture: x86_64

Untrusted kexts are not allowed

Kext with invalid signature (-67007) denied: /Library/StagedExtensions/Library/Extensions/38DF1AE2-F7E9-4C54-A11C-C512AA622B69.kext

Bundle (/Library/Extensions/Line6Audio.kext) failed to validate, deleting: /Library/StagedExtensions/Library/Extensions/38DF1AE2-F7E9-4C54-A11C-C512AA622B69.kext

Unable to stage kext (/Library/Extensions/Line6Audio.kext) to secure location.

Warnings: 

    Dependency lacks appropriate value for OSBundleRequired and may not be available during early boot: 

        com.apple.vecLib.kext - OSBundleRequired not set

        com.apple.iokit.IOAudioFamily - OSBundleRequired not set

 

(kernel) Notice - new kext com.apple.driver.usb.AppleUSBHostPlatformProperties, v1.2 matches prelinked kext but can't determine if executables are the same (no UUIDs).

 

UPDATE #1: the issue (i.e. no volume control) still persists, even after disabling SIP (as shown here https://www.tonymacx86.com/threads/guide-installing-3rd-party-kexts-el-capitan-sierra-high-sierra-mojave-catalina.268964/page-16), which bypasses the signature check. So, there must be another issue, possibly in the driver?

 

UPDATE #2: the issue is seen even with driver version 1.0.5 (verified using kextstat that installed version is 1.0.5).

 

Any advice on how to further debug this? How to verify whether the driver is basically working ok or not, besides the volume control being greyed out?..

 

Thanks

Edited by itsikhen
Update after trying driver v1.0.5

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...