Jump to content

HEADS UP: Check these parameters after every firmware upgrade


HonestOpinion
 Share

Recommended Posts

Dealing with an issue in another topic it occurred to me I should bring attention to the now two global settings I am aware of that live and are set within presets instead of the global settings. These parameters need be changed only once in any preset and that parameter's value will be reflected in all other presets. Due perhaps to these parameters' somewhat unique and special status I do not believe they are currently being reset to their former values after a firmware upgrade. Even after the global settings and/or user presets are restored from backup.  If this is indeed the case Line6 should probably eventually modify the firmware upgrade process such that these settings also be included with a global settings restore from backup.

 

The two settings I am currently aware of are the Output block's Powercab+ setting 'Powercab Remote' and the Input block's Variax parameter 'Variax Settings'. Even though both of these settings are located within a preset, once they are changed, a single time, any preset will do, their new value is automatically reflected in every other preset without requiring it to be set there as well. They are essentially global settings hidden within a preset!!!

 

So if you are seeing problems with remotely changing settings on the PowerCab+ , or similarly if your Variax settings are not changing properly, the above parameters' settings may be worth checking.  There is a good chance that many users, depending on your setup, may want to change one or both of these settings to "Per Preset" (rather than "Off" or "Global" depending on your use case).

 

Until and if Line6 changes the global settings restore process  if you are a Powercab+ or Variax user you may need to check and reset these parameters after every firmware upgrade.

  • Like 2
  • Thanks 2
  • Upvote 2
Link to comment
Share on other sites

Just for giggles I re-flashed my Floor. Although my presets were still there, the Powercab REMOTE setting had changed to OFF.

Restoring my backup returned everything to normal though.

Don't know about the Variax thing, not a Variax guy and I didn't check it before and after the test.

Wonder if that's at least one of the reasons for the specific instructions to backup before and restore after the update?

Anyhow nice catch. I don't know why I'd change the Powercab setting from PRESET to OFF or GLOBAL, but nice to know that if I did it would affect ALL my presets.

  • Upvote 1
Link to comment
Share on other sites

1 hour ago, rd2rk said:

Just for giggles I re-flashed my Floor. Although my presets were still there, the Powercab REMOTE setting had changed to OFF.

Restoring my backup returned everything to normal though.

Don't know about the Variax thing, not a Variax guy and I didn't check it before and after the test.

Wonder if that's at least one of the reasons for the specific instructions to backup before and restore after the update?

Anyhow nice catch. I don't know why I'd change the Powercab setting from PRESET to OFF or GLOBAL, but nice to know that if I did it would affect ALL my presets.

 

Thanks for going to the trouble to test this. So perhaps the Powercab+ setting is being restored with a full globals or user setlists restore from backup? I will try to remember to watch for this next time I upgrade. I know, as codamedia observed above, I have had to reset the Variax setting every firmware update although I don't remember if I had to with the 3.10 update. I also don't recall whether I needed to reset the Powercab+ setting as I started testing these two parameters after this firmware update without taking note of their initial values. As you pointed out, even if Line6 modified the restore process to include these two parameters in 3.10(not sure) it is a good thing to be aware of their unique "hybrid" operation and behavior among all other settings at the preset and global level.

Link to comment
Share on other sites

20 minutes ago, rd2rk said:

Just for giggles I re-flashed my Floor. Although my presets were still there, the Powercab REMOTE setting had changed to OFF.

Restoring my backup returned everything to normal though.

Don't know about the Variax thing, not a Variax guy and I didn't check it before and after the test.

Wonder if that's at least one of the reasons for the specific instructions to backup before and restore after the update?

Anyhow nice catch. I don't know why I'd change the Powercab setting from PRESET to OFF or GLOBAL, but nice to know that if I did it would affect ALL my presets.

 

I can confirm restoring globals does restore the variax setting as well. 

 

I used to only restore globals - though am now doing full factory reset and restoring all - and have only had one instance where just one set list lost the Variax changes that were linked to snapshots. Unfortunately I only noticed after relevelling the whole set - so that was a bit of a pain, but a on-off.

  • Upvote 1
Link to comment
Share on other sites

11 hours ago, waymda said:

 

I can confirm restoring globals does restore the variax setting as well. 

 

I used to only restore globals - though am now doing full factory reset and restoring all - and have only had one instance where just one set list lost the Variax changes that were linked to snapshots. Unfortunately I only noticed after relevelling the whole set - so that was a bit of a pain, but a on-off.

 

Did you restore only your globals or the user setlists as well?  Properly testing the current restore process with these variables might be a bit arduous. First you need to determine if the restore is resetting both the Powercab+ and the Variax settings. If it is this would be a change from previous firmware upgrades.

 

Secondly is it the globals or user setlist restore that is resetting them?  One would think if they are indeed being restored it might be the user setlists restore as the settings are contained within the presets, but maybe not. Otherwise, every time someone imported for example a Customtone preset with either of these two settings set differently it could potentially change the setting in every other preset on your device; so perhaps the settings would have to be part of the globals restore. As a matter of fact, now that I think about it, if you are set to for example "Per Preset" and the CustomTone preset you import is set to "Global", I wonder how come it doesn't affect the rest of your presets? It is a "set once, sets everywhere" setting. Did Line6 modify these settings' behavior upon import such that the new preset inherits your existing parameter settings for the Powercab+ and Variax? Maybe these two remote operation settings, PC+ and Variax, are not even contained in a preset's backup file.

 

Lastly, you need to determine if they are being set to a factory default or your previous firmware's setting,  In the past Line6 has changed some of their factory defaults from firmware to firmware. It might take a couple of test runs through the firmware upgrade and restore process to make sure your previous firmware's settings for these two parameters don't just happen to coincide with a factory default.

 

All these variables that need to be controlled for would probably be required in addition to rd2rk's and your test results in order to reach a more clear conclusion on how these parameters are working upon restore in 3.10.  PITA, I think for now I am just going to recheck these parameters after a firmware update :-)

Link to comment
Share on other sites

Hi

 

I made the update Friday evening and haven't had time test this as I hoped. My gear (LT and PC+ through L6-Link) works the same way as before the update, I did not lose the L6-Link. I have it set up with "Remote: Preset" and "Select (Preset): 1+2" (I never changed it, was default).

 

After reading this post I made some more test this morning and checked the L6-Link parameters in HX Edit and it was as when I made the preset (checked about 5 of them in three different setlists)

 

Upgraded as follows - Made a backup before I made any changes and another in the installations process (just in case...). The system rebuilt the presets and I made a factory reset and restored everything from the last backup (global, presets, IR...), full backup and restore (I did not restore the the factory presets, kept the new ones). After backup I rebooted the system and there was another rebuilt of patches in the setlists made by me. Hade no problems what so ever in the upgrade process and it passed my quick-test.

 

Hope it can er of any helps to narrow things down. Let me know if you want me to test something. 

 

Good job...

 

//Per

 

 

  • Upvote 1
Link to comment
Share on other sites

Just updated to 3.1... and decided to run a few tests regarding this post. 

  • Updated and nothing else.... 
    My presets worked, my variax settings did not, my tuner settings were gone and my global settings were all lost. 
  • Then I restored "GLOBAL SETTINGS ONLY".... 
    My presets worked, my Variax settings now worked as expected, my tuner settings returned and all my global settings were back to normal
  • I then followed the 3.1 "final instructions" and did a full reset of the Helix then restored everything from my backup. Everything is working as expected. 

It appears the "global restore" is taking care of the Variax settings, tuner settings, as well as all global settings. I don't own a Powercab so I can't comment in that regard.  

  • Upvote 2
Link to comment
Share on other sites

18 hours ago, codamedia said:

Just updated to 3.1... and decided to run a few tests regarding this post. 

  • Updated and nothing else.... 
    My presets worked, my variax settings did not, my tuner settings were gone and my global settings were all lost. 
  • Then I restored "GLOBAL SETTINGS ONLY".... 
    My presets worked, my Variax settings now worked as expected, my tuner settings returned and all my global settings were back to normal
  • I then followed the 3.1 "final instructions" and did a full reset of the Helix then restored everything from my backup. Everything is working as expected. 

It appears the "global restore" is taking care of the Variax settings, tuner settings, as well as all global settings. I don't own a Powercab so I can't comment in that regard.  

 

So perhaps the global setting restore now takes care of both of the Powercab+ and Variax remote settings? That would be great. Thanks to all the users on this topic who jumped in and did some testing. For me the takeaway here is that if you are having problems with remotely controlling your Powercab+ or Variax these settings are good to be aware of. Whether the issue is that you never ran a global settings restore, didn't know they existed and therefor never set them up properly, or that you changed them in one preset not realizing it would impact all of your others.

 

At this point I just think of these two parameters, 'Powercab Remote' on the Output block  and 'Variax Settings' on the Input block, as global settings that happen to be located within the presets instead of the global settings. Unusual but not an issue as long as you know they are there and how they operate. Even better if they are now quite possibly being handled properly in the global settings restore process.

  • Like 2
  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...