These forums are read only, please use our new forums here.

Main :: POD 2.0, PODxt Family, Pocket POD, FloorPODs



PODxt: Invalid Code Error 01
by BulletZ on 2011-03-12 10:18:00.3160

Hi,

My PODxt, which I hadn't used in a while, stopped working. Powering it up, the display shows "Invalid Code Error 01".

I tried power cycling it many times. Once it eventually started and I thought it was working again, but the next day it did it again. It showed Error 02 once, then it eventually came back to life once more, only to freeze almost immediately after touching the knobs. Now it's not coming up anymore.

I've tried the "Save+Edit" powerup, doesn't work. I've tried starting it in Safe Mode, I have no idea whether that works or not since the display doesn't change. I could nonetheless connect it to Monkey, and the Flash Memory shows as "Unknown Version". Tried flashing it, the flash went through fine, and Monkey told me the flash was successful, except after power cycling it again once the flash was done, it displayed again the Invalid Code Error 01 and showed as unknown flash version in Monkey yet again.

Is it dead?

That unit is about 4y old, and has seen little use. I'm quite worried, I was planning to buy a newer one, but if this is a testimony to Line 6's product build quality, I'm not sure I'm gonna follow suit...

Thanks for your help.



Re: PODxt: Invalid Code Error 01
by BulletZ on 2011-03-12 11:18:17.7380

A little more info: I tried starting the POD in Safe Mode B. That worked, and the SRAM test passed. I did flash it again in Safe Mode B, it went well. After restarting, it finally booted, I could use it for about 5mn, then it froze again. After restarting it, Monkey would no longer be able to flash the memory. It sees the correct USB firmware version, but claims timeout trying to access flash memory, and it's thus now impossible to attempt flashing anymore.

I can still access Safe Mode B, it still passes SRAM test, yet Monkey will not allow flashing anymore.

Looks to me like a flash memory failure. I'd happily replace any component myself, provided they're not SMDs (I haven't opened the POD yet) and I'm given hint as to what to replace...



Re: RE: PODxt: Invalid Code Error 01
by laplayantonio on 2011-03-17 03:04:28.9030

hello

  it seems your XT needs repairing

  please contact directly your Line6 dealer if your gear is still under warranty

  if it's not longer under warranty, please contact the FR Line6 Service Center: ( http://fr.line6.com/support/serviceCenters/ )

  FuzzIT – LINE 6 Service Center

  HUGO VAN DER GOESSTRAAT 17A

  9000 GENT – BELGIUM

  +32 938 30580

  merci d'inclure les données suivantes :

  - Nom et adresse

  - Numéro de TVA (seulement sociétés)

  - numéro de téléphone

  - adresse email

  - description détaillée de la panne.

  line6antonio



Re: RE: PODxt: Invalid Code Error 01
by BulletZ on 2011-04-04 08:45:02.3860

The POD is obviously no longer under warranty, unless this flaw qualifies as a "latent defect", which I'm wondering about given the number of reports on internet.

Assuming the socket-mounted flash is dead, where would I be able to purchase a replacement? Mine has a sticker saying:

POD/BODxt-SERIES

v 1.03 c/s:96FB

I've also contacted the support center as per your suggestion. Note that shipping my product to Belgium for repair is not really an acceptable solution.

Thanks.



Re: PODxt: Invalid Code Error 01
by BulletZ on 2013-03-12 10:19:25.3630

Reviving this old post, some more info as I'm "playing" again with this little devil. It appears that XT works "fine" (once it boots successfully) provided I don't touch any of the controls (knobs and buttons), i.e. that I do all settings via Line6 Edit. If I do that, then I can use it for hours. But touching any button is going to freeze it almost every time.

Since I doubt all the buttons went defective at the same time, I believe two things could explain this behaviour:

1) a general hardware problem in the button/knob control circuitry (I'm going to replace some of the bigger chemical capacitors which may have reached end of life)

2) a software problem

Hope this is helpful. It doesn't make the device super useful, but at least it can be used with a computer, somewhat.



Re: PODxt: Invalid Code Error 01
by BulletZ on 2013-03-13 09:15:03.2870

Definitely hardware related. Removing the /top/ cover "fixes" everything: the thing works like a charm. Gonna be looking for dry solders or (more likely) grounding issues.

Still, maybe this will help others...



Re: PODxt: Invalid Code Error 01
by toneman2121 on 2013-03-13 12:43:28.6490

...and 2 years later. that's great man! spray it with electronics cleaner. have you separated the top from the board? anyway good luck. come back and tell me what you found. i'm sure someone will benefit. i've read post with a similar story.




The information above may not be current, and you should direct questions to the current forum or review the manual.