Jump to content

rock2112

Members
  • Posts

    10
  • Joined

  • Last visited

Everything posted by rock2112

  1. Seeing how I bought my Helix on 9/2/15, which was part of the first distribution, it was already past 2 years old, thus past the 2-year extended warranty. So no way to take advantage of this offer. Didn't seem quite right.
  2. I agree with Uber Guru: 4 Patches showing on top row and 4 snapshots on the bottom row. Plus you always have the option of hitting the Mode button to view the various effects which can be turned on or off if needed.
  3. Just bough an EON615. So far liking it a lot for both guitar and bass. Hope to buy another soon.
  4. I've been using a small Fender keyboard amp for several years with pretty good success, but have wanted to upgrade to a nice FRFR speaker. Finally bought the JBL EON615. I went with the 615 because I also play bass and wanted a little beefier bottom-end response. After accessing the EQ settings via bluetooth I was able to save settings for both the guitar and bass. I'm very pleased with what I'm hearing from both. I'm finding that it's easier to match the output levels from patch to patch which makes it a little easier for lady mixing the FOH at our church. I'll probably get another 615 in the near future. Very pleased.
  5. I'm using the VDI cable with my JTV89F, but this past weekend I used the G30 with my bass at church and it worked great. I haven't heard much in the forums about how the bass amps on Helix were, but the sound guy at church was digging what he was hearing. My G30 has always worked great.
  6. Used my Helix at church for first time last Sunday. 1/4" mono out to DI box to FOH (haven't switch to the XLR yet but this works great). Volume set to about 2:00 on dial. Good signal to FOH and sounds great. Volume setting, coincidentally, is about the same on my X3 Live. Using JTV89F and life is good!!!
  7. Sweetwater VDI cable is $30. It is long but so far I'm liking it since I can route it various ways to keep it out from under my feet.
  8. Actually, I've found just the opposite. After the initial update to 1.01.2 and not seeing the model changes, the next day, with my JTV89F already connected to the Helix, the Helix is then turned on and the model changes worked. And has continued to work so far. So this is definitely not working consistently from unit to unit. The new update should be out soon with this fix and others. I will try it your way Xavierb. Thanks.
  9. Received my Helix today. Liking it a lot so far. I'm using a JTV Variax and have the Variax setting on "Per Preset". The preset is saving the Variax model but Helix is not forcing the change to that model. It plays whatever model the Variax is currently on. Am I missing something or is this a glitch?
×
×
  • Create New...