Please ensure Javascript is enabled for purposes of website accessibility Jump to content

connected but nothing happens


Recommended Posts

Dear community


I recently purchased an Amplifi 150. I installed the amplifi remote on my Ihpone 6S and connected to the Amplifi 150 through Bluetooh. I was successfull according to the app, and  I can use the device to play music from Youtube on, so that should hold.


My problem is, when I change settings in the app, eg. I want the settings to be like "nothing else matters" or anything else, like just turn up the volume through the app, nothing happens. I cannot controll anything. When I play on my guitar the sound is the "same" no matter the settings in the app.


There must be something very basic that I have done wrong, does anyone know what it is?


Thank you all in advance for helping out.


Best regards



Link to comment
Share on other sites

I had the same problem.  The amp is v. 1.0.  I've tried 2 computers (Win 8 and 10) and 3 iPads of varying versions to update the firmware.  The updates all fail via iOS and when attempting USB connection, the box is empty where I'm supposed to "Select device to update".  Device manager shows USB Composite device -- "This device cannot start (Code 10)" STATUS_DEVICE_DATA_ERROR. 


I've performed the factory reset on the amp and cannot seem to get it to go into update mode where the 4 tone indicators (A-D) blink.  Powering up with Tone & Tap pressed yields all tone indicators dark and just the tone button lighted.  There are clearly other debug modes from different combinations of button presses while powering up.  Should I be using something else?  I cannot find any documentation on any other button combination modes.


This is a horrible out-of-the-box experience.


Please post a solution

Link to comment
Share on other sites

  • 2 weeks later...

I have tried multiple devices, two iphones (5S + &S) and an Ipad, device timeout, update failed, restart amplifi....this reeks of a use the amplifi remote I need to update flash memory on the amplifi, and I cannot update the flash memory...problem is I waited to recieve the printer USB, and now I cannot return the amplifi, I am basicly left with an ugly bluetooth speaker....this is truly a horrible product, I would advice everyone NOT TO BUY THIS

Link to comment
Share on other sites

Hi all,


I got the Amplifi 150 and had the same issues: tried to update the firmware with an ipad, then with two different PC's and a direct connection via USB. Nothing worked. Finally, I downloaded the firmware updater for MacOS here:


and connected the Amplifi to my MacBook Air via USB cord. The installer recognized the Amplifi, and I was able to upgrade my firmware to the latest version, following the instructions on the screen. The updater works with all Mac Os X flavors, including El Capitan.


One thing I would like to point out; before you update, put your Amplify in 'update mode'. You do that by powering off the Amplifi first, then hold down the 'Tone' and the 'Tap' button at the same time while powering it on. If you have tried updating with your Ipad and failed, you might want to try this step. 


I admit the documentation is not great. But don't give up - once you update your firmware and get the app to work, it's actually an excellent amp. Good luck!

  • Upvote 1
Link to comment
Share on other sites

  • 1 month later...

I had the issue out of the box last might but luckily I was able to update the firmware using my iPad. I have to admit it was frustrating up until I looked at the forum and found the fix. Line 6, maybe you ought to take this stuff more seriously? you are not making long term friends this way.....

Link to comment
Share on other sites

@Lordloen I had the same issue, what you need to do is download the Line6 updater software in order to install the update.


Then you can select the .tmf file


I had installed the firmware update at least ten times to no avail. Then I finally did a factory reset (hold down the volume knob and tone button while turning the power on) and it seems to be fine now. Only pain in the lollipop was having to reinstall my tones from the app.

Link to comment
Share on other sites

  • 2 months later...

I had the same problem - and the primary reason why it doesnt work is because the amplifi drivers dont install automatically


on a windows pc: 


1. download the updater software

2. download the latest windows driver 

3. install the latest driver - it will automatically install the driver to the line6 path

4. plug the usb cable in 

5. you will see the device in your control panel - under devices - except that you will have an error - device doesnt start 

6. click into the device - and click on drivers - this will allow you to browse to the line6 folder and installed driver path 

7. click ok 

8. driver installs 

9. you should be able to now see the amp when you launch the updater

10. update as per instructions 

Link to comment
Share on other sites

  • 1 year later...

I have turned somersaults trying to update my AMPLIFi 150 using various PCs and versions of Windows. I am an experienced software developer, and I also know my way around a PC. The AMPLIFi USB driver appears not to install properly. Line 6 really needs to address this problem. When I suggest this on the support ticket, I get, “I can assure you that the driver works†as a response. Sorry, Line 6, you are dreaming. FIX IT.


In the end I updated the AMPLIFi using my iPhone via Bluetooth, which Line 6 says is unlikely to work. Here again, the Line 6 instructions were misleading. The secret is to click, “Show previous versions†in the AMPLIFi app, which then shows not only previous versions but also the update you wish to install, along with a handy update button. You don’t need to set the amp up in update mode because the iPhone app does this for you. It took about an hour to update, so charge up your phone and disable the screen saver before you begin.

Link to comment
Share on other sites

I have turned somersaults trying to update my AMPLIFi 150 using various PCs and versions of Windows. I am an experienced software developer, and I also know my way around a PC. 

I agree with you 100%. I'm also a very experienced hardware jock who could not make this work with the Amplifi 150, and I tried it with 3 different computers, precisely as-directed, and even attempted it while on the telephone with tech support, giving a play-by-play report of the result of each step. There are plenty of similar posts about this issue on the forum. Something is wrong with the process.


I had to spend $113 to send my 150 to California, and it was returned, working, without explanation, 3 weeks later. I had to ask what was done to correct the problem, and was told that it 'simply' needed to be reset to the factory default and then updated to the latest firmware version -- precisely what I was attempting to do!


Thanks for your explanation of how you resolved your problem. I smell 'abandonment' of this product line, and doubt that I'll ever have to nervously contemplate a future firmware release, but I'd be tempted to go the bluetooth route, if attempting it at all. 

  • Upvote 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...