Jump to content
sech

Helix MIDI preset changes V2.81

Recommended Posts

This post is for those who use a PC to trigger MIDI events in Helix. Since I updated to the 2.8 firmware, my USB connectivity for MIDI is not working.  I’ve checked all of my settings, reinstalled the ASIO audio driver and validated my USB connection to the PC as I’m able to control Helix perfectly through HX Edit app. I also validated the issue by reverting back to 2.71 and testing and everything worked fine. I also copied all of the global settings so I could reset them all in 2.8. Well, the issue is back and I don’t know what to try next. Any known issues or ideas you can share with us? I really need to resolve this before my upcoming live performances, thanks!

Share this post


Link to post
Share on other sites

Using MIDIOX, I routed my FCB1010/UNO via USB through my laptop and back out to a Helix Floor. No problems encountered.

Both devices are using MIDI Channel 1

MIDI THRU is OFF

MIDI OVER USB is ON

MIDI PC RECEIVE is set to USB

MIDI PC SEND is set to USB

 

I then routed it in Ableton Live. Again, no problem. I don't really know how to record the MIDI events from the FCB and play the back to the Helix, but I'm going to find out how just out of curiosity.

 

Meantime, check your settings.

 

EDIT: I left out MID PC SEND set to USB - required when recording midi FROM the Helix!

Share this post


Link to post
Share on other sites

OK, so forget LIVE. I switched over to Reaper and recorded a series of Preset changes from the FCB and played them back to the Helix, no problem, presets changed as expected.

Your problem is somewhere in your system configuration, Helix v2.81 works fine with recorded MIDI.

Share this post


Link to post
Share on other sites
16 hours ago, rd2rk said:

Using MIDIOX, I routed my FCB1010/UNO via USB through my laptop and back out to a Helix Floor. No problems encountered.

Both devices are using MIDI Channel 1

MIDI THRU is OFF

MIDI OVER USB is ON

MIDI PC RECEIVE is set to USB

MIDI PC SEND is set to USB

 

I then routed it in Ableton Live. Again, no problem. I don't really know how to record the MIDI events from the FCB and play the back to the Helix, but I'm going to find out how just out of curiosity.

 

Meantime, check your settings.

 

EDIT: I left out MID PC SEND set to USB - required when recording midi FROM the Helix!

 

I also recorded and played back MIDI PC changes using only the Helix (no FCB). Again, no problems encountered.

Share this post


Link to post
Share on other sites

Ok, I will check all of my settings again, I'm pretty sure they are correct. I've been performing with the same PC laptop and program (Showbuddy) for over a year and the Helix has performed flawlessly, then I updated to v2.81 and now I'm dead in the water. Showbuddy (ENNTEC) is a solo performer software that plays backing tracks, displays lyrics, triggers midi events and also DMX lighting, a whole show in a box so all I do is play guitar and sing along. Like I said, I went through the trouble of reverting back to v2.71 to check things and sure enough the midi commands triggered the Helix perfectly so then tried back to v2.81, nope...no go. Thanks for trying to help me out man!

Share this post


Link to post
Share on other sites

Unless "Showbuddy" has a FREE demo version, I can't troubleshoot that for you. All I can do is Record and Playback PC changes from/to Helix using Reaper. MIDI is MIDI. There has to be a problem with the communication between Helix an Showbuddy.

 

I just found the Showbuddy Demo. I'll have a look at it later and see waht I can see.

Share this post


Link to post
Share on other sites

Despite the lack of documentation I was able to create a midi chunk file, import an audio track, and play it.

Took about 5 minutes to figure out. Cool piece of SW!

Helix changed presets as specified in the chunk file.

Don't know what to say, it all works the way it should.

Are you clicking the "Send to MIDI" button before you start playback?

 

OK, I'm liking it less the more I play with it. In addition to the very annoying 30 minute shutdown on the Demo....

 

It seems (and this could be either a limitation of the demo or my inability to figure out this undocumented SW) that there's no real connection between the MIDI playback and the Audio transport. The MIDI doesn't play back when I start the transport, nor does the transport start when you click Send to MIDI. As soon as I click Send to MIDI the MIDI starts to play back independently of the Audio, and there doesn't seem to be any way to STOP the MIDI playback! 

 

Maybe I'm just not getting it, but I've spent enough time on this. If you know how to get around the above problems, let me know, because it SEEMS like it should be a good piece of SW, though how it can control a whole show without being able to IMPORT a MIDI track to control synths....

Have you seen Cantabile? I'd bet that using the DMXIS VST in Cantabile would get you a whole lot more functionality overall. If I had lights I'd be tempted to try it.

 

Anyhow, I've proven what I set out to do, which is that Showbuddy DOES in fact switch Presets on the Helix.

Share this post


Link to post
Share on other sites

OK, I found the manual. Created a Lightshow and a memo and set the MIDI chunk to start at the beginning.

It all works the way it's supposed to as far as changing Helix presets as required.

 

I wonder if the SW somehow assigns some kind of identifier to the external MIDI device that gets changed when Helix is updated?

Have you tried, with 2.81 applied, to create a NEW MIDI Chunk and see if it works?

  • Thanks 1

Share this post


Link to post
Share on other sites

Ok, I really appreciate your feedback, I’m going to go over everything again and I’ll try what you suggested. I did create new midi chunks post the v2.81 update and didn’t get it to work, including send to midi...

Share this post


Link to post
Share on other sites

That it works when you roll back to 2.71 is most baffling. Only other thing I can think of would be that the MIDI or USB driver isn't installing properly, but if you're starting the 2.81 update by installing the HX Edit file, all that should be automatic. I dunno...very strange!

 

You may need to get with support to check that all the proper drivers are in there.

 

 

Share this post


Link to post
Share on other sites

Ahhhh!

you did it!

You got me on the right track that is...

so, it turns out that the v2.81 update changed the way show buddy sees the helix, so for each preset I had programmed, I had to reset the category from the drop down menu under the new name for the helix and wham, it all works now!

when I said I had created a new midi chunk, I meant that I added one of the existing presets to a new song so nothing happened, but when I created a new preset that’s when I noticed the helix had a different name and when I tested it it worked and so I fixed all of the presets and now it’s all working again, man you really helped me out, thank you, thank you!

Share this post


Link to post
Share on other sites

FANTASTICO!

 

And Thank YOU for turning me on to ShowBuddy. I'll likely never use it, but it's a cool piece of SW!

 

I mentioned previously a program called Cantabile, which is a VST Host on steroids. Here's a link to the Cantabile Community Forum where they're discussing using Cantabile with DMXIS. Not that you need it just now, but if you decide to expand the MIDI/SYNTH aspects of your show, Cantabile is a super powerful alternative to ShowBuddy, and pretty cheap, too!

 

https://community.cantabilesoftware.com/t/thinking-of-doing-dmx-stage-lighting-through-c3-best-practice/2188/11

 

ROCK ON!

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Ok, to answer you previous questions regarding the show buddy sw, I don’t import midi tracks, I only use mp3 backing tracks so in the timeline, I can expand the waveform to exact points and add midi chunks to control lyrics and midi events for external hardware and lights. It really works well for that...

Share this post


Link to post
Share on other sites
Just now, sech said:

Ok, to answer you previous questions regarding the show buddy sw, I don’t import midi tracks, I only use mp3 backing tracks so in the timeline, I can expand the waveform to exact points and add midi chunks to control lyrics and midi events for external hardware and lights. It really works well for that...

 

Reason I was wondering about it was that as a show gets more complex, involving synths, whole MIDI compositions involving multiple synths and drum machines can be included IF they can be imported into the show controller software. That's also why I mentioned Cantabile, it's that next step up if you ever need it.

Share this post


Link to post
Share on other sites

Got it, I’ll definitely check out Cantibile. I searched high and low for software to perform solo and this was the best choice for pc although I use OnSong on my iPad sometimes. Btw, I’m in Texas, where do you live?

Rock on brotha!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×