Jump to content
joeydego

Is Anyone Actually Happy With This Thing?

Recommended Posts

I am very happy with my 150. I find the versatility of different sounds to be awesome, as I make all different kinds of music. It would not be nearly as good without the Line 6 Fbv Shortboard Mkii  though. It stores 25 banks of presets, gives wah and volume and live mixing of effects. No complaints.  I only use the bluetooth, and web connected stuff when I am setting something up then I save it in the presets. I never use bluetooth live. Everythng I need is saved in the hardware and the foot controller. Just plug it all in and go. Very satisfied.

Share this post


Link to post
Share on other sites

Less and less as the days go by. I get tired of having to start and restart bluetooth on my device then start and restart bluetooth discovery on the amp then start and restart the application just to get it to sync. I'm getting closer to going back to a traditional amp/pedal setup.

Share this post


Link to post
Share on other sites

I have the 75 and I just use it as a practice amp, but it can be used for practicing with the band. Pretty loud for the size. So far very happy with it, no complaints.

Share this post


Link to post
Share on other sites

Dont waste your time and money if you want bluetooth connectivity. They still have not got a fix for the cutting off problem in 2019, years after first release. As soon as the first memory banks are full, the problem will start and the only way to fix it by resetting the amp. If Line 6 has not got the interest to fix the issue they should at least make the code public so someone can fix it.

Share this post


Link to post
Share on other sites

If I had done a little more research I would have saved my money. I just bought the Amplifi 75. They don't work with Android so now I got to buy an iPad to make it work. POS.

 

Share this post


Link to post
Share on other sites
8 hours ago, rowdync said:

If I had done a little more research I would have saved my money. I just bought the Amplifi 75. They don't work with Android so now I got to buy an iPad to make it work. POS.

 

 

The AMPLIFi 75 should work with Android. Is the app not working on your device?

Share this post


Link to post
Share on other sites

I would question what prompted you to conclude that it 'doesn't work with Android.' ??

 

I have an Amplifi 30 and an Amplifi 150. They both work with the remote app on my Android phone, which is a 4-year old Nexus 6, and with my 6th generation 9.7" iPad.

 

I also use them with a laptop, using the computer's built-in Bluetooth to play backing tracks on the amps. I have no problems with Bluetooth disconnections. 

 

I have other doubts about the Amplifi series, notably the frequent difficulties that can arise out of updating the firmware, but that's probably a moot point, because we're not likely to see any firmware updates, anyway...

Share this post


Link to post
Share on other sites

Not happy at all. Extreme buyers remorse; should have followed my gut and not bought this thing. Except: when it's working right, I love it!

 

I purchased the Amplifi 150 a little over a month ago and immediately realized that it was a huge pain in the butt without a foot controller. I spent another couple hundred for an FBV3.

Had fun with it. The setup sounds great for my amateur, bedroom playing self. Bluetooth was buggy and annoying, but not that big of a deal. As a concept, it's great. If it works, it's actually not a bad value. BUT....

 

After about 2 months of very light occasional use, it just stopped working a couple of days ago.

 
I turn the amp on, and it goes through its startup routine, and then turns off. Usually, after several quick on/off cycles, it will stay on.
 
The sound it produces  is horrible. It is only playing the wet part of the signal. If I go to the tone edit page on the iPhone and turn off all the effects, or do the same thing with the FBV3, effectively running it straight through an amp and cabinet, it does not produce any sound.
 
I just started the remediation process with Sweetwater today, so we'll see where all of this ends up.

Share this post


Link to post
Share on other sites
On 10/5/2019 at 10:20 AM, cchristo said:

I just started the remediation process with Sweetwater today, so we'll see where all of this ends up.

 

Sounds like you may have purchased a *New* device, which is good -- much easier to arrive at a satisfactory conclusion with new equipment.

 

And it's also good that you're calmly initiating this with Sweetwater, whom I've found to be very reputable and accommodating. Line 6 would also cover you under warranty, but going through Sweetwater will probably afford you more flexibility, especially if your choice is to run away to something that may be less technologically-engaging, but more reliable than the Amplifi series.

 

Good luck!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...