Jump to content

pinoy1

Members
  • Content Count

    52
  • Joined

  • Last visited

Everything posted by pinoy1

  1. Sorry for the late response @PierM. First, I would like to apologize for using the wrong word (immolation). I have no idea where that came from, but thanks for correcting me! But I just figured out the issue (or what I thought was an issue) with my backing track. It's definitely NOT a bug in Powercab or Helix after the new updates. What I needed to do was simply choose from my computer's sound configuration to use the Powercab plus as the computer's speaker NOT the Helix. So the sound of the backing track when I play it from my PC will not be affected by any of the speaker simulation I choose from my Helix or directly from the Powercab. Thanks for your response again!
  2. Hello folks, I don't know if this is a bug or intended for ver2.0 in Powercab. Before the new update, when I use my PowerCab + with backing tracking, the backing tracking sound was NOT affected when I'm in 'Speaker' mode. Meaning, the backing tracking sound is clear and NOT muffled whether I'm using any of the speaker immolation. Now, after the update, the sound of my backing tracking sounds like muffled when I'm on speaker immolation. Basically, it is using whatever speaker immolation eq I selected. My set up: Guitar -> Helix -> PowerCab (via digital cable) and computer via usb -> Powercab. Please advise. Thanks!
  3. Great job man! I'm a huge Metallica fan and I will definitely include these on my presets collection. Thank you for sharing! And keep on sharing :)
  4. Anyone else excited for this? Saw this from TGP, a quote from phil_m... "So about the alleged HX reverbs... I can finally say they’re real and they’re spectacular! I think I will be saying goodbye to the BigSky very soon..."
  5. I was reading up some comments on TGP and some people are claiming that those 'squirrels/harsh-top-end fizz/artifact' sound is no longer there??? What do you think guys? Is that issue now consider dead (if there was an issue to begin with)?
  6. pinoy1

    Helix 2.3 tips

    LOL... This is got to be the easiest update ever!!! I have not even played around with the new amps and effects but I feel like I owe it to the men and women responsible on bringing this new Helix Editor to life. I am a developer myself and I can appreciate a good software when I see one. The create backup and restore backup capabilities alone is enough for admissions ladies and gents! The GUI is very responsive and the redesign is intuitive! I have not even used the other editors from the competition, heck one of them does not even have one, but I'm willing to bet that this Helix Editor will kick their @$$! Kudos to the whole team. Whoever you are. Big Thank You!!! Now back to playing... :D
  7. @saks Man, I know that feeling. Don't worry, it's worth the wait. I'm jealous, I've been wanting to get another one so I could run a full stereo. Maybe, I should shoot Mick an email.
  8. @glideman Wow! That's a lot of good options to have. I have the Xitone 1x12 passive cab powered by Matrix GT1000FX and it sounds incredible. This Mbritt cab is very tempting.
  9. pinoy1

    Litigator Heaven

    I got a different result compared to yours. I tried using the cab model and it sounded dull to my ears. Didn't like it at all. I like it with the cab model off way better. Thanks again for the feedback. Keep us posted.
  10. pinoy1

    Litigator Heaven

    Thanks for the quick response spikey! I'm also curious to hear your experience with the "amp" only mode. Please keep us posted.
  11. pinoy1

    Litigator Heaven

    spikey, I'm a little confuse, with your set up Helix -> Fryette PS 2 -> 2x12 V30's cab and using Ligator + cab model. Wouldn't the cab model in the Helix color your tone since you are using a 2x12 V30's cab? I'm not too familiar with Fryette PS 2 and I thought when going into a power amp that one should turn off the cab model in the Helix. Is the Fryette PS 2 different than any other power amp (i.e. Matrix GT1000fx) out there? I asked because when I use my Matrix GT1000fx into my Xitione Cab in a full-on guitar cab mode, I would turn off the cab model in Helix and turn it on when a switch my Xitone cab in a full-on FRFR speaker. I appreciate any feedback from this.
  12. @timster666 -- Thanks for the response. Please report back if you see any patter or solution. Thanks.
  13. @ duncann - "I'd probably start with a factory reset, as rvroberts suggests, after backing up any presets/setlists." -- I will definitely do that. Thanks for the response.
  14. @duncann, I'm not sure if I'm understanding your question correctly, but here are my set up: 1. Helix rack --> a pair of KRK Rockit 5. The left channel is through XLR out and 1/4 out for the right channel. 2. Helix rack --> Matrix GT1000FX (power amp) --> Xitone cab (1 x12 FRFR). I'm using the Helix right XLR out on this. I'm experiencing the issue in both setups. Thanks.
  15. @timster666 Where you experiencing this before the Fremen presets? And are you also using a rack unit? "At least you are not alone pinoy1 :-)" -- glad to hear that I'm not alone. :) Thanks. Thanks.
  16. "Does this happen if you build your own patch using only Line 6 suff (no imported IRs)?" -- Not that I could think of. But it could be a coincidence for now. Need to do more experimentation. "A factory reset (after a full backup) would be worth trying." -- I'll definitely do this later. For now, I want to figure out if there's some pattern that I can detect. "Lets hope its the first one!" --- I hope so too. :)
  17. Hey guys, I've been experiencing this I what I call a "dead-silence" Helix situation ever since I got rack the unit. Basically, while in the middle of playing, the sound will just cutoff. No sound, just complete silence coming out my monitors or xtone cab. All buttons in the unit are still functioning and also in the editor. The only way I can get the sound back is to change to another preset. What annoys me the most is that it happens so randomly. The only consistency that I noticed, and this might just be a coincidence, is that it seem to happen when I'm using an imported preset. It's worst right now since I bought the Fremen package last week. Before, it will only happen maybe once in a while but it's been very frequent since using the Fremen presets. Anyone else having a similar experience? I don't know if this is a software bug or a defect on the unit. Any thoughts will be appreciated. Thanks.
  18. Got these presets last night and so far I'm liking it a lot! I'm a casual player and really don't have a lot of time building my own presets, and this helps me enjoy my Helix even more. Although I also enjoy the process of building my own patch from scratch, having a quality-made presets at my disposal is a luxury that I like to have.
  19. Thanks for sharing chuskey! I'm fairly new with Helix and this video helps a lot! Great stuff!!!
  20. Congratulation on your new Helix! I'm also a HD500 user and just ordered my Helix yesterday. Here's hoping for many years of fun with the Helix!
  21. pinoy1

    Just ordered a Helix!

    LOL! My wife would love to have a bedroom like that!
  22. pinoy1

    Just ordered a Helix!

    "you'll have your work cut out for you if you want to evaluate all aspects of the Helix within 30 days." I agree, it's a small window to fully evaluate the Helix but hopefully that's enough for me to decide whether to keep it or not. Honestly, I have to be really disappointed to even go to the Kemper route. " I'd highly recommend using separate amp and cab blocks as that will give you the opportunity to so a split between the amp and cab so you can use a second cab block (or IR block) in your mix. " Really looking forward on trying this! Anyway, thanks for the advice DunedInDragon!
  23. Thanks for sharing, amsdenj! I'll try them when I get my Helix next month.
×
×
  • Create New...