Jump to content
talonmm

I don't work for Line 6, but you need to go buy a dt amp if you use Helix

Recommended Posts

I started a thread a few days ago on the forum area under the helix forum.

 

My dt amp did not seem to be integrating well with the helix as it should have after the 2.8 update.

 

Turns out I needed to purchase a special usb midi cable, and I probably was not using the correct L6 link cable (I probably just grabbed an xlr cable from my closet).  Through various posts in that forum I corrected my errors and finally got my helix and dt amp to work.

 

I was astonished last evening how great the dt amps I have sounded with the helix.  Here is my post in the other forum.  I wanted to come over to this forum area and share my experience, since I don't see much writing here about integrating the dt amps with the helix update:

 

Here is what I wrote...


My M audio cable finally arrived and worked like a charm!  I actually have 3 dt amps - a dt25 1x12, a dt50 head, and a dt50 2x12 (all purchased used a few years ago, cheaply when the pods died out and demand was quite low for these amps).


Much to my surprise 2 of the 3 had the latest update, the head did  not.  Monkey did a great job, although one time I had to reseed the usb plug in the computer to get Monkey and the amp communicating.


All three amps sounded inedible.  I want to stress that anyone who has not tried a dt amp with a helix will be blown away.  I have not tried the new line 6 powered speakers, but the difference between the amps and my stagesource (also bought used) is night and day.


There have been endless debates about amps in the room and powered speakers, but my helix never sounded better than last night with the dt amps!  And man, no matter what tones I chose on the helix and sent to the amps, they sounded alive, magnificent, loud as hell, and definitely like a killer amp in the room.  Yes, I was blown away.


Looks like the helix and dt amps only work in channel A. Other than master volume on the amp, no other controls change the tone when using the L6 link cable directly from the helix to the amps (a good thing as the helix took full control and made everything sound superb).


Thanks everyone for the advice and help!

 

 

 

Share this post


Link to post
Share on other sites

 It’s so ridiculously good!

 

 I was able to get this functionality two months ago when I first got the helix thanks to another member who taught me basic MIDI. 

 

 All the musicians in my town were hounding me to play through my rig. I finally had to put the Kabash on it LOL 

 

 Dialing in sounds was never this easy with the HD 500.  Truly a dream rig. 

 

 Although I have the added stress of wondering if my amps Will have the dreaded power transformer failure… For the third time. 

 

....but for the last year of steady use of my DTs...so far so good. 

 

Congrats. 

Share this post


Link to post
Share on other sites

is it possible to change topology / class / pentode triode and save in the preset like with POD HD series ?? do you use speaker cabinets in the helix modeling? i'm still using the old dream rig :  JTV + hd500 + DT50 .....With a torpedo cab in the fx loop of the POD, I can compensate using IRS + post eq to get an amazing sound in my amp. I know that IRS are supposed to be used with FRFR speakers, but with the help of post eq in Torpedo C.A.B, I can get rid of that extra boominess and obtain a very good polished but warm sound. 

Share this post


Link to post
Share on other sites

 

10 minutes ago, hichembell said:

is it possible to change topology / class / pentode triode and save in the preset like with POD HD series ?? do you use speaker cabinets in the helix modeling? i'm still using the old dream rig :  JTV + hd500 + DT50 .....With a torpedo cab in the fx loop of the POD, I can compensate using IRS + post eq to get an amazing sound in my amp. I know that IRS are supposed to be used with FRFR speakers, but with the help of post eq in Torpedo C.A.B, I can get rid of that extra boominess and obtain a very good polished but warm sound. 

 

I am such a novice with these things - I really just like "plug and play". 

 

But if you venture over to the helix forum and my original post, someone put a hx-edit screen shot of the new individual options you can make to your DT amp with the 2.8 update.  I believe, the options you are looking for have just been added.

 

The Pod hd 500 series sounded great with DT amps, but PDKTDK hit the nail on the head - Helix and dt amps are dream rigs, and I feel a substantially better sound than the jd 500 line.

 

If you have a helix, get those used dt amps before demand (and prices) rise!

 

If you have a dt amp and no helix, get one.

 

PS - I also love the stomp, too bad the stomp does not have an l6 port!

 

 

Share this post


Link to post
Share on other sites

Those DT amps make anything sound better...Hope I won't get a transformer problem for a second time like some other unfortunate users  

  • Upvote 1

Share this post


Link to post
Share on other sites
30 minutes ago, talonmm said:

[...]

If you have a helix, get those used dt amps before demand (and prices) rise!

 

If you have a dt amp and no helix, get one.

[...]

Yep, and make your dreamrig complete with a Variax ;-)

Share this post


Link to post
Share on other sites
4 hours ago, klangmaler said:

Yep, and make your dreamrig complete with a Variax ;-)

 

Line 6 certainly have had their successes - but also a lot of disasters (amplifi and Variax come to mind)

 

I have a Variax with the dreaded low E plink string.

 

I heard the helix firmware update gave some new options for Variax users.  Has anyone been able to add volume to their low E string or change any parameters with the new firmware to improve this problem that Line 6 admitted they don't know how to fix?

 

 

Share this post


Link to post
Share on other sites
1 hour ago, hichembell said:

is it possible to change topology / class / pentode triode and save in the preset like with POD HD series ?? do you use speaker cabinets in the helix modeling? i'm still using the old dream rig :  JTV + hd500 + DT50 .....With a torpedo cab in the fx loop of the POD, I can compensate using IRS + post eq to get an amazing sound in my amp. I know that IRS are supposed to be used with FRFR speakers, but with the help of post eq in Torpedo C.A.B, I can get rid of that extra boominess and obtain a very good polished but warm sound. 

 

Yes, it's possible to change all those power amp parameters in the Helix preset (or per snapshot). You can also assign them to controllers if you want. As far as cab modeling, generally you'd want to not use it in the Helix with the DT amps, but you can experiment, I suppose.

Share this post


Link to post
Share on other sites
14 minutes ago, talonmm said:

 

Line 6 certinally have had their successes - but also a lot of disasters (amplifi and Variax come to mind) 

 

I have a Variax with the dreaded low E plunk string.

 

I heard the helix firmware update gave some new options for Variax users.  Has anyone been able to add volume to their low E string or change any parameters with the new firmware to improve this problem that Line 6 admitted they don't know how to fix?

 

 

 

I don't think Line 6 considers either of those lines disasters... I mean, the AMPLIFi is still being sold, and the Variax has done pretty well. As far as the piezo plink, that's something that exists, and is something that's a difficult problem, and I don't think there was ever going to be an easy fix. Some players' style seem to make it more of issue for them than others.

  • Like 1

Share this post


Link to post
Share on other sites

The Ampli

44 minutes ago, phil_m said:

 

I don't think Line 6 considers either of those lines disasters... I mean, the AMPLIFi is still being sold, and the Variax has done pretty well. As far as the piezo plink, that's something that exists, and is something that's a difficult problem, and I don't think there was ever going to be an easy fix. Some players' style seem to make it more of issue for them than others.

 

Reading posts in the Amplifi area, it appears Line 6 has abandoned support and the amps they produced.  There are some line 6 items like the amplifi amps, the g10 wireless (prior to the new g10s) that had design issues that were never corrected.  On the variax front, some players found ways to fix their guitars, many didn't.  and why would their style make the low e string not work, but allow the a string and the four others to work ok?

 

 

Share this post


Link to post
Share on other sites
39 minutes ago, talonmm said:

Reading posts in the Amplifi area, it appears Line 6 has abandoned support and the amps they produced.  There are some line 6 items like the amplifi amps, the g10 wireless (prior to the new g10s) that had design issues that were never corrected.  On the variax front, some players found ways to fix their guitars, many didn't.  and why would their style make the low e string not work, but allow the a string and the four others to work ok.

 

Abandoned support in what way? In the sense that there hasn't been a firmware update for a while? I don't know how many firmware updates should be expected for a line like the AMPLIFi. It's hard to gauge how many people have problems with the line just from that forum because it's a pretty slow forum overall. The fact that Line 6 is still selling the amps says something about the line though... If it wasn't making money for them because of warranty claims and/or returns, they'd discontinue it.

 

As far as the G10, Line 6 did actually reinforce the micro USB jack on the production line. Again, I have no idea how common the failure actually was. Things such as that have a tendency to get amplified online. I've had my G10 for over three years and still use it all the time, and I've not any issues with it.

 

I don't know all the specific issues people have posted in regards to the Variax, as I haven't followed those threads all that closely. It still seems to me to be something that's not affecting everyone, at least not in the same way.

 

Honestly, I've been on these boards for quite a long time now, and if I believed all the dire sounding posts people up here, I would think Line 6 is doing much worse than they are. You kind of have to let some negative posts roll off your back because it's just par for the course for the internet. Negativity has more of an impact than positive posts.

Share this post


Link to post
Share on other sites
58 minutes ago, talonmm said:

....

Reading posts in the Amplifi area, it appears Line 6 has abandoned support and the amps they produced.  ....

 

 

 

19 minutes ago, phil_m said:

 

.... You kind of have to let some negative posts roll off your back because it's just par for the course for the internet. Negativity has more of an impact than positive posts.

 

In this context it's also important to remember that his is a support forum. Users come here mostly to report and get help for problems they are having. Fully satisfied customers don't generally come here. So it's not surprising to see a lot of problems being discussed here; that's exactly what this space is for.

Share this post


Link to post
Share on other sites
6 minutes ago, silverhead said:

 

 

In this context it's also important to remember that his is a support forum. Users come here mostly to report and get help for problems they are having. Fully satisfied customers don't generally come here. So it's not surprising to see a lot of problems being discussed here; that's exactly what this space is for.

 

I agree.  However, it was mentioned that line 6 is still promoting the ampli line.  if you check out the amplifi area (an update has not been provided by line 6 in years, there have been posts that parts are not available for the amplifi models anymore, and there is no support for the models)... here is the link: 

 

 

 

 

 

Share this post


Link to post
Share on other sites
15 minutes ago, talonmm said:

 

I agree.  However, it was mentioned that line 6 is still promoting the ampli line.  if you check out the amplifi area (an update has not been provided by line 6 in years, there have been posts that parts are not available for the amplifi models anymore, and there is no support for the models)... here is the link: 

 

 

 

 

 

 

Line 6 generally doesn't sell most parts directly to customers. I know Full Compass stocks some parts for some things. But service centers can still work on the AMPLIFi series. If Line 6 is still making and selling them, they're still fixing them.

Share this post


Link to post
Share on other sites

I agree - the Amplifi series has not received an update for a long time which suggests it is longer being actively developed. However it is still supported. I don't know what the post you quoted means by 'immediate' support but if you contact Customer Support you will get support. I also don't know about the time lag for parts availability but it is still being manufactured and sold so parts are available; Line 6 support can direct you.

 

I don't plan to argue with you about whether or not I would be happy if I owned an Amplifi (I don't). If I bought it for what it can do today I would probably be happy since it still does that. If I bought it expecting a series of updates over the next several years I would probably not be happy. But that says more about my expectations than Line 6 support.

 

 

Share this post


Link to post
Share on other sites

I don't want to appear too harsh on line 6.  I love many of their products.

 

Hopefully the people who have purchased amlifi amps have found a way to get them repaired.  It's good to know Line 6  has not abandoned them.

 

I had purchased a used HD50 2x12 amp and it never stopped working, but it turned out to have been built with one of those bad power supplies.  Although used, Line 6 honored the original warranty and switched out the part(s) for no charge. 

 

No one is perfect and they have had some misses in their history and some big hits.  I really like Line 6 company and many of their innovative products.

 

 

 

 

Share this post


Link to post
Share on other sites
23 minutes ago, talonmm said:

[...] amlifi amps [...] HD50 2x12 amp [...]

No one is perfect

Right ;-)

For the JTV (although this is really getting offtopic) check out these tips:

https://www.youtube.com/watch?v=bJhdSczB-lI

And you were talking about the JTV's, not about (all) Variaxes, right?

Share this post


Link to post
Share on other sites
1 hour ago, klangmaler said:

Right ;-)

For the JTV (although this is really getting offtopic) check out these tips:

https://www.youtube.com/watch?v=bJhdSczB-lI

And you were talking about the JTV's, not about (all) Variaxes, right?

 

My plank issue was with a JTF-89F guitar.  Great guitar - I still can use it with the conventional pickups.

 

I believe the plinking issue happens across most (if not all the newer models). 

 

Many have said some guitars never get the low e string plink, and some do, but no one is sure why.

 

I have a friend that's a guitar tech and he tried to repair my variax (even getting parts from Line 6), to no avail.  I have tried cleaning various things and put thicker strings (thicker strings worked for some).  Nothing helped.

 

Many other people found no fix and if you visit that part of the forum, it has been acknowledged that Line 6 has admitted they don't know how to fix this problem.

 

 

Share this post


Link to post
Share on other sites

Please - give me  a link to "that part of the forum". I'm really curious who said so -

and when "Line 6 has admitted they don't know how to fix this problem"...

Share this post


Link to post
Share on other sites

 I should’ve traded up to that helix years ago. 

 

 If you are using your DT 50/25 in conjunction with the HD 500 X, You will only gain. 

 

You lose nothing. That’s the bottom line. 

 

 The answer to all of the questions is a resounding “yes you can!”.   

 

The learning curve for the helix is a couple of hours coming from the HD 500 series. 

 

Its only a win situation and as I said somewhere here in the last 2 months as a new helix owner...I haven’t seen anyone sell their helix and go back to an HD series. 

 

 The tone behind my words is joyous rapture.

 

 Upgrade folks!… And let’s start sharing presets!

 

 The XLR out to front of the house is great too in my opinion. No complaints there either. 

Share this post


Link to post
Share on other sites
On 7/26/2019 at 10:40 AM, klangmaler said:

Please - give me  a link to "that part of the forum". I'm really curious who said so -

and when "Line 6 has admitted they don't know how to fix this problem"...

 

I wish I could give you a specific link, but I don't have the time to search for it.  Go to the variax section of the line 6 forums and search the first few pages (sorted by most recent).

 

You are looking for a subject titled something like "plink" or "plinnking" or "low e string problems".  The giveaway will be that there are many many more responses to that post than any others.  That post was started a very long time ago.  go to the last few pages of the post (the most recent activity) and you will see some specific mentions where the variax community either stated, or proved that Line 6 does not know how to fix the problem.

 

If line 6  knows how to fix the problem, then why are so many people still unable to get their low e string to work after trying so many different remedies and replacement of parts?

 

Share this post


Link to post
Share on other sites
6 hours ago, talonmm said:

I wish I could give you a specific link, but I don't have the time to search for it. [...]

 

I see.

 

(But I was following these threads long time ago, fortunately ;-) )

 

6 hours ago, talonmm said:

If line 6  knows how to fix the problem, then why are so many people still unable to get their low e string to work after trying so many different remedies and replacement of parts?

 

Many people were able to fix this. I was able to fix this (irritating noise), too.

The piezo Pu's, the bridge (esp. of the JTV) can be somewhat tricky - in combination with the very sophisticated possibilities of Workbench HD. When you are the proud owner of a high-tech guitar, it can sometimes be a little more complicated to find a solution to a seemingly small problem.

Anyway, for some folks and their JTV a simple reflash of the firmware did it, for example.

 

And we and should transfer the topic to the appropriate threads now, I guess:

https://line6.com/support/forum/37-variax-instruments/

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×