Jump to content
Phil_GMC

Helix acting as soundcard but not set as soundcard

Recommended Posts

Hello folks,
I hope you can help. I've just swapped my ageing Scarlett 18i8 1st Gen for a 2nd gen one. The old Mix Control is now Focusrite Control and very different.

For some reason my Helix volume knob now controls the volume of everything (PC, DAW, Guitar) and so does the Scarlett. This is a pain because when I'm recording into my DAW and I want to up the guitar level with the Helix volume knob it alters the DAW volume too.

I'm using Reaper. Helix used to only control my guitar volume. Any ideas? Thanks in advance.

Share this post


Link to post
Share on other sites

When you have Reaper open make sure it is using the ASIO device you want. Make sure your new Scarlet is selected. That would be where I start.

 

Do not rely on your old hardware's drivers/utilities. Download/install the newest ones for your new unit.

Share this post


Link to post
Share on other sites

This is impossible. Helix Volume Knob is analog attenuator for a chosen Helix outputs. No way it can control anything on any other device than Helix.
Using two interfaces at once can be confusing. Please consider to use one.

Edited by zolko60
confusing is better word than frustrating

Share this post


Link to post
Share on other sites

If you're using your Helix as an interface for recording (or the Scarlet) your computer is treating that as it's soundcard (as it is right now, anyways) and the output level of the master volume control will raise or lower the level over EVERYTHING playing back through the Helix, including the playback from Reaper. The scarlet would function the same way without changing any settings (and that's how most soundcards work). If you have the analog outputs of the Helix connected to the Scarlet, turning up the guitar master volume will change the level going into Reaper, and may clip your inputs on the Scarlet. All of this is expected behavior. I'm not familiar with the Focusrite Software, but I would assume you can route/setup monitor mixes just like you would with a normal mixer, so you'd have to go into that software, and adjust the Helix levels to whichever output its is connected to. I would agree with Zolko, though. Pick one interface at a time to use, and make sure you have the proper settings in Reaper assigned.

Share this post


Link to post
Share on other sites

The combination of the DAW and the Focusrite mixer can be confusing.

 

IF your speakers are connected to the Focusrite Outputs 1 and 2, AND Reaper Master is set to Output 1/2, AND you've got the Helix 1/4" outs connected to the Scarlett Inputs 1/2 with Helix Big Knob set to 1/4", connect the XLRs to Input 3 and 4. Set Reaper to RECORD 3 and 4.

 

The FR mixer, with Monitor Outputs 1-2 Stereo selected, should have Analog/Hardware Inputs 1-2 and Software Playback 1-2 showing.

 

With the Helix Track Monitor Switch set to OFF and Record ON, when you press PLAY you can jam along to whatever has been recorded, and hear the Helix direct, no latency. The BIG Knob controls the Helix Output. 

 

When you press RECORD the Helix Track will record from Inputs 3 and 4. Since the BIG Knob is controlling the 1/4" Outs, the XLRs send at 0db, Big knob has no effect on the RECORD level.

 

When you play back the recording, the Reaper Slider controls the Output. The FR Mixer Output slider controls the final Output level, but has no effect on Reaper.

 

There may be other ways to go about this, but this is the easiest method that I've found.

Share this post


Link to post
Share on other sites

Thanks folks, I'll check it out letter on today. Where is the Helix track Monitor switch? 

 

Zolko60, I'm sorry but mine controls everything, pc sounds, youtube videos, daw etc. Helix can be used exclusively as a soundcard but it just doesn't suit how I work. 

 

To clarify how I use it. Helix LT is on the floor under the desk so for normal computer use it's easier to adjust volumes with the Scarlett which is on a shelf at eye level, I also have my headphones plugged into the Scarlett which has independent volume control for them. I leave them plugged in permanently and just hit the me button when I want to use phones. 

 

Studio monitors are connected to rear  of Scarlett. 

 

I have Helix XLR left and right direct into front of Scarlett 1 & 2 this allows direct monitoring of guitar with zero latency and also just playing guitar if I don't want to boot the PC up. I use stereo effects so like to leave the gain knobs at 12 o clock and adjust using the Helix vol. It's a ball ache having to adjust two knobs which I'm having to do now. 

 

I record in Reaper using Helix USB which makes wet and dry recording ready and also re-amping. 

 

It must be the Focusrite control but it's a little confusing, to me anyway. I say this because it was OK with the 1st gen Mix Control and the Helix vol only controlled the output of the Helix. 

 

I am using the new drivers and software. 

 

Maybe I'm doing it all wrong, I have routing dyslexia, you should have seen me connecting up a video recorder AND a Sky box to my TV years ago, total discombobulation. 

Cheers

 

 

 

Share this post


Link to post
Share on other sites

I suspect this is due to your computer choosing to make the Helix it's sound card when the Helix is turned on since it's connected via USB.  Obviously the Helix won't have this behavior when it's turned off, so it's likely something in the configuration of your computer's sound devices.

Share this post


Link to post
Share on other sites

The sound properties of the computer are set to use the Scarlett for input and output. I've had the 1st gen Scarlett for years and all I've done is swap the Scarlett and installed the drivers and new control software. 

Share this post


Link to post
Share on other sites
1 hour ago, Phil_GMC said:

Zolko60, I'm sorry but mine controls everything, pc sounds, youtube videos, daw etc.

Can you demonstrate it somehow?
Make a video when you twist Hx volume knob and yt video volume slider, daw master moving?

Share this post


Link to post
Share on other sites

If you're recording using Helix USB, then the Helix is your sound card. Reaper can only use one sound card at a time, so it's output is going to the Helix. Take the XLR or 1/4" outputs to the Scarlett inputs 1-2. Set the Big Knob to whichever outputs (XLR and/or 1/4") and turn it all the way up. That's Unity.

 

Setup the Scarlett mixer sw so that Output Monitor 1-2 is showing Hardware Inputs 1-2 and Software Playback 1-2. Set your headphone monitor the same.

 

In Windows, set the Scarlett as the default recording and playback device. This way Youtube and other streaming stuff will go to the Scarlett, and will be mixed with the Helix.

 

In Reaper, set the Audio device to Helix, First Input 1, Last Input 8. Set Outputs to 1 and 2.

 

I changed my configuration to test it. It works. Unless I'm missing something (it's 4am), that should get it for you.

Share this post


Link to post
Share on other sites

Thanks rd2rk, I'll check it out. I appreciate your time. Something obviously changed itself when I booted with the new device. With the old device Helix only altered the output of the Helix. 

 

Zolko60, I can do yes but the on screen sliders don't move in the same way they don't move when I turn the book knob on the Scarlett. They act like a master volume between computer and speakers. 

 

Cheers

 

Phil

Share this post


Link to post
Share on other sites

In the Scarlett mixer, leave the sliders at default. You can turn the physical input level knobs all the way down, only turn them up if the master knob isn't giving you enough.

Don't forget, in Reaper, on the Helix channel, set the input monitor switch to OFF or you'll get an echo.

Share this post


Link to post
Share on other sites

Well how did this happen????? I've switched on tonight and before I made any changes I set my video camera up to show Zolko60 what was happening. I didn't do it, Helix is now only controlling the guitar output level, just as it was before.

 

I'm so confused. Sorry Zolko, if it happens again I'll post a video. I feel like I've wasted everyone's time now but it was happening. What could have happened to make it revert to how it was before?

 

I'm confused.

 

Cheers

 

Phil

Share this post


Link to post
Share on other sites
1 hour ago, Phil_GMC said:

I'm confused 

 

Join the club. I've been confused for 44 years...;). But if it's working now, then it's working...run with it. Don't poke the bear.

Share this post


Link to post
Share on other sites

Well, switched on tonight and it's doing it again. Now I need to try and work out rd2rk's settings. I went to YouTube first to do a video for Zolko60 but it wouldn't play, it said "Audio rendering error, please restart computer". I switched Reaper off and it played it fine and Helix didn't control the volume.

 

When using my DAW, if I just play a track, the halos on Scarlett 1/2 light up so somehow the DAW is getting sent to the Helix and back into the Scarlett. I have my computer soundcard set to Scarlett playback and record.

 

Why does it keep on changing?????

 

On another note, with my old 1st Gen Scarlett, I've recorded via Helix usb and a mic plugged into the Scarlett at the same time, if I switch on the Scarlett in Reaper and select inputs I don't get anything like what I got before. I used to get USB1, USB2 etc, now I get fniusbwave_48 1, fniusbwave_48 2, fniusbwave_48 3 etc.

 

Cheers

 

Phil

 

UPDATE:

I tired rd2rk's settings but couldn't fully follow them, it's probably a terminology thing, ie, me not understanding rather than him not explaining.

 

UPDATE 2:

I vaguely remember this happening once on my old unit but I can't remember what I did to fix it. Unless it corrected itself.

 

Update 3: 

I just did another reboot, I could run Reaper, my guitar, and YouTube all at once but YouTube was coming from my laptop speakers, it gave no audio rendering error message. 

 

 

 

Share this post


Link to post
Share on other sites

It sure would be helpful if you could post a screenshotof the Sound Panel.

 

If the Scarlett is connected to the laptop by USB, you should be able to make it the DEFAULT DEVICE in the Windows Sound Panel. That will send YouTube to the Scarlett.

 

If your XLRs are connected from Helix to Scarlett 1 and 2, attached is a screenshot of what Focusrite Control (the Scarlett mixer) should look like. Obviously, MUTE should be OFF if you want to hear anything.....

 

Also, on the Device Settings tab, be sure that the sample rate matches the Helix and what you've set in Reaper.

Share this post


Link to post
Share on other sites

Thank you, not going to get much time in the next couple of days but I'll get back to you. 

There isn't an attachment by the way. 

Cheers

Share this post


Link to post
Share on other sites
7 hours ago, Phil_GMC said:

Thank you, not going to get much time in the next couple of days but I'll get back to you. 

There isn't an attachment by the way. 

Cheers

 

One more complaint about this horrible new forum software - any screenshot worth looking at is bigger than 102.4kb!

 

Merry Christmas!

Share this post


Link to post
Share on other sites

I wasn't complaining buddy. Just that I can't see an attachment.

 

More info. I managed to get the wife to have an extra glass of wine with dinner so she is asleep on the sofa now ;o)

 

The only thing that works is I HAVE to open Reaper with Helix off. I don't even have to press play, just open reaper before switching on Helix.
I wonder why I've not had to do this before? It is a workaround but I'd still prefer it how it was. It's a little bit of a ball ache because I can never run Guitar Pro with Reaper open so I'm going to have to keep on switching of Helix, as I said, it's underneath my desk, I just know I'm going to keep banging my head ;o)

 

I've just tried to record and it gives me problems in that I can't see the Helix in the ASIO panel so I can't record via USB. Not majorbut I do like to record a dry signal too sometimes. wink.gif

I've changed nothing in Helix, no recent updates so I'm wondering if it is more computer issue than Helix.

Cheers 

Playback.png

Recording.png

Share this post


Link to post
Share on other sites
1 hour ago, Phil_GMC said:

I wasn't complaining buddy. Just that I can't see an attachment.

 

MY complaint, not yours. THEN I go to the thread and YOUR screenshot  worked! AARGH!

Oh well, I'd rather have problems posting screenshots than using my system!

 

1 hour ago, Phil_GMC said:

The only thing that works is I HAVE to open Reaper with Helix off. I don't even have to press play, just open reaper before switching on Helix.
I wonder why I've not had to do this before? It is a workaround but I'd still prefer it how it was. It's a little bit of a ball ache because I can never run Guitar Pro with Reaper open so I'm going to have to keep on switching of Helix, as I said, it's underneath my desk, I just know I'm going to keep banging my head ;o)

 

I'm starting to think that your problem is gremlins...:-)

Apart from the basic computer hardware and OS (did you post that info? I might've missed it), I'm running all the same stuff as you, got no problems no matter how I configure it!

Are you sure you've got all the proper drivers installed? Helix v2.71? I forget if that installs the latest ASIO drivers

Does HX Edit (v2.71) work?

Have you tried connecting the speakers to the Helix?

Is all of this really worth it to have the Helix under the desk?

Just throwing  stuff at the wall here.......

 

Share this post


Link to post
Share on other sites

Thank you for your help buddy. 

 

I have two computers, I use a powered USB hub to share the Scarlett, Helix, keyboard and mouse. Both running Win10 Pro. The laptop is an Asus and the desktop is a self build. I use the laptop for my music because the desktop affects guitars with interference. I will try the desktop ASAP. 

Shame there isn't a program where you can save system info from one pc and then put the usb stick in the other one and it tell you where differences are. 

I have my Helix under my desk because I have to make videos for my mentor and the workshops over at www.guitarmasterclass.com I'm not a gigging musician, I sit down to play, I record with my video camera on the desk at hand along with my keyboard etc, it all helps for workflow and re-takes, It's not vital to have the Helix there, but it's out of the way and keeps things tidy.

I've worked this way for a long time, I'm not a good player but I enjoy what I do and I keep improving.

I had my other Scarlett for a couple of years, maybe more, always used it like this and I'm familiar with it that way.

Thanks again for your help.

Cheers

Phil

Share this post


Link to post
Share on other sites

They’re pretty specific about NOT putting the Helix thru a hub and, fwiw, I never put the Scarlett thru a hub either. Worth a try.

Share this post


Link to post
Share on other sites

I've had them both through the hub with no issue for over a year, well the Scarlett is new but it was another Scarlett before. This issue only just started happening. Do you still think it could be the hub? The hub goes to a switch to swap computers that I've also been using for a long time. 

Share this post


Link to post
Share on other sites

When troubleshooting complex systems, it's often useful to cut down to bare bones, and add variables from there.

You're getting strange and inconsistent results.

The manufacturer says "DON"T USE A HUB!"

A fellow user with a very similar system that has NO PROBLEMS says "DON"T USE A HUB!"

AND you're sending DATA thru a SWITCH?

 

Start by applying KISS theory.

  • Upvote 1

Share this post


Link to post
Share on other sites

I just tried the desktop with the hub and the result was the same. I've just hooked the Scarlett and the Helix to the laptop on dedicated usb ports. Exactly the same result, the DAW playback is somehow going through the Helix xlr ports and into the front of the Scarlett, I know this because the halos around the gain knobs are lighting up on the Scarlett. 

 

It must be something in this new Focusrite Control but I don't find it as intuitive as the last Mix Control PLUS I'm a routing numpty.

 

Not got any more time tonight to mess but any guidance left here will be much appreciated.

 

Thank you

 

Phil

 

Share this post


Link to post
Share on other sites

You're going to have to go into the WINDOWS audio menu and select the Scarlett as your audio playback device. For whatever reason your computers are both defaulting to the Helix as the playback device when everything is connected.l would honestly use one or the other for tracking stuff. Or unplug the Helix from USB when you're tracking through the Scarlet. You won't be able to use Edit, but at least you won't be fighting with hardware. The Focusrite software shouldn't have anything to do with how audio is routed to the Helix, either. 

Share this post


Link to post
Share on other sites

Thanks but there is a post few above this with screenshots of my audio control panel. Scarlett is set as default playback device. 

Share this post


Link to post
Share on other sites
29 minutes ago, Phil_GMC said:

DAW playback is somehow going through the Helix xlr ports and into the front of the Scarlett

 

AS LONG AS YOU USE THE HELIX AS YOUR ASIO IN YOUR DAW THE DAW PLAYBACK WILL COME THRU THE HELIX TO THE SCARLETT BECAUSE HELIX IS YOUR SOUNDCARD AND YOU CAN"T ROUTE THE DAW PLAYBACK DIRECT TO THE FOCUSRITE UNLESS THE FOCUSRITE IS THE SOUNDCARD IN THE DAW!!!!

 

Sorry to shout, but no matter how many times and ways I say this, you keep missing the point!

 

34 minutes ago, Phil_GMC said:

It must be something in this new Focusrite Control

 

In your configuration, the Scarlett is ONLY a MIXER! You can route streaming audio from the computer to the Scarlett by setting it as the default device in the Windows Sound Panel, in which case:

in the Focusrite Control you set Monitor 1-2/Software (DAW) playback to 1-2

 

And you can route any Scarlett Input to any Scarlett output

 

BUT YOU CAN"T SEND THE OUTPUT OF YOUR DAW DIRECT TO THE SCARLETT UNLESS THE SCARLETT IS SET IN YOUR DAW AS THE ASIO! Even though the Control SW CALLS it SOFTWARE (DAW) Playback, it only plays back from the DAW if the Scarlett is the ASIO in the DAW.

 

2 minutes ago, gunpointmetal said:

You're going to have to go into the WINDOWS audio menu and select the Scarlett as your audio playback device. For whatever reason your computers are both defaulting to the Helix as the playback device when everything is connected.l would honestly use one or the other for tracking stuff. Or unplug the Helix from USB when you're tracking through the Scarlet. You won't be able to use Edit, but at least you won't be fighting with hardware. The Focusrite software shouldn't have anything to do with how audio is routed to the Helix, either. 

 

You've already got the Scarlett set as the default device in Windows Sound Panel (per your screenshots). The reason the DAW is playing back thru the Helix is because you're using the Helix as your ASIO Soundcard in your DAW!

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites
1 minute ago, Phil_GMC said:

Thanks but there is a posta few above this with screenshots of my audio control panel. Scarlett is set as default playback device. 

And the Helix is your default Communications device, which means anything from a browser or media player is going to come out of that anyways unless you disconnect it, and for whatever reason (probably drivers) its taking over in Reaper (from your first post anyways), so you should probably just use one interface at a time for recording. 

Share this post


Link to post
Share on other sites
2 minutes ago, gunpointmetal said:

And the Helix is your default Communications device, which means anything from a browser or media player is going to come out of that anyways unless you disconnect it, and for whatever reason (probably drivers) its taking over in Reaper (from your first post anyways), so you should probably just use one interface at a time for recording. 

 

Actually, the Communications device is used by programs like Skype, even if he disables it, that won't fix his problem.

Share this post


Link to post
Share on other sites

All the problems would go away with ONE interface connected at a time. I can't see the benefit of having both connected unless you absolutely NEED to run Edit while you're recording, but that seems like an extra time sink for productivity to me, anyways.

Share this post


Link to post
Share on other sites

One thing I don't get is why OP is wasting a perfectly good 18i20 by using the Helix as his ASIO Soundcard.

Use the Scarlett as the ASIO Soundcard, get an A/B box to split the signal between Helix and Scarlett inputs (recommend an active vs passive)to get a clean track, OR, do what I do. I use a Relay G10 and send the 1/4" to the Helix and the XLR to the Scarlett. If re-amping is a requirement, get NATIVE!

 

2 minutes ago, gunpointmetal said:

All the problems would go away with ONE interface connected at a time. I can't see the benefit of having both connected unless you absolutely NEED to run Edit while you're recording, but that seems like an extra time sink for productivity to me, anyways.

 

His only problem is his insistence on using the Helix as his soundcard. With my setup, I get to use all of the Scarlett inputs (many more than Helix) AND use HX Edit AND re-amp, all at the same time with NO GRIEF EVER!!

  • Like 1

Share this post


Link to post
Share on other sites

Thanks, I do have Helix and Scarlett enabled in asio, I'm using asio4all. I haven't touched anything in reaper or at least I hadn't prior to this issue. I left it set as it was with my 1st gen and that's how it's been for over a year. That's what is so annoying. 

 

How else can I do it if I want to record over a backing in my daw? I've only every fumbled along on my own so I've got lost somewhere. 

 

Thanks

Share this post


Link to post
Share on other sites

I'm not insisting on using Helix as soundcard. I don't want to use Helix as soundcard. I've just sold a Radial Twin City AB Y splitter because I was getting exactly what I wanted before I went to the 2dnd gen Scarlett

Share this post


Link to post
Share on other sites

Throw away ASIO4All. The dedicated drivers for either device are going to infinitely more stable. Or at least DISABLE HELIX in the Asio4All menu. You only want the Scarlet as your soundcard, and Helix will talk to Edit without being used as the soundcard.

Share this post


Link to post
Share on other sites

 

Now you've introduced ASIO4ALL into the mix. Please re-read my post about the KISS method.

 

4 minutes ago, Phil_GMC said:

How else can I do it if I want to record over a backing in my daw? I've only every fumbled along on my own so I've got lost somewhere. 

 

 

Please re-read my post about using Scarlett as ASIO with a splitter or G10.  To use a backing track, send the track from the audio output of either your other computer or a smartphone to a pair of inputs on the Scarlett and take those to a track in Reaper. Piece o' cake, I do it all the time.

 

2 minutes ago, gunpointmetal said:

Throw away ASIO4All. The dedicated drivers for either device are going to infinitely more stable. Or at least DISABLE HELIX in the Asio4All menu. You only want the Scarlet as your soundcard, and Helix will talk to Edit without being used as the soundcard.

 

This too!

  • Like 1

Share this post


Link to post
Share on other sites

Here's another fun thing you can do with my setup:

 

Take an effected track from the Helix.

Take a clean track from the splitter (can't recommend the G10 highly enough!).

In Reaper, take your clean signal from the clean track to multiple tracks with amps/effects from multiple VSTs (I have used Native, Amplitube, Guitar Rig, BIAS FX, TH3 and S-Gear - if your computer has the CPU to handle it!), all over EZDrummer and a synth loop (that's getting crazy!). Switch amps at will on any and all tracks. When you find a combination you like, put slight (X ms) delays on some of the tracks. It'll sound like several PERFECT guitar players with different rigs all doubling the part. CRAZY THICK!

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×